Newbie here. 


Just purchased a ready-to-fly 3DR Hexa-C and installed drivers, downloaded and installed MissionPlanner-1.2.48 software.  Followed instructions to uploaded 2.9.1b firmware first before even thinking of selecting Connect button. 

Oh ya, I also verified correct Com Port, and bits per sec (115200) for both the com port and mission Planner.  The problem I see at or near the end of Read Hex File is a alert window "Communication Error-No Connection". 

At this point I have swapped USB cables 3x, uninstalled and installed  MissionPlanner-1.2.46, even uninstalled USB driver "Arduino Mega 2560" and installed arduino-1.0.4's driver.

Lastly, I opened the Mission Planner software and selected "Terminal" I observed "com port open" but was not able to send commands to module.

This was test on both my laptops (one I'm typing on is a Windows 7 laptop, the other was my Windows 8 laptop with driver signatures turned off.


What in the world am I doing wrong!  This should be this difficult.  Help!


Doug W.

Views: 19832

Replies to This Discussion

Have the same issue. Rather frustrating. Seems to be that either V2.72 arduplane or 1.2.48 planner is bugged. I can connect and see telemetry both with usb and  3dr modem easily though.

Thanks for the suggestion, I have ensured the COM port settings are correct in the device manager. I am able to connect correctly to the APM to see telementry data and the terminal connects via USB.
Any other suggestions? Cheers

I have same issue since APM Planner 1.2.48 and AC 2.9.1b.

Sometimes it is just "Connection Error - No Connection" and sometimes as on screenshot above.

Telemetry, configuration and Terminal working fine, firmware load is broken.

After much troubleshooting and endless evenings trying everything under the sun, such as reformatting the notebook and installing Windows 7 and uninstalling the older version of Mission Planner 1.2.48 and installing 1.2.50.  I still had no joy connecting to the APM 2.5.

Then I sat back and looked at the Hexa-C and noted that I had a stabilized camera platform with a gyro and a cable which was correctly connected to the Pitch Servo plug located on the bottom side of my copter.  So out of pure desperation, I decided to unplug it.  Low and behold!  The APM started talking to the notebook and Mission Planner.  At this point I do not believe the old version software was ever the issue.  It seems the Pitch Servo is possible pinned put incorrectly or the Turney TGY-90S is defective.

Attached are photos of the camera stabilzed platform and its servo cable connector.  

Where do I go from here with respect to connecting the stabilized platform to the APM?


I would try reconnecting it now that you have the APM and Mission Planner communicating.  Reading your thread reminded me of my experience.  I connected my Rx and all of my servos to the APM and couldn't get it to communicate so I removed everything and it started communicating.  Then reconnected servos etc and its been fine ever since.

I tried that. The moment I reconnected the connection, The output side Red & Blue LEDs went blank and connection between APM and Mission Planner failed.

Further investigation showed that the white wire (S) plug was connected to A11 while power and ground was pinned on Output 8.  When the white wire plug on A11 was removed, the red & blue LED started flash and I was able to reconnect to the mission planner.

Researching the APM, I wondered if A11 was suppose to be for Roll Servo, and I moved the plug over to A10 with no adverse effect.

Since I'm new to all this, I need some help and guidance on how to get the pitch servo to function when I fly the copter in stabilized mode.

Any help would be grateful. 


Doug W.

Update your APM to the newest version. I did and everything worked))

Hi there! I got my apm 2.5 board at yesterday, and when i tried to update firmware first time,  I had the same issue. Several hours and attempts after i found solution to my case. I have several com port because of some bluethoot moduls. After i disabled these com port and only the arduino 2560 port left in the device management, the update run succesfuly. after disabling other port the simple connect command was faster too.

Latest version is 1.2.50. I tried to install it as fresh install. Still don't work.

I have compiled code in Arduino IDE and flashed.

Thanks, I had the same problem!

I disabled all my ports, other than the one that i used for the transfer. It worked. 

The same thing that Peter Jobbagy said. 


My trick with bluetooth module and MP connection has been described here. Maybe the 3DR connection has the same issue. Just try to wait for the connection window of MP and THEN power up your 3DR. Hope it will help. Bertzilla


© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service