ArduPilot problem (Everything goes crazy). *Problem solved: bad Rx.*

Hi, I recently bought ArduPilot with an IMU and a shield for my EasyStar.

I have wired it up like the guide on the Google Code page showed.

 

When I turn it on to test it, I can move the plane an the control surfaces will counter move like they should in the stabilizing mode. And the MUX light turns on and off like it should.

 

But then suddenly, all lights on all the boards, including the receiver go completely crazy.

All servos stop dead for a couple of seconds before they go completely of the hook, even the elevator servo broke loose from the fuse ones.

The plane doesn't respond on any of the commands from the transmitter. I'm not even able to turn of the MUX, and even when the MUX-light turns off, the servos still behave like chikens without heads.

Sometimes it even throttles up.

 

The only thing that seems to help a bit is shutting off the transmitter, then it stops. But when I turn the transmitter on again, same problem.

This problem has also happened after the transmitter was turned off, but I only experienced this ones.

 

The only thing I can do to stop it, is pull out the battery and wait a couple of minutes. Put it in again after a few seconds doesn't help.

 

I have removed the shield and tried again without luck, I have checked the wiring, I have even twined the servo wires and tried to removed any possible interference but nothing seems to helps.

 

I have the newest code, but I don't think it is the code because stabilizing mode seems to work flawless until something triggers it to go wild.

 

I can't fly it in manual mode either, because when this problem suddenly kicks in, it even jams it in manual mode.

 

There is no radio interference that triggers this problem, of that I'm sure.

 

My Tx/Rx is a Hitec Optic 6 Sport with Hitec HFD-08RO (35 MHz) and I haven't had any problems with them before.

 

I haven't been able to fined any post about the same problem. I have found a few with the same symptoms, but never quit the same problem.

 

Hope somebody can help, thanks.

 

 

(Conclusion: If you don't bother to read this thread, this problem was caused by a bad Rx. After changing the Rx everything works fine.) 

Views: 708

Reply to This

Replies to This Discussion

I suddenly remembered that in my last two flights without ArduPilot, the plane would suddenly nosedive or do something weird before acting normal again.

At the time I thought some hard wind burst did this.

But now I suspect this also was a done by the broken voltage regulator.

 

Well, at least I have now ordered a TURNIGY Sentry 25amp Speed Controller so this problem should hopefully be eliminated.

Alright, now I have got the TURNIGY Sentry 25amp ESC. Testing it without ArduPilot everything seems fine. The motor even runs smoother with this ESC.

It delivers a steady 5V to the Rx.

 

But then I hooked up ArduPilot, checked if everything was alright and plugged in the battery.

BOOM, both servos get full power to one side, and just keeps going while grind of the teeth off the servo cogs.

Okay, so I quickly pulled out the battery, and with my servo cogs already ruined I tried ones more.

Same result, but this time also the throttle got jammed full open.

 

This happens immediately the plane gets power. The MUX is off, and the ESC hasn't even time to start properly.

 

I tried again without ArduPilot and everything works fine.

 

Now, in the manual it says «Input 1 should go to your receiver's Channel 1 (aileron)».

I don't understand why, so I put the input 1 into the rudder channel like I think it should be.

After some thinking time I tried it like its written in the manual: «Input 1 should go to your receiver's Channel 1 (aileron)», and put power on it again.

Surprisingly ArduPilot seemed to work fine.

Well except I have to use the aileron control to move the rudder, and the prop spins a 2-3 rounds every 10 sec.

 

I took a video of this:

 

 

So I switched back to the rudder channel, and this time it still behaved almost like the problem in the beginning of this thread, but not as violent.

But when I turned on the MUX it seemed to work properly.

 

Still on the rudder channel I tried another time. This time the servos went completely bonkers. But again, turning on the MUX works properly.

 

Here is a video of that:

 

 

I first thought it was a short circuit in the Rx, so every servo lead got a signal, but the MUX works so I don't think its that.

I more or less suspect there is something wrong on the board.

But after looking at all the solders and it doesn't look like there are any short circuit there either.

 

I don't think it is interference, then it should be just as bad with the MUX on.

After some more thinking, could it be Tx that's failing?

It has survived at least 2 hard crashes.

 

I am still weary much a beginner at this hobby like you surely understand, so does somebody recognize this problem or maybe know what to do?

 

Thank's in advance.

I'm not sure--I don't think anyone else has seen this problem so it's hard to replicate. Do you have another Rx you can test?

 

It could also be a wiring or soldering problem, but I'd have to take a look at the board to see. If you want, you can send your board to me and I can test it for you. Just PM me for address details.

 

BTW, that original ArduPilot will be discontinued soon and most people have upgraded to APM, which is MUCH easier to set up.

It's probably a bit far to send the board from Norway, will some pictures do?:


Free Image Hosting at www.ImageShack.us
Free Image Hosting at www.ImageShack.us
Free Image Hosting at www.ImageShack.us
Free Image Hosting at www.ImageShack.us
Free Image Hosting at www.ImageShack.us
Free Image Hosting at www.ImageShack.us
Free Image Hosting at www.ImageShack.us
Free Image Hosting at www.ImageShack.us
Free Image Hosting at www.ImageShack.us
Free Image Hosting at www.ImageShack.us

(No, I don't have another Rx.)

Aside from one of those red wires that looks like it might have a hair touching the next pin, those look good. 

 

I'm on vacation in Mexico and don't have hardware in front of me, but I'd break it down if I were you. Try the ArduPilot board by itself, without shield and IMU and see how that works. 

 

If need be I can send you another board that's working well. But ultimately, we need to get you off the original ArduPilot before we end support for it.

Thanks for the checking, the hair isn't touching, I just haven't cut it yet.

But I found something interesting yesterday, a thread where somebody has the same Rx with same symptoms.

So I suspect a bad Rx and ordered a Hitec Electron 6 Fm 35Mhz, I hop this will help.

If not I have to check the complete board like you suggest.

About ArduPilot Mega, I think I should try to get the original ArduPilot to work before buying APM, its a bit to expansive toy too just throw away.
But then again, if I can't find this problem I just maybe have to buy it to get my EasyStar flying "on its own".

Symptoms very suggestive of a bad Rx, probably loose or damaged crystal if it is that kind of Rx. You say it survived two crashes, that may explain it. Ancient RC mantra says to always replace crystal after crash.

 

Yes, I got a Rx with a crystal in it.

This problem only seems too occur when I use the rudder channel for the rudder (aileron channel for rudder seems too work), is this something a broken crystal could do?

 

How hard of a crash should it be to replace the crystal btw? In Norway they cost about $20 which I think is a bit steep.

I have to admit that I have not always followed this rule if thorough testing has shown the Rx to function well but a new crystal is a small investment if you are setting up an expensive new plane.

I will never forget my first experience with a loose crystal. Fortunately it was during an engine run-up with the plane tethered. It was a big 3D funflyer with enourmous control surfaces that went absolutely wild and the throttle as well. After a few seconds the throttle went low long enough for the engine to shut down so I was able to approach the beast.


Since then I have always taped my crystals securely. 

I bet it is the Rx itself seeing as the symptoms are related to one channel and intermittent. Hope you get your new one soon. Let us know how it works out. 

 

I got the new Rx on Friday, and used the weekend to test it, and I am happy to tell this problem now is solved.

 

It was definitely a bad Rx. The new one worked like a dream, and as an extra bonus it received almost no noise like the old one did.

 

(I still got some trouble with the ArduPilot code but I decided to make a new thread because this is a whole different problem.)

 

Thanks everyone for helping me finding this problem.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service