ArduPilot Throttle Channel

Hello All,Getting a setup going. Everything appears to be working well, except the throttle.Obviously, going straight into the Rx works just fine.The ESC normally plays a startup tone, and then 3 beeps to let me know it's ready. It does this when going straight into the Rx.If I jump the Rx into the "in" side of ardupilot.And hook the ESC into channel 3 on "out" side.I get the startup tone, but not the following three beeps.Has anyone else experienced something like this?I've quadruple checked the servo connections, and they're correct.Any suggestions?Thank you!John C.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • hello people, i think i have a problem with the mux (ch3 and ch4), i have been searching and reading the webpage from top to bottom and i can´t make it work...

    :-(
    look at this:

    GPS... OK
    IMU... OK
    INPUTS:
    AIRSPEED...OK
    CH1.............OK
    CH2.............OK
    CH3.............OK
    CH4.............OK

    OUTPUTS
    CH1.........OK
    CH2.........OK
    CH3..........BAD TRYED CHANGING TO MUX4 not working
    CH4..........BAD

    TELEMETRY.........OK

    CGS.....................OK


    any ideas?

    seems like i am going to try and fly without throttle and without rudder also (seems like ardupilot does not support using ailerons and vtail at the same time.....
    can you please give me some ideas on what else to try..... waited long time for my ardupilot to arrive... :-(
  • I don't think this is an isolated issue as I had exactly the same problem with mux 3 and only found out recently when I started using throttle. Thanks to this post I also fixed it using mux 4.
  • John, It's possibe the mux chip could have been damaged be ESD. All is not lost. You could use chn. 4 by moving the wire from mux 3 to mux 4 and solder on the extra connectors. The Aurdupiolot doesn't read inputs 3 & 4, it's not wired. These channel's outputs are just switched from computer to receiver when going to man. mode. If it works, that would confirm the problem plus get you going right away.
  • Developer
    Check the continuity between the pins and these two pins on the mux.

  • 3D Robotics
    I assume you soldered the jumper wire so channel 3 is enabled?
  • Developer
    Sounds like you need to adjust the minimum throttle servo value in the header file to a lower value. I am not familiar with the Plush, but most speed controllers will not arm unless they see a low enough throttle signal (i.e. stick all the way down). If you want to test this idea hook the esc up to the rx and start it up at say 1/4 stick. If you get the same behaviour then this is what is happening and what you need to adjust. Just be careful in case the Plush does not have this feature in which case your prop will spin!
  • Admin
    John,

    I believe that the ESC is looking for a throttle control signal which it gets from the Rx at power up.

    What position do you have your Ardupilot CNTL signal at when powering up? It should be in manual. Looks like the throttle control signal is not being passed through the Ardupilot mux from the Rx when in manual.

    Just a thought.

    Regards,
    TCIII
This reply was deleted.

Activity

DIY Robocars via Twitter
RT @SahikaGenc: AWS DeepRacer & Hot Wheels Track https://youtu.be/4H0Ei07RdR4 via @YouTube
Monday
DIY Robocars via Twitter
Sep 8
DIY Robocars via Twitter
RT @davsca1: We are releasing the code of our Fisher Information Field, the first dedicated map for perception-aware planning that is >10x…
Sep 8
DIY Robocars via Twitter
RT @SmallpixelCar: How this works: 1)object detection to find cones in single camera image, 30 frames/sec on @NVIDIAEmbedded Xavier. 2)comp…
Sep 8
DIY Robocars via Twitter
RT @SmallpixelCar: Use two color cones to guide the robocar. No map needed, on onsite training needed. Just place the cones and it will fol…
Sep 7
DIY Robocars via Twitter
Sep 7
DIY Robocars via Twitter
RT @roboton_io: Great to see http://roboton.io running at 60fps on the cheapest #chromebook we could find! #edtech #robotics #educat…
Sep 3
DIY Robocars via Twitter
RT @openmvcam: Crazy in-depth article about using the OpenMV Cam for Astrophotography: https://github.com/frank26080115/OpemMV-Astrophotography-Gear https://t.co/BPoK9QDEwS
Sep 3
DIY Robocars via Twitter
RT @openmvcam: Hi folks, it's finally here! Our first draft of our Arduino Interface Library is out! It works over SoftwareSerial, Hardware…
Sep 3
DIY Robocars via Twitter
RT @chr1sa: Please let them have an open API. This would be perfect for @DIYRobocars races https://twitter.com/NintendoAmerica/status/1301513099707658246
Sep 3
DIY Robocars via Twitter
RT @SmallpixelCar: Lanenet pretty much used all my GPU power on @NVIDIAEmbedded Xavier since I optimized with tensorRT. I need to run anoth…
Sep 3
xemone liked Max Gilson's profile
Aug 31
DIY Robocars via Twitter
RT @LyftLevel5: Our @kaggle competition on Motion Prediction for Autonomous Vehicles is now live! Experiment with the largest-ever self-dri…
Aug 24
DIY Robocars via Twitter
RT @chr1sa: Our next @DIYRobocars virtual AI car race will be on Sept 26th. Sign up here https://www.meetup.com/DIYRobocars/events/272786977/ https://t.co/UENKGSOWO8
Aug 24
DIY Robocars via Twitter
New ready-to-run @NVIDIAEmbedded JetRacer car from Waveshare. Perfect for the next @diyrobocars race as soon as we… https://twitter.com/i/web/status/1297960223013867520
Aug 24
DIY Drones via Twitter
RT @chr1sa: The US government just approved 5 US-made drones for purchase, all based on the @Dronecode @PX4Autopilot standard. Great news f…
Aug 20
More…