I've just released ArduPlane 2.60

The main new features in this release are:

  • wind estimation
  • long term dead reckoning support
  • wheeled takeoff and landing support
  • optional new roll/pitch/yaw controllers from Jon Challinger

For a description of the first 3 new features have a look at my previous post. All of these features have been test flown on my PulseXT 40 and have performed very well.

The new roll/pitch/yaw controllers from Jon can be enabled by building with

 #define APM_CONTROL ENABLED

in your APM_Config.h. If you enable the new controllers then I strongly suggest you read Jons blog post about the new controllers and how to tune them. These controllers are still experimental, but if we get good feedback on them from users we will quite likely adopt them as the standard controllers in a future release.

Other changes in 2.60 include:

  • a new RECEIVER_RSSI_PIN compile time option, to allow you to display receiver RSSI via MAVLink. This should be useful for FPV flying.
  • an important fix from Jason Short for an erase bug in the dataflash. If you use dataflash logs then please erase them after loading this release to ensure the pages are properly initialised.
  • support for the new features in the new MTK GPS firmware
  • updates to the configuration parameters for the Mount code. If you use the mount code, then please check your parameters carefully, as some things have changed.
  • a fix to the JUMP command in missions, which solved a problem where the wrong command could sometimes be run
  • a fix to the initial yaw from AHRS when using a compass
  • new FENCE_ACTION_REPORT value for FENCE_ACTION
  • new "OBC" failsafe code as a compile time option
  • new RST_MISSION_CH option
  • new STICK_MIXING option
  • support for dual stabilisation mounts (eg. one camera and one antenna)
  • removed old CLI switch and dip switch support
  • fixed a derivative filter bug that could have a small affect on AHRS attitude
  • fixed LOITER_TIME to match MAVLink spec (time is in seconds)
  • added FBWB_ELEV_REV option

Happy flying!

Views: 6542

Reply to This

Replies to This Discussion

@Manu:I used this one config file :

http://code.google.com/p/ardupilot-mega/downloads/detail?name=skywa...

I only changed loiter and WP radius other stay untouched.

@Eagle: only stock controller used, didn't want to experiment that soon. Perhaps on next flights...

I just installed 2.6 on a APM1.4 and am having problems entering CLI mode. I tried 3 returns which normally work but instead it just shows text saying that it's initializing demo servos and then calibrating IMU and then ready for flight. What would prevent it from entering CLI mode or is there some other way I can enter it? I've tried the switch on the board that use to be used but that didn't work either. I have a thread started in the arduplane group.

http://diydrones.com/group/apmusergroup/forum/topics/gps-stopped-wo...

Looks like Mission Planner 1.2.10 has solved all my Write Mission problems with 2.6. I suspect that it was some sort of a timing problem?

DO_REPEAT_SERVO not work.

Hi Andrew, I'm making with evidence; DO_REPEAT_SERVO command but does not work in arduplane 2.6, when I use this command HIL sumilador funcioan well.

special settings for this command?

thanks
jim

My tests will take longer - I lost my Skywalker (not APM failure, just preflight check omited),

I have to take another bigger plane (mine Bluespy 2600mm) and adjust params for it.

I'm having a problem with GPS not being recognized with 2.6 on 2 different APM1.4/1280 boards. I've tried 4 GPS units but am getting nowhere! I've put the details here and would appreciate if anyone has any clue to how I can solve this. I can't even get into terminal mode on either so my testing is limited.

http://diydrones.com/forum/topics/gps-simply-not-working-no-matter-...

Hi F11music.com,

Not sure but this might be related, I've loaded Ardupilot 2.6 HIL on to my APM1 1280 and 2560 and cannot get any GPS data to the mission planner, the plane will fly, but the GPS data that X-Plane 9 generates does not seem to be getting fed back. 

See my post

http://diydrones.com/forum/topics/where-can-i-find-depreciated-hil-...

Joshua Beltz reports a similar problem with 2.6 HIL.

I am going to try to roll back to version 2.5 to see if this works.

I know that X-planes is generating the GPS data, and I think that you've concluded that your GPS modules are working, it's just like there is some sort of blockage in feeding the GPS data back to the APM.

I know that HIL doesn't use the actual GPS unit but maybe the cause of the blockage in the transmission of the GPS data is the same in both cases.

Best regards

Martin

This question was posted by Mike back on page 3 and doesn't seem to have been answered.

"Where can I find more information about the "support for the new features in the new MTK GPS firmware" new feature?"

Is this just 1.6 or is there a newer version available?

Thanks

The new MTK GPS firmware hasn't been released yet. This is just getting ArduPlane ready for it when it is. 

Thanks Chris. So I guess it will make its way into ArduCopter eventually as well.

I'm working on resolving an issue in FBW-A mode. While testing FBW-A and stabilize the airplane turns right maintains the proper bank and holds altitude. When I bank to the left it initially holds alt for about 1 sec, you can see the pitch increase but then it sharply looses altitude in both FBW-A and Stabilize. I'm not sure what values i should be looking at. I have rudder comp set to .5 and pitch comp .8. I've tried increasing pitch comp and it results in a altitude increase upon moving the stick left or right to bank. Both left and right seem to be holding the bank.

What values should I be looking at modifying?

Thanks,

Ken

Hallo,

can somebody clarify to me what movement orientation is intended for rudder control surface?

For instance when APM is in stabilize mode and the plane is leveled then I move the plane in roll axis -> left wing down, right up. What direction is supposed rudder to move?

Now I have set it to move right as I used to do when flying with usual acro planes: roll left, rudder right to make knife flight.

This is but different with glider planes, there it is contrary: roll left, rudder slightly left.

So what rudder direction needs APM software for correct stabilization?

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service