I've just released ArduPlane 2.60

The main new features in this release are:

  • wind estimation
  • long term dead reckoning support
  • wheeled takeoff and landing support
  • optional new roll/pitch/yaw controllers from Jon Challinger

For a description of the first 3 new features have a look at my previous post. All of these features have been test flown on my PulseXT 40 and have performed very well.

The new roll/pitch/yaw controllers from Jon can be enabled by building with

 #define APM_CONTROL ENABLED

in your APM_Config.h. If you enable the new controllers then I strongly suggest you read Jons blog post about the new controllers and how to tune them. These controllers are still experimental, but if we get good feedback on them from users we will quite likely adopt them as the standard controllers in a future release.

Other changes in 2.60 include:

  • a new RECEIVER_RSSI_PIN compile time option, to allow you to display receiver RSSI via MAVLink. This should be useful for FPV flying.
  • an important fix from Jason Short for an erase bug in the dataflash. If you use dataflash logs then please erase them after loading this release to ensure the pages are properly initialised.
  • support for the new features in the new MTK GPS firmware
  • updates to the configuration parameters for the Mount code. If you use the mount code, then please check your parameters carefully, as some things have changed.
  • a fix to the JUMP command in missions, which solved a problem where the wrong command could sometimes be run
  • a fix to the initial yaw from AHRS when using a compass
  • new FENCE_ACTION_REPORT value for FENCE_ACTION
  • new "OBC" failsafe code as a compile time option
  • new RST_MISSION_CH option
  • new STICK_MIXING option
  • support for dual stabilisation mounts (eg. one camera and one antenna)
  • removed old CLI switch and dip switch support
  • fixed a derivative filter bug that could have a small affect on AHRS attitude
  • fixed LOITER_TIME to match MAVLink spec (time is in seconds)
  • added FBWB_ELEV_REV option

Happy flying!

Views: 6504

Reply to This

Replies to This Discussion

Hi Paul,

I'm having the same problem.  APM1 was working fine with HIL and Xplane on MP 1.2.6 and HIL 2.5.  I updated to both 1.2.8 and HIL2.6.  Now I see a blip of data just after selecting "Start Sim" and then no data.  I loaded 1.2.6 again and the problem persists.  I noted a warning that the EPROM was going to be wiped when loading HIL 2.6.  I'd like to try rolling back to HIL 2.5 but not sure how to do that, the 1.2.6 MP now trys to install HIL 2.6, not 2.5.

Steve

Thanks Jonathan.

Hi Steve,

This LINK will take you to the Wiki page that describes how to load firmware.  Make sure to read all sections as you have to make at least one change to the config file. If you want to load the sim version, other changes have to be made to the config file.  I have been a little nervous about trying it myself, but I believe I will this weekend just so I know that I can do it.

Thanks,
Paul

http://code.google.com/p/ardupilot-mega/wiki/Programming

I just loaded V2.60 had have a couple of questions:

  1. Is there a way to test if the RET_MISSION_CH is working correctly before I make the first flight? I was expecting something like Mission Reset to flash on the HUD but I got nothing.
  2. Can I just load my V2.50 PID’s or should I start with defaults and do the tuning all aver again?
  3. I went to erase all the old logs but it says no dataflash installed. What’s that all about? I have one of the last APM2’s and Mission Planner 1.2.8.

 

.

 

I did a little more testing this evening and found that my transmitter also becomes nonresponsive as soon as Mission Planner is connected to the simulator.  After disconnecting from the simulator the transmitter remains unresponsive.  It was working as expected within Mission Planner before connecting to the sim.

Any help will be appreciated.

Thanks,
Paul

Paul,

Wow, Is my only option to compile the source if I want to roll back to the previous version of the APM and HIL software?  I will probably try it, but I am sorry that I upgraded, I was close to 1st flight.

Can you point me to the changes, including those for the sim version you referred to?  And I'd like to hear how your recompile turns out.

A convenient feature in MP might be to contain the links to roll back one version (if the update causes problems for the user).

Steve

APM1, Win7

Hi Steve,

I think that's the only choice.  My first attempt to load with Arduino didn't go so well.  I got lots and lots of errors.  I reloaded ArduPlane 2.6 from Mission Planner and all seems well.  I'll second the motion to have a utility to load previous versions of firmware.  It's just comforting to know that you can go back to what worked and then take your time to get up to speed with new releases.

Paul

James: Please check again. The MP shows 2.60 for me.

I set up the  Arduino IDE, uploaded the GCS_Mav to my APM1 1280.  APM 2.5 will not compile for the 1280 because it's too big for the memory my mega has, and so I tried APM 2.4.  It does not quit after selecting "start simulation" like APM 2.6, but there's still a problem with getting good data from X-plane 9.  The Xplane part was working before, so I have not touched it.
I noticed that several people have had the identical problem with APM1 and the latest APM 2.6.  Have my fingers crossed that the problem is obvious and easy to fix in the next update.  However, I'm a little worried 1280's won't be able to load the growing code.

I'm having an issue with channel 5 & 6 outputs. Previously, I was using channel 5 for manual flaps and 6 for manual camera panning. In Arduplane 2.5, it worked fine, but now I am having a weird bug.

 

If I set channel 5's function to manual, I get no response on the flaps when I flick the switch. If I set it to mount_roll (or something other than manual), then write the params, then set it back to manual and write params again, it works fine. Each time I restart the autopilot (ie. change the battery) I have to go through this process. It only appears to affect channels 5 & 6.

 

Anyone else having this problem? It didn't occur in 2.5

Hi Mike,

ad 2) I am NO expert, but if you didn't enable Jons new controller, I think it should work, at least it did work for me.

ad 3) The dataflash card may not have enough contact. I have two APM 2.4 and on one I had to put two layers of electric tape on the dataflash card to make it work, on the other none. See here: http://www.diydrones.com/forum/topics/apm2-fails-to-detect-use-micr...

Hope it helps.

Thanks for the reply I will work on the card to see if I can get it to make contact.

It was a nice morning and the old PID’s were good.

.

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service