I've just released ArduPlane 2.62

The main reason for this release so soon after 2.61 is to fix elevon mixing. That was broken completely in 2.61. My apologies to everyone with an elevon plane!

Other changes in this release:

  • new IMU timing code from Randy. This improves the accuracy of the timing in the DCM code, which should give a small improvement in attitude estimation
  • fixed fetching of relative altitude when you save a mission from the APM to a file using the mission planner
  • added support for MAV_CMD_PREFLIGHT_REBOOT_SHUTDOWN. This makes it possible to reboot an APM2 remotely from a ground station
  • added speed scaling for wheeled takeoff. This prevents the rudder from over-correcting in the later parts of a takeoff
  • fixed setting a specific GPS protocol for an APM1-1280. This allows you to select any of the GPS drivers in a APM1-1280.
  • fixed navigation roll in an automated landing, to prevent wings hitting the runway during the last stage of a landing
  • fixed LAND_PITCH_CD to only apply to the final part of a landing
  • fixed noisy PWM output on startup on an APM2. This should help with some cheaper ESCs not booting correctly on startup
  • fix for NMEA parsing from Alexey Kozin (thanks Alexey!)
  • added a AHRS_BARO_USE parameter. This allows you to disable the use of the barometer for vertical acceleration correction. Combined with ALT_MIX, this makes it possible to completely disable the use of the barometer (in case your barometer is very badly shielded from air flow)

Happy flying!

Views: 3890

Reply to This

Replies to This Discussion

Arduplane 2.61 was found quite smooth going in AeroSIM-RC

Observation:

  • When 2.62 flight firmware is loaded, no issue of connection with Mission planner observed 100% success rate tried 20 times, always success.
  • When 2.62 HIL firmware is loaded, serious issue of connection with Mission planner observed, 0% success rate tried 20 times, never got connection with MP.
  • Then loaded 2.61 HIL, no issue observed.

I am having the same problem on an APM 1/2560. My system is not functioning as it did on 2.6 . I am going back to 2.6 for now

 

Did you erase the eeprom first? (CLI setup/erase)

Arduplane 2.61 Long flight tested on Flying Wing in AeroSIM-RC

Hi, can anyone explain the parameters ARSPD_OFFSET and ARSPD_RATIO? I'm having real trouble getting meaningful airspeed data. The parameter wiki says what the parameters are, but not what they do exactly, or how to calibrate the airspeed sensor.... thanks

Yes. As Asaak said everything seems to be moving in slow motion. I have another system with an AMP 2.0 running ArduPlane V 2.5 and will wait before upgradeing firmware to get the nav improvements.

A question about the software reboot: Code-wise it seems to be restricted to APM2. Is there any reason to believe the same method would not work for an APM1 1280 or is it just untested? Thanks!

Thanks, can anyone confirm that 2.62 is supposed to work with airspeed ?

I am unable to see AS in MissionPlanner,  - but it works fine in test menu.

APM 2.5

Hi all,

I´m having problems with esc initilization too. I use a turnigy plush 40A and it`s not starting. 

I have another APM2 with the same esc and earlier version of ArduPlane and always worked.

Anyone have a solution? How can i install an earlier version of arduplane using the Mission Planner?

Thanks

Asaak - Question Have you resolved your problem? If so, what resolved it?

I am still having major problems with AP 2.62.

First :

Just to check my hardware I loaded Arducopter 2.73 without erasing or anything else. Arducopter loaded without problems. After loading I went to flight data and checked out the HUD action. The hud follows roll, pitch, and Yaw almost instantaniously. Also Transmitter calibration using tlementery was normal. OK the hardware is fine.

Second :

I did the exact same thing with ArduPlane 2.62  on the same hardware and guess what . Snails pace on Hud reaction to Roll, Pitch, and Yaw. There seems to be a major problem with  the Mavlink system and 2.62 in general. Using the CLI calabration and testing of the hardware A to Z is normal. The numbers on all tests Roll, Pitch,Yaw,Compass, PWM, and Passthru follow inputs to the letter with no visable lag.

Help any one?

I'm having the same problem with Arduplane 2.62.  I uploaded this morning and my HUD display does not react to movement around XYZ axises as I am moving it.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service