I am new to ArduPlane.

I have a bench setup with APM1 hardware, IMU OilPan, APM Planner-1.1.87, RC Receiver, ESC  but without the plane.

I have ArduPilot-2.34 running on APM1. I am able to connect to the APM1 hardware using the APM Planner. I  calibrated the RC control input channels.

I do not see any attitude indication in the Artificial Horizon (APM Planner->FlightData)  when I move the APM1 hardware. Raw Sensor readings of Roll, Pitch are zero.

However, when I run "test imu" on the APM Planner terminal, it says "Init IMU" and I start getting text readings on the console for Pitch, Roll and Yaw varying from -10 to +10 as I move the hardware.

I also tried loading parameter files bixler.param and easystar.param. There is still no indication on the attitude display.

I tried loading older versions of the code from 2.32. There is still no indication on the attitude display.

For testing I downloaded and installed ArduCopter-2.5.4 on the same hardware with same setup. The Attitude indication on Artificial horizon works well.
The Artifical Horizon in this case displays "Disarmed".

Please help me resolve this issue.


Mahesh M

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hi,

    I am facing the same problem again ... just when I thought that it was solved !

    I was using the pre-compiled ArduPlane-2.34 binaries through APM Planner for the hardware checks as well as for HIL simulation. The HIL works very well with the autopilot flying the aircraft through the waypoints that I defined. After this success I was integrating the setup with the plane. That's when I started facing the problem again.

    After the recent upgrade APM Planner now downloads the 2.40 binary and not the 2.34.

    With ArduPlane-2.40 my HUD/Attitude indicator is not working irrespective of whether the switch is in Fly / CLI position. I can connect to the hardware via MAVLink 1.0 (USB). I can also perform "test imu" with the results same as what I described earlier. But there is no attitude indication.

    I also tried connected to the APM1 hardware using 3DR radio. Connection was ok. Again no attitude indication. Switch was in "Fly" position.

    Since the 2.34 binary is not downloaded by APM Planner now, I compiled and loaded the 2.34 code using Arduino-022. I was surprised to see:

    a. In "Fly" switch position I am not able to connect to APM1 ... says serial link slow.

    b. In "Fly" switch position - I am not able to connect even using 3DR radio.

    c. In "CLI" switch position - connection ok - no attitude indication.

    d. The 2.34 code compiled in HIL mode works fine.

    I again tested with ArduCopter-2.6. The attitude indication works fine. So I think there is no problem with the hardware.

    Any ideas? Please help me resolve this problem. Wish to get the autopilot in air asap !!!


    Mahesh M.


  • Developer

    what board type do you have?

    apm1 1280

    or apm1 2560

This reply was deleted.


Neville Rodrigues liked Neville Rodrigues's profile
Jun 30
Santiago Perez liked Santiago Perez's profile
Jun 21