hi there 
I have had the APM for a few weeks now and and i am trying out the auto function.
It follows the mission course fine the first time.
Then i try to load a different course and write it to the APM, then i switch it into Auto mode in the air and all it does is circle around in the air and eventually try kill itself (nose dive).
I also noticed that it becomes very jerky on the Ailerons like it is trying to correct it self quickly while flying in circles. 


I did not reset the APM board between loading the missions.
I am using ArduPlane v2.28 and APM mission planner.

I have added a log it happens at 63%

Views: 1344

Attachments:

Replies to This Discussion

The rudder is pretty low dont think that would be a problem.

Add this to list of strange thing's

This is when it goes in circles halfway through a mission.

At this stage I would recommend Adnre's suggestion and setup HIL to make sure the problem is with the APM.

Sounds like a signal loss and then a search..?? Is there anything obstructing your GPS RX?Were is it located anything else near? Also I Like to delete old programs before adding a new one on most everything...frees up space= faster- and lets face it, that board is not a 32gb SSD. lol  hope you get it going...setbacks have allot of drag!

trying it now with xplane 9 and it works like a dream  not a single thing wrong and near perfect navigation. Wonder why it does it with my plane guess i will have to look into it when it comes.

Ok, so in theory the APM is fine.

Is the APM securely fastened? Is your prop balanced?

Yes it is securely  fastened with a rubber band.Some one told me that you don't need to balance the plastic APC props it is 6x4 but will look into how to do it.

Got another Bixler yesterday and had a test flight last night.

Didn't get much time to fly as it was getting dark and spent most of the time setting it up.

Anyway when i got it to fly to the way points it didn't start circling.

But it zigzagged the whole way and i was using the bixler config file.

Guess i will have another flight tonight and see how it goes.

Can you try the following:

- Disconnect the rudder servo, or disable it in the APM

- Use the default PIDs

I had trouble with my rudder excessive throws. It also appears that the PIDs in the Skywalker param file is extremely high.

I know of someone why struggled with zigg-zaggs to waypoints for months until he discovered the yaw pid was too high.

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service