Arming the hexa motors ....

Hi guys,

I have resolved the RC problems. It was a defect receiver in fact, and after changing to a new one, the binding process worked fine, as well as the radio controls calibration. 

Now the next step : calibrating and arming the ESC's. I think the calibrating worked, as I heard a lot of different bleeps and melodies, but as I bring the throttle back down after a few minutes, I have no response of the motors to the throttle. Also after unplugging the lipo and repowering, I tried to arm (throttle to the right bottom for 3 seconds ...) but no response .....

What's wrong now ?

I had the switch in fly mode, I suppose that's OK ? The blue LED on the board is blinking slowly.


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hi,
    Thanks a lot to Gareth ! I followed your advice to the letter and I managed to calibrate all my ESC's, I think. Although they didn't all react in the same way. Two of the six actually responded immediately to the full throttle when I plugged them in my receiver. After the calibration, the arming was also kind of funny. No direct reaction to the arming with the throttle stick to the far right bottom for a couple of seconds. So I changed the switch to the CLI mode (I think) or the closest to the RX pins. I still didn't get any arming with stick to the right. But when I moved it to the left for a second or two, I got to arm them, strange no ? So, there must be a couple of details to be corrected here, but I'm already very happy to see my motors turn at last !!!! Thanks to all those that helped me out so far....
  • I have admit that the original JrDrones videos on this were what allowed me to first figure this out.

  • Let us address the ESC calibration. Leave the transmitter on with full throttle. and the esc you want calibrated plugged into your throttle channel. Plug in the ESC. You will hear a few beeps, I cant remember 3 or 4 maybe. Then immediately reduce throttle to 0%. You will hear a confirmation beep/s. Then unplug the esc from the lipo, then plug it back in. After the esc has booted you should have full control over it using your throttle. Calibrating the escs takes less than 20 seconds, its the unplugging and plugging and losing count ETC that make it a pain. I will share a "lazy secret". Instead of unplugging the 3pin connector from the PDB on the arducopter, Use a small jump wire (1 end female sil, other end male sil) and plug the receiver into the 4 pin sil motor connector that gets plugged into the APM. Works for me :)

    Not being able to arm can be un calibrated escs or perhaps a reversed channel on your transmitter or APM planner.

    Calibrate the ESCs, if that doesnt fix the problem. Check in APM planner that you have the correct stuff mapped to the correct places, as well as going in the correct directions. If you move the stick to the right, the green bar should move to the right.

    Wash, rinse, repeat ;)

    If you dont come right with the esc calibration, let me know and ill post a video of the process :)


This reply was deleted.


Hiroki Tanaka liked Hiroki Tanaka's profile
Oct 13
Derrick Davies liked lisa TDrones's profile
Sep 23
xemone liked Max Gilson's profile
Aug 31