Artificial horizon going nuts over 3DR Radio only (SOLVED)


Using the latest V2 3DR radio-
It seems that lately (worked normally until about a week ago) my artificial horizon (AH) tumbles according to the very random and fluctuating pitch roll and yaw values visible under the status display in mission planner. Using 2.76 and about at my wits end here. I have tried reflashing APM, reflashing both 3dr radios, disconnecting airpseed sensor, setting GPS AHRS gain to 0 (it is now back at its default of 1), and am out of options. 
The system runs perfectly fine under a USB connection to the computer. AH is stable and all other indications appear fine. It just seems like pitch roll and yaw goes haywire when the 3DR radios are connected. I am not able to do a level or a accelerometer calibration while using the radios. I get the message: "ac2 2.0.37+ is required". I have no idea what this signifies.
I am able to switch modes using the radio, and connect fine every time. I am also able to execute commands, such as a Preflight_Calibration via the radio. Airspeed indications are also normal over the radio. It seems like there is only an issue with the gyro portion of the connection. 
Does anyone have any insight into possible troubleshooting actions that I could take at this point? This issue is posted for assistance over at the arduplane forums as well under the 2.76 FW section.

Attached is a youtube video of what I am experiencing:

Views: 294

Reply to This

Replies to This Discussion

Which APM hardware are you using?

APM 2.76

Been spending the better part of the day with this. Recently switched back to USB only and now it appears to be tumbling via USB power as well. I am beginning to think that I have a bad APM. It now fails every calibration attempt. I have tried reflashing to earlier firmwares, doing a CLI setup/reset/erase, all to no avail. Still open to any suggestions.

I am using APM 2.76. I tested the 3.3V regulator and checking voltage across pins 1 and 4 of the I2C socket. I was able to determine that the 3.3V regulator was indeed blown, as it measured 5 volts across those pins, instead of 3.3. I used this video by Randy to determine the cause:

I will RMA this ardupilot.

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service