Hello all,
I've been searching for quite awhile now, but haven't found the solution (yet).
I have a Hex with a PixHawk FC (running APM:Copter V3.3.3 Hexa) and a Taranis TX.
My landing gear is working all right this far:
With CH 8 on a 3 position switch, it's "down" on 991 pwm and "up" on 2010 pwm.
However: CH 8 in mid position (1502 pwm) it should act on "auto".
In Mission Planner I've left the servo pwm values on default.
So my problem is: How can I get it to react in mid position (auto retract)
Thanks in advance.

Views: 2575

Replies are closed for this discussion.

Replies to This Discussion

Hi

i'm using the auto mode for quite some time now on my landing gear. 

I got the landing gear wired with only the signal wire to my FC. vcc and ground go to a bec. 

The output on the FC is linked to a 3-pos switch on my tx, no wire connection between rx and landing gear. Parameter in FC is set to 29 (Landing gear) i guess. if switch is high, landing gear retracts, low it deploys. In middle pos it is auto and deploys automatic in rtl and landing as mentioned above. 

I haven't figured the auto retract out but i guess it isn't implemented so far.

making the long story short:

Connected Signal wire from LG to FC, VCC and Ground of landing gear to a bec. Configured a 3-pos switch for the right rc function. Set Rc-function according the output where i wired the LG on to 29

Hope this gets you going 

Hi Niels G.

I have it working this way also, but "auto" isn't working and should be when in "landing/RTL and/or auto flight".

Auto retract and deploy is implemented in AC 3.3.+

So my problem still is there.

Manual controled YES, auto controled NO

These are my settings:

Servo signal wire in AUX1

VCC and GROUND in BEC.

MissionPlanner CH8_OPT on 29 (LG retracts and deploys manualy, so that's fine)

MissionPlanner CH9_OPT on 29 (LG gives no reaction at all)

Have you checked, that your landing gear is retracting at high value pwn and extending at low pwm? 

That was some problem i had first. Landing gear or signal from my tx got the wrong way round. You can correct the value according to your tx with the LGR_SERVO_DEPLOY or RETRACT values. 

Real auto control is not yet implemented i guess. i was doing it the way: Takeoff, retract LG, put switch to middle/auto, flying the mission and at the end of the mission the LG extends automatic. That is, what i got so far. 

Still not working like you tell :-(

I hope I'm not asking to much, but could you please tell me your settings.

Signal in PixHawk AUX1? Yes/No?

VCC and GND in BEC? Yes/No?

In Full Pararmeter List:

CH8_OPT on 29 Yes/No?

CH9_OPT on 0 Yes/No?

RC8 > RC8_FUNCTION on 0 Yes/No?

RC9 > RC9_FUNCTION on 29 Yes/No?

In Extended Tuning:

Ch8 Opt: "Landing Gear"

Did I forget something?

Thanks in advance  :-)

Signal to Landing Gear at my setup through Aux 1 which is RC9 according to the wiki. 

Maybe that is the whole crux at your setup... Must have overread it before. 

You can try to setup the signal wire to aux1, CH9_OPT to 29. 

RC Channel is the input channel of your tx to the FC. If you put the 3-pos switch through channel 7 or 8 in you should set the CH7/8 OPT in the Extended tuning to the right dropdown, landing gear. 

Lost my track here... 

Put the signal wire of your LG in Aux1. Make sure the Landing gear is powered through a Bec and not through the FC

Setup a 3 pos Switch on your tx to either channel 7 or 8 input to the FC.

Set the RC9_FUNCTION to 29.

Make sure the output of the pwm on your tx is according the pwm values for the landing gear retract/deploy in LGR_SERVO_DEPLOY/RETRACT

now it should work as planned, which is for me that the LG deploys if entering Land Mode or Land phase in RTL if the 3pos switch is in middle position

hope this works

"Put the signal wire of your LG in Aux1. Make sure the Landing gear is powered through a Bec and not through the FC"

Checked

"Setup a 3 pos Switch on your tx to either channel 8 input to the FC"

Checked

"Set the RC9_FUNCTION to 29"

Checked

"Make sure the output of the pwm on your tx is according the pwm values for the landing gear retract/deploy in LGR_SERVO_DEPLOY/RETRACT"

TX set to 1250-1750 (50% weight, didn't do this yet)

Now wait for weather to get better :-((((

Will report a.s.a.p.

Thanks again.

Edit: have to go, will be back tomorrow

""Make sure the output of the pwm on your tx is according the pwm values for the landing gear retract/deploy in LGR_SERVO_DEPLOY/RETRACT"

TX set to 1250-1750 (50% weight, didn't do this yet)"

 

Can'T make sense out of it. 

You need three signals from the 3 pos switch. 

Low, High and the middle part. Stupid question, but have you done the Radio Config for this switch/Channel? 

Than you can get the values out of the radio calib screen according to the switch position and alter the values in the config for LGR_SERVO_DEPLOY/RETRACT

Think I'm loosing my brain by now.

The only way it's working is in MANUAL MODE.

AND CH8 > RC8_FUNCTION in Pass Thru (=1) setting in MissionPlanner.

AND signal in the PixHawk Main Out 8

AND Ch8 Opt in Extended Tuning > "Landing Gear".

AND RC9_FUCTION > 29

Switch in Mid Position AUTO? Forget it :-((

Ok, sounds strange. 

I'm home right now, so i can check on my hexa exactly how i done it. 

Will get back to you with my exact build and the parameters

have eyes on: 

Signal wire of LG is in port AUX 3 of Pixhawk. 

RC11_Function is 29 (LG)

3-Pos-Switch is on Channel 8 of the Pixhawk with Low pwm 982, mid 1494 and high 2006

In Extended Tuning Tab CH8_opt is landing gear. So pixhawk knows that rc 8 is for the LG

LGR_SERVO_DEPLOY is a value of 1000

LGR_SERVO_RTRCT is 1950

That is basicly my setup and it works. Well, works in the way that i can control the LG with the 3-pos switch. High value is retracted, low is deployed. If i retract the gear after takeoff in a mission and put the switch in middle pos it will deploy at the end of the mission, in land mode or rtl. 

There is no auto retract after takeoff or i haven't find it yet. 

Maybe you can use this setup as a start

ahh ok... i think i found something as i was reading your post again... 

You put the signal wire for the landing gear in MAIN Out 8? i think this is not working as it needs to be in AUX out. As i described it is in AUX 3 in my setup. 

Maybe this is a shortcut for your problem... 

FINALY got it working your way:

"Signal wire of LG is in port AUX 3 of Pixhawk. 

RC11_Function is 29 (LG)

3-Pos-Switch is on Channel 8 of the Pixhawk with Low pwm 982, mid 1494 and high 2006

In Extended Tuning Tab CH8_opt is landing gear.

LGR_SERVO_DEPLOY is a value of 1000

LGR_SERVO_RTRCT is 1950"

I can't express how happy you made this "old" (67) Dutchman :-))))))

Thank you so very much!!!!!!!!!!

It was a pleasure to be helpful

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service