Edit: Success - http://diydrones.com/profiles/blogs/it-works-fully-automated-parach...

I want to try this with my quad and see if and how it works.

Here's my waypoint list:

Basically takeoff to 6m (will actually take off the ground myself as AC v2.7.1 doesn't seem do the takeoff).

Then fly to a close waypoint at 10m alt, then to a further waypoint at 60m alt, loiter for 5 secs, release the chute, loiter for 5 secs, descend to an interim waypoint at 30m, descend further to a closer waypoint at 15m and RTL from there. This is in a fairly open area and the drop will be about 60-70m from the takeoff. May change the waypoint positions if there's a bit of wind.

Does that order & logic look about right?

Views: 9444

Reply to This

Replies to This Discussion

However before I even get to that I've just spent the last hour searching the wiki and forum trying to figure out where to connect the servo, how to activate it and test it. Frustrating to say the least as there's either no info or conflicting info.

http://code.google.com/p/arducopter/wiki/AC2_Camera has info on adding a camera but nothing on triggering it via a servo.

http://code.google.com/p/ardupilot-mega/wiki/Tracking is out of date and also says nothing about triggering.

http://code.google.com/p/ardupilot-mega/wiki/APM2board says A9 is used as camera shutter but nothing else.

The servo does seem to work on either A9 or CH8 out (I have changed it since the screenshot above)

Any advice?

If you don't come right then try contacting Hein at hein@vlap.co.za. I understand he helped develop the trigger function and uses it regularly for cameras.

Trying to get this to work but can't get any output for a servo.

Following this I've set RC8_FUNCTION to 10 (camera_trigger), RC8 MIN & MAX to 1100 & 1900, CAM_TRIGG_TYPE to servo, tried plugging a servo into A8 (or A9) but nothing, servo does not even move.

What else do I need to do?

I've opened an issue here, please star it if it affects you so that it can be attended to.


Any new solution for move the servo?

I'm having trouble getting anyone to look at this despite quite a few 'issues' being posted. I know nothing of programming but found this in the code for DO_SET_SERVO: APM_RC.OutputCh(command_cond_queue.p1 - 1, command_cond_queue.alt); but it's all greek to me (no offence to the Greeks)

I'll probably start on this next (weather permitting), will keep you informed of any progress!


Discovered while playing with the HIL simulation that any DO_xxx command only works if a dummy waypoint is placed after that command, so DO_SET_SERVO actually does set the servo 6 (RC6_xxx) to whatever you told it in the mission planner (RC6_MIN/MAX) BUT although the mission planner actually shows the CH6_OUT as changing there is no physical PWM output that would drive a servo.

I just started thinking about making servos do things at waypoints but there is not much info on it.
Do you know what the RC parameters do like 1-manual 11-release? I thought they would correspond with a waypoint function. Perhaps thats what you need to set to get a servo output, or perhaps its just in HIL that its not driving a servo?

Like you said there's not much info on this at all.  I presume 1-manual is just to drive the servo manually to what position you've given it, 9-mount_open, 10-camera_trigger & 11-release sound like they all do the same thing. The HIL simulation 'should' cause the APM to behave exactly like it would in flight, it certainly seems to do everything else correctly, eg, I got it to DO_SET_HOME correctly (this is in ArduPlane).

DO_SET_SERVO also worked correctly at the right point in the mission showing the CH6_OUT change from 1200 to 1800 in this case but maybe in the HIL the servo outputs are disabled. If so the only way to test is to physically fly the plane which I can't do at the moment as it's a bit dark :).

OK, I ACTUALLY managed to get it to work in the HIL simulation!

What I discovered is that all DO_xxx commands need a dummy waypoint placed AFTER the DO_xxx command otherwise they won't work





Home will be set at WAYPOINT_1 but it will only be set if WAYPOINT_2 is there.

So I did this:

#1 is a dummy waypoint otherwise the mission won't run

#2 sets the servo to 1200ms,

#3 is a waypoint that will be flown to,

#4 sets the servo to 1800ms at waypoint 3,

#5 is flown to,

#6 sets servo to 1200ms at waypoint 5

#7 is a dummy otherwise #6 won't work

#8 jumps to waypoint 1 to repeat the mission 2 times

#9 is a dummy otherwise #8 won't work

VERY bizarre, is this a bug or was it intended this way?

Now I must try it in the air...

Reply to Discussion


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service