I have done auto-tune in the past, but I'm currently having problems which I can't seem to resolve.

My setup includes a 3DR Pixhawk running ArduCopter firmware 3.3.2   with the default values for the PID.

I've setup Channel 5 to get into Alt-Hold, and channel 7 is set to start auto-tune.  Also re-did the radio calibration several times.

When I fly and follow the procedure, auto-tune doesn't seem to do anything.

To verify that all is set correctly, I connect the Pixhawk to the mission planner on the ground, and do the following to simulate the procedure:

1. Arm

2. Raise throttle to avoid Disarm

3. Enter Alt-Hold

4. Switch to auto-tune

The display does show the auto-tune as starting, so it doesn't seem to be a configuration issue, but still, when in the air, nothing seems to be happening.

I would appreciate any help in resolving this.

Views: 845

Reply to This

Replies to This Discussion

only thing i can think of is that auto tune does initialize in air but does not start because the drone is receiving RC inputs continuously for some reason due to bad calibration or problems with your transmitter. thats the direction i would take. Like the RC stick not fully centred or something. 

I have verified that I have no trims, and performed radio calibration to accept the current centers as correct.

Is there a way to configure the sensitivity, in case the transmitter is not keeping perfect center for some reason?

Only other option I can see is to use a different transmitter and hope for the best.

only input should stop it.  - and deadzone ensures that it does not need to be a "perfect center"

make us a short log of such attempt:

1. in stabilize, Arm

2. fly to 5 meters

3. Enter Alt-Hold

4. auto-tune on

5. no input from you  .. wait 4-5 seconds,

if no twitching, land, post log

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service