So I am following the guide for AutoTune and I put it into AltHold and then flip the Ch7 button I have assigned to AutoTune, and it does not start twitching or doing anything.

I do have some trim settings changed on my tx and I'm curious if that could have impact on stopping the AutoTune from starting because the pwm values might be set out of the required range.

Log File C:/Program Files (x86)/Mission Planner/logs/QUADROTOR/1/2015-09-16 10-36-45 61.bin.log
Size (kb) 4716.119140625
No of lines 66648
Duration 0:00:00
Vehicletype ArduCopter
Firmware Version V3.2.1
Firmware Hash 36b405fb
Hardware Type
Free Mem 0
Skipped Lines 0

Test: Autotune = UNKNOWN - No ATUN log data
Test: Balance/Twist = GOOD -
Test: Brownout = GOOD -
Test: Compass = FAIL - WARN: Large compass offset params (X:-72.00, Y:-325.00, Z:95.00)
WARN: Large compass offset in MAG data (X:-72.00, Y:-325.00, Z:95.00)
Large change in mag_field (53.74%)

Test: Dupe Log Data = GOOD -
Test: Empty = GOOD -
Test: Event/Failsafe = FAIL - ERR found: FS_BATT
Test: GPS = UNKNOWN - No GPS log data
Test: IMU Mismatch = GOOD - (Mismatch: 0.31, WARN: 0.75, FAIL: 1.50)
Test: Parameters = FAIL - Bad parameters found:
THR_MIN set to 400.0, expecting less than 200

Test: PM = GOOD -
Test: Pitch/Roll = GOOD -
Test: Thrust = GOOD -
Test: VCC = GOOD -

After noticing my compass is not calibrated could that be part of the problem? I just recalibrated it and I'll have to run another flight test later when new props come in to see if that issue is resolved. Obviously, I have the pre-flight check disabled which is why it allowed me to fly with a failed compass. I have no GPS attached to my drone.

I set the THR_MIN to 400 because all the motors were not starting simultaneously otherwise.


I'm going to post the log file here. This is a major problem as my drone really needs to be tuned. Am I going to have to tune it manually?

Views: 354

Attachments:

Reply to This

Replies to This Discussion

Oh I think it's because I wasn't putting the throttle at 50% during testing.

I will try this and repeat at a later date.

UPDATE: The autotune is still not working at 50% throttle. When testing attached via USB with the battery unplugged, MP says that it is in AutoTune mode. I re-calibrated the compass, and it now gives warnings but not FAIL. So I think the compass should be ok.

I am using these SimonK ESC and I am assuming at this point it is a compatibility problem with the Pixhawk. It would be VERY nice if someone who knows anything about this could comment. I'm kind of sad because AutoTune is pretty important, and since I'm going to be changing my drone a lot, I can't afford to manually tune it every time I add or remove something from it.

Having a similar problem here: http://diydrones.com/forum/topics/autotune-on-v-tail-quad-not-inita...

Though my Ch7 gives me full amplitude my copter does not go into AutoTune. Also Mission Planer does not display that AutoTune is enganged.

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service