Hi All,

I have flown my quad 12 times now, using the stock pid param as per 3.2.1

I get ~25min per flight with small HD Tube nose-mounted FPV cam.

I now want to attempt Auto-tune to optimize the rig.

 I don't think I am experienced enough to do PID tuning manually.

However, I read somewhere around that Auto-tune can fail on bigger, heavier quads, with low kv motors.

My build is based on the Tarot 650 Sport Quad Frame (X-config)

FC - PixHawk (3.2.1)

Motors - Tarot 4114  320kv    

Props - CF 1550

ESC - HobbyWing Xrotor 40A

Batt - 8AH 6S

AUW : 3kg

1) I would like to know if Auto-tune can be done successfully on this build.

2) Do you recommend that I first upgrade to 3.3.3

Thank you for your valuable comments.

Regards,

Gerhard

Cape Town, South Africa

Views: 3458

Attachments:

Reply to This

Replies to This Discussion

Hi Steve,

Quad's Thr Mid setting hover is @ 400,  see attached pic.

Prior to Atun, with bad vibration, I had the same experience that, when changing from eg AltH to Stblz,

the vehicle would loose Altitude sharply, had to Thr-up to get it on level again.  Once the vibration was resolved, with ATun, I find now that changing FM from eg AltH > Stblz (Thr was at Radio mid-point setting during FM Change) the vehicle would in fact climb, such that I have to Thr-down a little, to get it on level. Same with changing from PosH > Stblz. This behaviour is however exceptable to me.   Changing FM from AltH to PosH and back, does not in my case result in an large step Alt-change, such that I have to use the Thr stick. 

I am really not experienced at all to offer sage advice, however these are the basic points

that I have focused on, apart from the normal model Mandatory Init
Config and Extended Config etc,  which I recon that you have done as well -

1) Radio TX sticks centred.

2) ESC's Calibrated for your ESC's brand/model.

3) Vibration within acceptable levels.

4) Set Thr Mid point for Hover in FM Stblz (mine @ 400)

     I assume you followed this How TO ?  >>http://ardupilot.org/copter/docs/ac_throttlemid.html

5) AutoTune to satisfaction.

I hope this helps?

Regards,

Gerhard

Attachments:

try setting AUTOTUNE_AGGR to 0.1 (instead of 0.05)

I followed steps on the wiki for setting thr mid and all other needed calibrations. On previous flights I looked at imu and saw that vibe looked great so I tried originally to go for loiter right off the bat (since I never had problem with alt hold before). On start of loiter it dropped like a rock and I barely was high enough to recover(see loiter_fail.bin). I then went back looked at all the data confirmed calibrations looked good and tried alt_hold instead of loiter. Same thing happened(see alt_fail.bin) ..the throttle in and throttle out do not match I've noticed. throttle out drops but throttle_in does not?

I'd love to try autotune but If I can't figure out issue with alt_hold I'll never be able to tune it.

Attachments:

Hi Steve

You did not indicate what mode you were switching from before entering Alt hold and Loiter but I presume it was stabilize.  Depending on the weight of your multirotor, and the power of your motors/propellers your machine maybe over powered or under powered. Conversely the flight controller throttle output level may not be 50%.  Alt hold, loiter and autotune need the throttle out to be at 50%. So perform a 1 minute hover, down load the log and see what value the throttle out is at. Lets presume throttle out on your multirotor is at 60%, this means your multirotor is under powered. So when you switch from stabilize in hover mode to loiter the flight controller switches throttle out back to 50% and hence your multirotor will lose altitude. Again if the stabilize test hover mode throttle out is 60% enter this value into the Throttle mid setting. Now the flight controller knows the actual power required for your multirotor and switching flight modes should be almost transparent. There is one other setting you may want to adjust, this is throttle deadband, this effects the amount of deadband of your throttle stick when hovering in Alt hold or loiter. I have my pixhawk set to 75 and works pretty well. Once alt hold works correctly you can start Autotune. If the throttle is not set to the 50% or in your case a modified value autotune wont start. In my case I had to fiddle a bit with the throttle stick in order to get autotune going.

Hope this helps

Just had a look at your Loiter fail. bin. Sorry I missed it. Your hover is around 55% so your machine is under powered. Having the Throttle mid at 40% makes the situation worse. Enter 55% into the Throttle mid setting. You could consider upgrading to the next Lipo battery IE S4 to S5, or S5 to S6 to give your multi more power.

Cheers.

I should have looked at your log earlier so I apologize, I can see you are running a 4S lipo the cutoff voltage for safety of your machine for 4S should be in the area of 14.4 but no lower than 14 volts. You reach this in the first 3.5 minutes. I think your battery miliamp capacity is too small. I also notice you flight controller voltage is quite dirty and too low. It appears you may not be using an APM power module? Pixhawk needs 5.3 volts because of the internal hardware has an isolation diode which drops the voltage by .3 volts. Your VCC low peaks are at 4.85 volts. 

I will go to bed now. Its night time in Auz.

Thanks Henry for looking

Couple things - I'm fairly certain on the loiter the throttle mid was set at 550. I know the alt_hold_fail.bin was 100%. But regardless of it if was 400,500 etc..I don't see why the throttle out for a moment drops to 200.  I have done alt_hold on other vehicles that were under powered and never ran into any issues.

This vehicle as you mentioned is 4S and I'm using Lithium-Ion batteries. I'll have to check but I was fairly certain I had power module on there powering the pixhawk. I'll have to check again.

I'll look into maybe if my firmware is old and see if there was a bug with alt_hold.

Wait Lithium ION?not LiPo?what is your C rating?

There was an issue with althold

https://github.com/ArduPilot/ardupilot/blob/master/ArduCopter/Relea...

line 16:

"1) Bug fix for desired climb rate initialisation that could lead to drop when entering AltHold, Loiter, PosHold"

Thank you! I will have to confirm my pixhawk's are both up to date. I was fairly certain that my newer vehicle had most up to date firmware but will double check.

I need to double check but I think its a 4S5P pack so 17000 mah @ 2C rating(at most) I can draw about 34 amps. I think on a slightly less heavy version I flew it for about 25 minutes. I recently added about 300g which I think from calc's didn't pose a problem power-wise.

Hi Olivier

       Out of curiosity, what were you PID setting for that size x8?  

cheers.

-Matt


Olivier said:

As an example here is a 12KG X8 with low 170KV motors (I fly it up to 18kg AUW) that successfully autotuned,  no issue at all.

Cheers and good luck!

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service