Pixhawk, Arduplane 3.2.2.

Hello guys,

having a problem to make EKF to work. 
As soon as I put the EKF_ENABLE 1, the massage "BAD AHRS" appears on my Mission Planner screen. I couldn't find any similar topic on other forums so you're my last chance =)

I thought that it's might be a hardware problem, but both of my Pixhawks acts the same. The IMU pin legs connections on PCB are also look fine. All the initial calibration were made.

I also had an idea that it might be a wrong EKF_ or AHRS_ parameters problem, but I varied them without any successful result. 

Both IMU seems to work according to log file. But most of EKF'1-4' logs shows zeros. Since it was recorded indoor so I turned off the "AHRS_GPS_USE 0", but even with its on and outdoor the result is the same - "Bad AHRS"

I also noticed that INS_PRODUCT_ID turns to "0", saying that IMU is unknown, but not 5 as it should be for Pixhawk.

Please help, I spent the 2 days solving this problem without any results!

Here are the Parameters and Logs.

Views: 41132

Reply to This

Replies to This Discussion

Turns out the problem is not really a problem.

It only manifests if you have a very low quality 3d fix. As far as I understand, because of the bad fix, the EKF is having a hard time reconciling the barometer altitude and gps altitude, as well as the compass heading and the GPS heading.

Take the plane outside and all is well. I should make a note on the github for the wiki to mention this under the AHRS error FAQ.

I'm having the same problem, and it's driving me insane. If I move the body of the plane, as an addition I also get ERROR VELOCITY VARIANCE and ERROR POSS HORIZON VARIANCE.

Using Arduplane V 3.5.0 (379ca5ac)

Someone please help. This is my third day trying to fix this. I'm NOT a programmer so please give a basic answer. I'm hoping there is a parameter in Mission planner that I can look for and change a setting.

Take your plane outside and wait for a good hdop and the error will probably disappear. Let us know!

Thank you, I will do that. It's raining heavily at the moment and not expected to clear for 24 hours but I will get back to you.

I also am getting more BAD AHRS errors than normal. There are probably some parameters I can change to desensitize the error message. I have looked but not sure what to tune. Does anyone know what to adjust to make this error message less sensitive?

It does clear after I fly for a while but I am unconvertible sending it off on a waypoint mission with a BAD AHRS error showing. It seams to have gotten worse with the last airplane firmware version.




I am also on 3.3 plane and having the same problem with "Bad AHRS"  None of the solutions here seem to work for me.  Has anyone else solved this on plane? or just copter?

Airplane 3.6.0 has solved this problem. For me it has totally gone away.

I have this same Bad AHRS in plane 3.7.1 MP 1.3.43.

Done all the stuff suggested. Recalibrade, power down/up, etc.  Only time it doesnt happen is when I take the plane outside.

Any updates from anyone else?

I'm with the same version of Fw and same problem as yours. Is there a solution? Any firmware that corrected this error?

Mike said:

I have this same Bad AHRS in plane 3.7.1 MP 1.3.43.

Done all the stuff suggested. Recalibrade, power down/up, etc.  Only time it doesnt happen is when I take the plane outside.

Any updates from anyone else?

i have this problem running arduplane on pixhawk, runing the same firmware..only is mine shows up after powering and it goes away after 40sec. consistantly.

I'm about ready to throw away a brand new Pixracer because I can't get rid of this error.  I've tried all of the fixes listed here and elsewhere and it continues to happen.  It's really starting to piss me off.

I left the Ardupilot world over three years ago because I couldn't get beyond compass problems on the then new Pixhawk, but recent hardware and software looked interesting so I decided to give it a try again.  But wasting a weekend on this probably is about ready to drive me away again. We REALLY need some way to get more info about these errors and what's causing them.  Does anyone know if it's caused by the IMU, GPS, barometer, magnetometer, phase of the moon????  How can we debug these things?

I'm running the latest release Plane firmware on a new genuine Pixracer with AUAV.co GPS and other accessories.

Hi lately i Have did 3 test flights regardless of the compass variance and bad ahrs i have. All safe landing and recovery.

since the bad AHRS flag went off after 40sec consistently, i assumed like other Avionics on an airplane we have 7 mins to realign the INS IRS and gyro. so i gave it a go call.  the only problem i had was with the Compass alignment keep on getting compass variance, by crosschecking with actual compass the primary compass seems to giving out correct reading +- 2 degree which is acceptable for flying. gps hdop was good.. so i turn off the 2nd onboard compass. ARMed  and There she goes. though from time to time   I had a compass variance flag due to  EKF. 

Reply to Discussion


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service