Pixhawk, Arduplane 3.2.2.

Hello guys,

having a problem to make EKF to work. 
As soon as I put the EKF_ENABLE 1, the massage "BAD AHRS" appears on my Mission Planner screen. I couldn't find any similar topic on other forums so you're my last chance =)

I thought that it's might be a hardware problem, but both of my Pixhawks acts the same. The IMU pin legs connections on PCB are also look fine. All the initial calibration were made.

I also had an idea that it might be a wrong EKF_ or AHRS_ parameters problem, but I varied them without any successful result. 

Both IMU seems to work according to log file. But most of EKF'1-4' logs shows zeros. Since it was recorded indoor so I turned off the "AHRS_GPS_USE 0", but even with its on and outdoor the result is the same - "Bad AHRS"

I also noticed that INS_PRODUCT_ID turns to "0", saying that IMU is unknown, but not 5 as it should be for Pixhawk.

Please help, I spent the 2 days solving this problem without any results!

Here are the Parameters and Logs.

Views: 31081

Reply to This

Replies to This Discussion

@Hisham - So to fix the AHRS problem, you just turned off the internal compass?

i had the same thing, and performed an accell calibration, and it fixed it. 

if it happens often, apparently, re-arming with the plane still fixes it for some, but this is the long term solution. 

hope my experience helps others. 

I made several attempts to calibrate the compass and the error persisted. After reading in some forums the similar experience of a colleague, where he solved the problem by downgrading to the first firmware version for arduplane. I did the same and my problem was solved. With this older version of firmware running perfectly on my plane, the only thing that has changed is that the engine is always armed, so be careful with the throttle stick as the engine starts as soon as you move the stick.

Same issue have run through everything. But it seems there has always been issues with this and were told its not GPS  the settings are to strict repower. Looking below is questions from 2015 and Ive seen them going back to 2014 so there must be a definitive answer seeing as though its been happening since the inception of the board.

PLEASE HELLLLLP!

Are you using a compass? I get this using planes without compass and makes sense that I get the error, because the AP can't determine heading while stationary without a compass. As soon I take off the error disappears. If you have a compass, it might be a calibration / variation issue. 

Hey Hein I dont have an external compass no just gps and the Pixhawk. I didnt realise u needed or could get an external compass. I can not arm with the error so ca not get in the air. Even with the internal gps off.
Any chance you can explain how you arm and any other pointers you may have. Its really strange as the really cheap boards dont have this issue and this was exspensive.
O and I have recalibrated everything also. Even did a setup from scratch, and loading param file.still nothing. I also cleared the entire preflight check list. Still nothing.
Cheers

Hi Gus - are you flying copter or plane? If copter - you need a compass - then you just need to make sure everything is calibrated and take it outside- the AHRS error should disappear. With plane (with all compasses disabled), you'll still have the error on the ground outside, but just ignore it.

Gus

I also have this problem. However I can arm by disabling the INS bit in parameter ARMING_CHECK.

Andrew

Gus said:

Hey Hein I dont have an external compass no just gps and the Pixhawk. I didnt realise u needed or could get an external compass. I can not arm with the error so ca not get in the air. Even with the internal gps off.
Any chance you can explain how you arm and any other pointers you may have. Its really strange as the really cheap boards dont have this issue and this was exspensive.

I'm still in the process to understand how everything works, and I'm stuck with my RC controller. I've bought the Spektrum DX6i controller but I don't  know how to connect it to my apm board (see picture). It must be something very simple but I could find the answer on the web or on youtube. https://reviewsdash.net/best-fishing-drones/

Have you carefully gone through the documentation? Unfortunately apm is no longer supported. There are many low cost boards (cheaper than apm).

Reply to Discussion

RSS

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service