Dear all,

I'm facing an issue and wondering why my Battery (6s 12000mAh) supposed to provide a 35mn flight time just gives 20mn (Out of Battery)... Then, Check voltage after landing... 23.24v (50%).

Details:

C Rating is:10

Battery Voltage to failsafe was 22.2 - 1000mAh

Curr. Volt (Min.:2167; Max.: 2268; Mean: 2238)

Curr. Curr ((Min.:0; Max.: 3104; Mean: 1151)

My Lipo is pretty brand new but...

Please see the pics in attachement

Thank you for your help

Regard

Views: 268

Attachments:

Reply to This

Replies to This Discussion

Likewise, I am getting a red-blinking warning light after 30 seconds of flight time on either of the batteries I use.

I am thinking we both have a payload-strain issue where the discharge we are asking of the batteries is just too great. Heavier payload, winter conditions and having to compensate for high windswill drain the battery quickly.

What calculation are you using to determine the 35 minutes of estimated flight time?

I am using the Multistar 16000 10c 14.8 volt battery, with a payload of 10 pounds on an x8 where each motor should have a theoretical lift of 3 pounds: 24 pounds in total. Makes no sense why the red blinking light goes on almost right after liftoff. I've posted the question in another forum, and will let you know if I get (us) any useful answers.

You can also email me if you like at pq652a@yahoo.com.

Peter

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service