Hi guys,

I've got a quick question about the battery voltage percentage shown on the HUD of the APM mission planner. My setup is to measure the total pack voltage (option 3) via the onboard ADCs (not using the Attopilot sensors) and the voltage readout is correct. The percentage reading, however, seems to read 100% constantly, even as the battery voltage reduces. Does anyone know how to get this display to function correctly? I assume that I need to set a maximum and minimum pack voltage to let enable it to figure out the percentage but I can't see an option for this anywhere?

Cheers,

Owen

Views: 2734

Reply to This

Replies to This Discussion

I have noticed the same problem.  Also using total pack voltage (option 3) and onboard adc's

The % is for xbee/mavlink connection strength.  The farther my copters go from my laptop, which has xbee to mission planner, that number drops.

no, that's the % in the top right of the screen.  We are talking about the % in the bottom left of the screen.

My guess is that the battery percentage readout is decremented when you have a current sensor connected. Then it can count down based on the battery capacity that you've configured.

All the attopilot sensor does is apply a voltage to the analogue input proportional to the current it senses.

You need to use BATTERY_MONITOR mode 4 if you want to track battery usage. Definition of the values for BATTERY_MONITOR are as follows: 

0 to disable battery monitoring,

1 to measure cell voltages for a 3 cell lipo,

2 to measure cell voltages for a 4 cell lipo,

3 to measure the total battery voltage (only) on input 1

4 to measure total battery voltage on input 1 and current on input 2.

 

BATT_CAPACITY should be set to your battery capacity in mAh. I set mine to a lower value so that even if I hit 0% I am not in danger of damaging the battery, but this is up to you.

 

Once setup it counts down based on the signal from the current sensor. 

I just tried it out with a constant 5 V input. The reported rate of depletion depended on the Volt/Amp setting I chose, as one would expect.

Note that once you go below 0% it underflows and you'll see 6400% or so, at least for APM. Either arithmetic doesn't check for underflow or there's a signed-unsigned misunderstanding between APM and the planner.

Ah I see, so the percentage readout is based on the current measurement from the attopilot sensor. Makes sense that it isn't changing then as we aren't using the attopilot, just measuring voltage directly on the APM. Looks like the attopilot sensor is going on our wishlist!

Cheers guys!

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service