okay....I'll give you the rundown...
 
so....i have a quad that was flying BEAUTIFULLY. like absolutely perfect.
 
One day i had a charger die so i ordered a new one and the quad sat for about a week while i waited for a new charger, GPS casing, new props, and a couple new batteries
 
When all the parts came in, i charged the batteries right up, re assemble the GPS unit, went to the field to calibrate, and the thing would stay off the ground for more that a few seconds.
 
I originally thought it was a motor issue.
 
so i got all new motors.,,,which didnt work....
 
so then i thought it was an esc issue.....got new ones.....didnt work....
Firmware issues? Nope....

Settings issues? Maybe, but i can't see anything wrong.....
 
then i thought maybe the wiring went bad.....rewired the whole thing.....didnt work
 
so maybe the pixhawk flight controller was bad......ordered a new one.....nope....
i have to crank max throttle to get it up in the air at all.....and then it either just starts to fall or blacks out all together.....
 
i am out of ideas.....and really upset that i cant get this *EXPENSIVE* project in the sky again....
 
i'm not sure why it was working just fine, then decided to just no fly again.....

No profanity, no hate.....i just need to get this thing to fly. Any and all help is greatly appreciated.....

6600mah 3s battery
pixhawk flight controller
30 amp esc's
900 kv  propdrive motors. 
12X6 " props

Views: 126

Reply to This

Replies to This Discussion

Did you ever solve this problem? I'm having the same issue.

Try going to a 4s battery, I had similar problem and by adding more cells, it worked.

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service