Hi,

I have a very strange symptom with my 1 year old APM2.5 board.

I have used it without any issue for the last year. The board was sitting for the last three months in my Octo. Never used it since then.

Today I tried to connect to it via 3DR radio, powering the board with a lipo->"Connection time out" in mission  planner. I looked for every possible cause : cables, configuration, etc.

The radio are fine since I could change the local and remote radio units through the config utility. So that puts the radio out of the loop.

 I then decided to connect directly by USB cable -> Windows looks strangely enough for a driver and does not find it. What the heck...It always worked and the driver was already installed on this PC.

So I tried to reinstall manually the APM driver -> Windows did not want to install it.

Then I realized I had left the lipo battery connected at the same time of the USB cable. I disconnected the Lipo battery. Then Windows found the APM MEga 2560.

For 3 seconds the LEDs turn on on APM when I plug the USB cable but turn off after and the COM ports disappears from the device manager.

Could I have a bricked APM ? What would cause this as between the last time the board worked and now, nothing changed on software or hardware level ?

Should I ship the card back to 3DR for analysis ?

Views: 9743

Replies to This Discussion

i did another tentative to connect on APM with another USB  cable. This time I get COM11 in device manager.

Then still impossible to connect, neither in CLI, neither to flash the firmware again. It gives me sometimes this message, sometimes a communication error :

although device manager sees the COM port:

I see LEDs as following on APM:

-green fixed led next to GPS port

-a flashing red led : double short red flashing.

It stops in the middle here :

and then gives yet another error message I get trying to flash:

First check how is that USB connector on APM working....maybe its broken.

Yeah, I will have to take a look at the board itself for any fried component.

It must be something that was destroyed by a voltage spike. Are they specific components on the board I should check with a multimeter? (I do not have more sophisticated tools to investigate the SMD components, unfortunately.

Once iwe connected all wrong,and fried something on output side so now I power my APM from imput side(jumper on) and it works fine....luckly my Pixhawk just arrived....

I guess I'll have to swallow the fact this card is definitively broken...and get a second pixhawk as replacement. I will post hereunder a video showing the behaviour of this damned APM 2.5 when trying to flash a new firmware.

Here a video I made to explain the problem:

Has this APM2.5 board been in storage for long enough, that its installed MAVLink version is simply incompatible with the present version in Mission Planner?

I'm only asking because I had a problem with MAVLink incompatibility a while back, after pulling a spare board out of storage. I don't recall what that problem looked like though.

edit: there was probably a MAVLink-specific error message when I had a problem. so this is likely not the same problem.

Yes it was unused for at least a couple of months but I doubt my symptoms are the same, because even via USB I can't communicate to the board.

when I connect my half broken usb connector I have to hold it or move it until I hear sound from windows and than not touch it...did u try to connect power to input side with jumper on?

Hi Emin, thx for your suggestion. I will try that although I doubt it is the issue because I also tried the ISP 6 pins interface without success. I would really like a hardware diagnostic of this board at least to understand how it broke up (and avoid it for the other boards).

If anyone from 3DR reads this, could I sent you the card back for analysis?

Please go to MP Help tab and select Show console and repeat the video so we can see the messages in the console window.

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service