Hey gang, thought I would just start a thread on a retrofit I'm doing on a Fury Ion camera ship that I'm going to take into the Arducopter realm.  I've got my 3DR hexa running pretty well but need to use the Ion for much larger camera work so it's time to rebuild.  Just as a bit of background I've been flying traditional helis for just over a decade 6 years of which I've been a team Hirobo pilot.


Currently I've got an APM 2.5 with a ublox GPS integrated along with a 3DR radio.  The Ion is running 700 Radix FAI blades and the stock flybar and paddles setup.  I removed the paddle weights I was using for manual AP work.  I'm using the stock Ion motor (Hacker C50-15XL) on ~20/1 ratio at ~ 1700 rpm.


I've currently got stabilize mode working fairly well.  One point of note, when doing the mechanical setup I noticed that there's not a whole lot of rudder throw once the servo is setup with the stock PIDs.  I changed the Rate PID to 1.25 to get the throw I thought was correct but that was NOT a good idea, had serious tail wag issues.  For the experienced heli pilots, trust that the throw in flight will be close to right with the stock PIDs!  I'm currently set at .350 P for yaw rate and dropped the roll/pitch stabilize values from .700 to .550 to get the airframe to settle into a reasonable hover.


More to come as I get a chance to test GPS hold.



Views: 1248

Reply to This

Replies to This Discussion

Great to hear.  Good luck and let's see some pics when you're ready!


I'm based in Japan and I've run into a couple of Hirobo people at a UAV conference.  They seem to be working on a full size competitor to the Yamaha RMAX...that's my understanding anyway.

So I did encounter a bit of an anomaly in that I see to be getting jitter on the swash servos which don't seem to do so if connected directly to the receiver. Any ideas on what I might be doing wrong? I have a castle ultra BEC unit powering the apm on the output rail as well as the receiver and radio electronics. Voltage set at 5.4v.

I got the Heli working ok in stabilize mode but the jitter seems to be coming from the apm unit output.
Another issue I noticed is that swash servo ranges hs1 -hs3 keep resetting to 1000-2000 after power down and power back up. I can write and refresh and see the correct values but they seem to reset after a power off. These are the only parameters that see to do it, my flight modes and gimbal config all seem to stay.

Any ideas where I went wrong?

hmm..jitter could come from at least two places.  Either the controllers are changing their mind a lot about what the output to the servos should be, or perhaps the servos aren't happy with the update rate.


I've always found that the servos hum a bit when connected to the APM..much more than when connected to a normal radio but it's never caused me any problems in flight.


Could you try reducing the RC_SPEED parameter at least to see if the jitter goes away.  I think it's 125 by default for the heli and you can find it in the mission planner by clicking Configuratino, Standard Params, Adv Parameter List.


     After you do the swash plate set-up are you pushing the "save" button?  I strongly suspect you are but just wanted to check.

     The parameters that are causing you trouble are here?

I also checked out the HS1_MAX and MIN, etc on my machine and it seems to be working ok...

Hey Randy thanks for the reply. I have been hitting save, also tried setting manually in the advanced params list. The write takes and refresh shows the values but it resets those three only on power off power on each time consistently. All other params seem to stay including zero and swash degree settings.

I'm manually working around it using good old fashioned mechanical setup for now. I'll try the RC speed param and report back. These are futaba 9252s that seem to serve me well in several helis.
RC speed didn't change it, tried 333 and down to 71 hz.

Paul, can you look in your parameters, and see if AHRS_GPS_GAIN is set to 1, or 0?  If it's 1, that is likely the problem.  In that case, try arming the copter, and see if the jittering stops.  Please report back.

Another possibility, when you say jitters, do you mean that when sitting still, they are moving?  Or do you mean that when you move the stick, the movement is not as smooth as you'd expect?  If that is the case, I think it's "just the way it is", the APM isn't updating the servos as fast as an Rx direct does.  Either that, or we've lost some precision somewhere, because I've noticed it too.

Paul, can you go into the first tab of MP, and where the map is showing, at the bottom you'll see a box which says "tuning".  Check that, and little graph window will pop up.  It'll probably be graphing something default.  Now, on the graph, it's either a right click, or a double left click, that will pull up like a menu with all the things you can graph.  Uncheck all the boxes, and then check the one called "Freemem" or something like that.  Then close the menu, and look at the graph.  How much free memory do you have?

We recently ran into a problem where we are running out of memory, we discovered this on quads, and helis use even more.  This is really bad, and can cause weird things to happen.  I had a really weird situation pop up once.  Then the fact that you are using a camera gimbal... it might be you're totally out of memory or something.

Just a crazy idea.  This was fixed for 2.8 or 2.8.1, but obviously you can't use that yet for TradHeli.  It can be solved in the short term if you can compile and upload your own code manually.  We should have this all sorted out shortly.

Hey thanks for the Response! 


For the jitter, the behavior I am noticing is that while sitting on the bench, motionless with TX on and heli ready to run minus ESC batteries connected (running opto isolated on 10s), the swash only servos (just those three) are moving back and forth very slightly and rapidly, you can very faintly see the swash buggering side to side if you watch it closely.  The movement is very small and rapid, almost as if the servo isn't finding center.  I checked all three into the RX directly bypassing the APM and each sits perfectly even under load when direct connected to receiver.  I'll check the AHRs config when I can get back down in the basement tonight and report back.  I'll also check the memory tracking you mention below and try to get screen shots.  Thanks again for the help!!!



Here's a quick pic I took of the rig last night.  I've been running it without the APM stuff for about 7 years now (mostly manual or helicommand controlled for the AP/AV jobs I've been doing).  I designed and machined everything on there using the CNC shop i have in my garage.  More on that later...


Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service