I'm struggling a bit here, and I apologize if this has been discussed, but I was unable to find anything relevant on the topic. Thank you for your help, everyone.

Here's the scenario: I am running Plane on a Pixhawk, all the latest f/w, controlled by a DX7s (I know), and a DMSX satellite RX. Plane flies great manually, tuned, vibe checked, all great. Telemetry is all in order.

However, I'm ready to explore auto flight but cannot for the life of me figure out why my Flight Mode is asking for PWM channel 8 instead of 5, which is the 3-way Flap switch (that works just fine in Copter). 

I've played around with the switch mapping and some mixing, but I really do not need 6 flight modes (and I'm concerned that a PWM value on the 'cusp' of another range could switch inadvertantly to another flight mode). Does anyone out there know how I can resolve this otherwise petty issue? 

Thanks,

C

Views: 331

Attachments:

Reply to This

Replies to This Discussion

Correction: CH 6, not CH 5 is what I want to show up in the modes list. 

Well, after a few more times searching this forum, I found it. It's the FLTMODE_CH parameter... Change it in the tree to whatever channel you like. 

Attachments:

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service