Hi guys!

I've been away from the Arducopter community for around 2 years now. I never got the early APM1.x to work stable, so I've been using other FC's the last couple of years.

Do you think the newest Arducopter is a stable/solid solution now? Is it advisable to trust it for professional use with expensive equipment and cameras, or does it still have "bugs"? I will, of course, test the system extensively, but I would like your opinion before getting involved again.


Views: 4543

Reply to This

Replies to This Discussion

Ok, APM 2.5+ received, starting my Arducopter Project.

What Version is considered to be most stable, any recomendations?


Use 3.0.1 from Mission Planner. That is latest officiel release for ArduCopter. 

First flights with APM 2.6 with external 3DR compass/gps completed. Here is my first impression.

I'm using a cheap quad for testing purposes until I get to know the APM. Didn't want to risc my octo. I spent some confusing hours trying to figure out the compass. Could not get it to work correctly. It showed North when facing South etc. When disconnecting Compass, I still got Compass Readings but it was not correct. I had ordered a APM 2.6, but on the casing it says "2.5". So I suspected I had received wrong model with internal compass. I opened it up but could not see much of the trace that is supposed to be cut to disable internal Compass on 2.5. So I just cut a little between the pads. Voila, the external Compass worked! After setting everything up, calibrating Compass, accellerometers etcm and adjusting Rate P and a few other parameters, It flyes great! Rock steady Loiter and altitude hold.


Tomorrow I will test further and maybe "Fly to here". If everything Works this good, I will be moving the APM to the octo much faster than planned! Very impressed so far. APM has come a LONG way since I tried the earlier versions!


Does anyone know if APM2.6 has a internal Compass? I suspect the problem was that the Compass just was not "properly" disabled, if not I have received a APM2.5. No problem for me, but do you know if there is anything else I'm missing out on if I have received a APM2.5 instead of 2.6?

APM 2.6 should not have any compass installed at all.  Sounds like you got a 2.5 by accident.

Ok. Is there any other differences between APM 2.5 and 2.6?

All my glitches have been self-inflicted.  I have flown some extensive waypoint missions (2km+) with no problems whatever.  I have also had glitches on waypoint missions:

  • Not specifying an altitude on TAKEOFF, causing hexa to careen towards low obstacles
  • Forgetting to delete a mistakenly inserted waypoint in Mission Planner, causing hexa to try to fly to edge of known universe (RTL saved my ass).
  • 915 mHz FPV transmitter interfering with GPS and causing poor hexa to stagger drunkenly about
  • Poor vibration control causing altitude problems during flight

There are minor glitches, all of which are logged as issues, but on the whole I feel safe flying out of sight into the desert.  I'm still nervous (what did I mess up this time?) but so far it's working great.

Other than the missing compass, no, not that I know of.

Another day with success!

Today I experimented with "fly to here" and auto/waypoints etc. Everything worked. Even turned off my tx to test RTL/failsafe. It felt so wrong turning it off, but it came home and landed with no problems at all. This looks very promising!

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service