Can't calibrate compass on APM 2.5 - Big offsets

Hello everyone.

I'm having a very annoying issue with an APM 2.5 board. I can't manage to do a proper compass calibration. After getting samples for 60 seconds I get the offsets, and the first one is always way out of range.

I get around -215, -60, -100 every time. It varies a little bit, +-10 or so, but that's just about it. I didn't even manage to get something over -200, not even -199.

My first try was inside a laboratory with lots of equipment, so got outside. Still the same. Went to the street. Same results. Took the APM back home and tried it there. Same thing. I just went to my yard to try it out, with the same luck.

What might be the issue? Any ideas?

Thank you!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Do a mag test om terminal, unless the numbers make sense, the sensor is defective. Also, measure its voltage.
  • Admin


    How about providing a picture of your APM mount on your vehicle so we can get an idea as to where it is located on the frame?

    You might have to go to an outboard compass to resolve your calibration issue.


    TCIII ArduRover2 Developer

  • Sorry, I forgot to add that I have tried with and without the battery, cables, even the frame. I've even tried with just the board.

This reply was deleted.


Ben Sinnock left a comment on New Zealand DIY Drones Group
"Hi all, glad to be in the group. Apologies in advance but I have a great many questions."
14 hours ago
Hiroki Tanaka liked Hiroki Tanaka's profile
Oct 13
Itzik Ronen left a comment on VTOL
"BiCopter center of gravity.
I saw a code came out for Bicopter.
How far can the center of gravity of the BiCpter VTOL QuadPlane motors line can be?"
Oct 5
Derrick Davies liked lisa TDrones's profile
Sep 23
xemone liked Max Gilson's profile
Aug 31
nick rymer left a comment on ArduCopter User Group
"I recently switched laptops and now have Windows 10. I installed Mission Planner on my laptop and plugged a mRo SiK Telemetry Radio into the USB port. The radio is not recognized on the com ports but is instead on the "Other Devices" tab in Device…"
Aug 20