I've been trying to get the Tarot T-2D configuration application to run for a couple of weeks in a VM with no luck. I've tried VirtualBox with:

  • Windows 7
  • Windows 7, running the .exe in WinXP compatibility mode
  • Windows XP SP3
  • Windows XP, no SPs

Each time I get a dialog from Windows telling me the application has crashed and asking about sending an error report. I would really like to be able to point my camera somewhere other than straight ahead, but until I get this app working, I can't do that.

I got the application, along with drivers for the Tarot USB dongle, from here:


I can see the "Prolific" device in Device Manager, but when I get to step 3 at the above link:

Double click on the ZYX-BMGC-EN_V1.5.exe file (found in the above zip) and the configuration UI shown below should appear

the application crashes every time. I got the gimbal from a local hobby shop, so it's not ready to roll with my Y6 like the ones direct from 3DR are.

Has anyone done this in VirtualBox? Another VM? Has anyone seen these symptoms?

Views: 3500

Reply to This

Replies to This Discussion

It is my curse in life to figure everything out immediately after asking for help. There are worse curses, I suppose.

After many hours of internet searches and trial and error, I've just come across this, which says one needs to enable 3D support in VirtualBox so the app can draw that fancy 3D rendering of the camera.


I haven't tried it yet, but will when I get home. Posting it for others who may have the same problem.

3D was the problem, but it wasn't as simple as enabling 3D support in VirtualBox. Here's what I had to do:

  • boot Win7 VM into Safe Mode
  • insert Guest Additions disc from VirtualBox Devices menu
  • install Guest Additions and Basic 3D support
    • as opposed to experimental WDDM drivers
    • Guest Additions installer will ask you if you want WDDM, click "No"
    • this only works in Safe Mode, as the installer will warn you if you are not in Safe Mode
  • reboot into normal mode
  • follow the wiki


I just wanted to thank you for sharing this tip.

I actually had started to re-install an old laptop just to get this thing starting.

I would never have thought about the 3D support in VirtualBox.

Thanks for sharing, you saved me a lot of time.

I actually reported the problem to tarot-rc  telling them that it would be helpful to detect 3D support and return an adequate error message instead of silently dying.


Glad it helped.

Better error messages from that application would be very helpful indeed. Thanks for contacting them.


Just wanted to comment here - this had been driving me nuts for weeks. I managed to get this working within VirtualBox once I started looking at the 3D settings (thanks to this thread). However I followed a slightly different path, after booting into Safe Mode I tried the method above but it didn't work for me, so I enabled the experimental drivers which worked as expected.

Can't thank you enough, the Tarot software's complete lack of an error message had be completely stumped! 

Reply to Discussion


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service