Can't connect to APM2.5 on ArduCopter in configuration mode; terminal mode works fine

I have a quad copter with an APM 2.5 installed on it.  Last week I updated from the stock 2.8.* code to the newest (available through mission planner) 2.9.1.  Immediately after update, everything seemed fine, though I didn't try to fly it.  I disconnected power, installed my gimbal (A11) and camera trigger (A9).  When I reapplied power, I wasn't able to connect to it over the 3DR radios, so I tried the USB.  Same thing.  As a last resort, I tried connecting through USB in terminal mode.

Here is the overall list of symptoms:

  • LED "C" on the board is lit solid blue.  LEDs A and B are dark
  • On reboot, the board gets to Init Gyro and the terminal freezes.  Disconnecting and reconnecting gives me a functional terminal.
  • I can't connect from Mission Planner in normal graphical mode over either 3DR radio link or USB.  It gets some of the parameters and then the connection times out.
  • I can connect via terminal mode
  • I can reflash the board with apparent success
  • I can't run the ins test to completion (prints "Init Gyro" and then stops and locks the terminal)
  • The battery sensor is reporting 0 volts even with a fresh battery
  • I can't arm the device from my radio (didn't try through command line, and graphical mode doesn't work so I can't try it from there)
  • Powering on the device causes the ESCs to play their welcome song and final beep indicating (I guess) connection to the APM.

Here's what I've tried:

  • Disconnecting all ESCs, GPS, 3DR radio, RX module, and camera gimbal (leaving just the APM)
  • Erasing the EEPROM
  • Reflashing the 2.9.1 code
  • Reflashing the 2.8.5 code
  • Resetting parameters to factory defaults
  • Verified that neither the camera servo or shutter release cable had shorts in them.

None of that allows me to connect in configuration mode.  Does anyone have any suggestions?  Is the board just toast?

Views: 2143

Reply to This

Replies to This Discussion

Was the quad flying/working on 2.8?

With APM2.5, are you using the 3DR Power Module to power the APM?

What was your power source for the gimbal and shutter servo?


And here I thought I'd given every piece of information possible :)

  • Yes, the quad was flying on 2.8.  I flew it several times both using my radio (Spektrum DX8) and also via pre-programmed waypoints.
  • The quad is the ArduCopter 3DR Quad D - Ready-to-Fly ( with stock power module (I would guess 3DR)
  • I used the +/- power pins on A9 itself to power the servo (tilt mount only; it isn't near me right now so I'm not sure of the servo make/model).  I just plugged the servo connection directly into that port.



Just realized I left off one answer.  

The camera was being triggered using the "relay" mode, even though there was no relay attached.  This just sent +5V down a USB cable to a Canon PowerShot running CHDK.  The S and - pins were used on A9.

I used the +/- power pins on A9 itself to power the servo (tilt mount only; it isn't near me right now so I'm not sure of the servo make/model).  I just plugged the servo connection directly into that port.

Hmmm...that may have been a problem. THIS page on the adding the camera gimbal has this to say...

Warning:When using the APM Power Module or other dual supply setup with JP1 off, don't connect power from the A10 & A11 connector to the servos, just use the signal lines. Power the servos via PWM Outputs connector.

I would roll back to the previous configuration (I think that is what you were trying to do/did), no servo connected. In short take it all apart to the point where it was working so we can determine what is broken.

All the 'A' connectors are summed up for power distribution. This means that although you did not specifically connect power from A10 or 11, connecting to A9 was the same thing.

I will have to look over the schematic to see what may have given up electrically.

Do you have a very good inspection microscope or eye loops for tiny detail inspection?


I've been looking over the board layout (for APM2.5.2) and can not clearly see the +5 connection traces (even with all layers applied to the drawing. There was another warning about where not to connect the servos HERE.

WARNING:The diagram 'Typical QuadCopter Layout shows the gimbal servos connected and powered by the 5V coming from CH10/CH11. This will most likely cause a brownout. Please connect your servos for the gimbal to 5V/GND on the Outputs connectors and only connect the signal line to CH10/CH11 see AC2_Camera

The embedded link takes you to where I previously linked. The meaning seems be to use A0 - A7 (Pin 1 - 8) for power. A8 (pin 9) and A9 (pin 10) also are not clearly connected to +5VDC on the schematic; same for A10, A11.

This is a bit confusing, even to me, at this time.

I will go back to APM2.0 board for clues...

....nope, same connections though the JP name seems to have changed.

A search through the posts is probably in order the mean time you need to get back to a working condition...if you haven't damaged your APM. Roll back the hardware/firmware to what worked and let us know.


I see the warning that you cited.  Frustratingly, on the AC2_Camera page they show the gimbal's servo connected directly to A11.

As I mentioned previously, unplugging all of the external components (GPS, servos, motors, etc.) still doesn't change the behavior of the board.  It comes up with a solid blue LED each time regardless.  I suppose that drawing too much current from A11 could have burned something out, but that is substantially different than a brown out. Maybe a board replacement is in order.

If I shouldn't connect the servo directly to A11, where do I draw power?  Is that what you are suggesting pins A0-A7 are for?  Is there a harness somewhere that splits the power and signal wires allowing me to plug the servo's signal wire into A11 and power somewhere else?  

Sorry if these are obvious questions.  This is my first radio control craft that isn't a toy, so I'm really new to this.

After reading quite a bit, I think that I understand how you are supposed to connect the gimbal servo.

  1. Remove JP1 (jumper 1) to disconnect the "output" power rails from the analog and APM internal power rails.
  2. Connect power to the APM through the PM power-module connector.  This powers the board and its internal electronics.  It also powers the radio, Mavlink radio, and GPS.
  3. Connect power to the output power rails.  On my quad, this is a two-wire connection from the power distribution board used to distribute power to the ESCs.  When jumper 1 is removed, this power is dedicated to the output devices and does not starve the APM of power, so there are no brown-outs caused by the servos.
  4. Connect the gimbal servo's power to any of the +/- pins on output.
  5. Connect the gimbal servo's signal line to A11 as before.

I've tested this on a backup APM 2.5 that I have and it seems to work.  The quad shipped to me with power provided on both the output rails and the PM connection on the board and JP1 in place.  It seems to me, the non-expert, that this should have provided ample current to the board since the two connections should be summed, but I'm willing to believe that isn't true.  Removing JP1 should serve to isolate the servo from the APM and provide some additional protection.

I talked to uDrones customer service and they have generously offered to replace the board.

That is very kind of them.

I agree with your analysis above. Looking over the schematics and board layout all the way back to APM2.0 I still can not find trace connections for the +5 on the PWM Output lines - there are only 8, A0 - A7. A8 - A11 are the same situation, not clear as how it is connected on any layer of the board.

This may, or may not, be intentional on the designer's part. There is a name layer that indicated the center pins are +5 but without a clear trace, like seen on the Input connections, I can not be sure.

Here is a picture for show & tell (click on it for the full size):


Good luck and hopefully your experiences will be better and this one will help someone else.


I knew there was a great discussion about the gimbal connections.

HERE is the main thread.

HERE is a great diagram showing wiring - BEWARE the diagram is not quite correct regarding exact pin wiring. Consult the Wiki for correct places to put the pins.


Glad they're going to replace it for you Nathan, I have a APM 2 board with the exact same symptoms, it's never had a servo plugged in anywhere and has only ever been connected through USB and yet the gyro is dead.

There quite a few reports of this and one solution is to replace a 3.3v regulator on the board, otherwise send it back (and they seem to accept ones with these symptoms them back very easily...)

Is there any general consensus on what's causing the gyros to die?  I just threw out anything I could think of that might have been related, but proximity in time doesn't mean causation.  I'd like to keep from making the same mistake twice if possible.

Also, on the gimbal front, can we clean up the wiki page on camera gimbals?  It shows plugging the gimbal servo directly to A11 and A10, power and signal both.  Something that describes possible configurations would be more helpful than just saying "don't plug the servos into the analog outputs" for folks like me that are new to this.

Reply to Discussion


© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service