Can't connect to APM2.5 on ArduCopter in configuration mode; terminal mode works fine

I have a quad copter with an APM 2.5 installed on it.  Last week I updated from the stock 2.8.* code to the newest (available through mission planner) 2.9.1.  Immediately after update, everything seemed fine, though I didn't try to fly it.  I disconnected power, installed my gimbal (A11) and camera trigger (A9).  When I reapplied power, I wasn't able to connect to it over the 3DR radios, so I tried the USB.  Same thing.  As a last resort, I tried connecting through USB in terminal mode.

Here is the overall list of symptoms:

  • LED "C" on the board is lit solid blue.  LEDs A and B are dark
  • On reboot, the board gets to Init Gyro and the terminal freezes.  Disconnecting and reconnecting gives me a functional terminal.
  • I can't connect from Mission Planner in normal graphical mode over either 3DR radio link or USB.  It gets some of the parameters and then the connection times out.
  • I can connect via terminal mode
  • I can reflash the board with apparent success
  • I can't run the ins test to completion (prints "Init Gyro" and then stops and locks the terminal)
  • The battery sensor is reporting 0 volts even with a fresh battery
  • I can't arm the device from my radio (didn't try through command line, and graphical mode doesn't work so I can't try it from there)
  • Powering on the device causes the ESCs to play their welcome song and final beep indicating (I guess) connection to the APM.

Here's what I've tried:

  • Disconnecting all ESCs, GPS, 3DR radio, RX module, and camera gimbal (leaving just the APM)
  • Erasing the EEPROM
  • Reflashing the 2.9.1 code
  • Reflashing the 2.8.5 code
  • Resetting parameters to factory defaults
  • Verified that neither the camera servo or shutter release cable had shorts in them.

None of that allows me to connect in configuration mode.  Does anyone have any suggestions?  Is the board just toast?

Views: 2133

Reply to This

Replies to This Discussion

I can change the wiki but I haven't been following this subject very closely so if anyone could PM me the corrected wiki text?

Reply to Discussion


© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service