Hi I have an apm 2560, I have been trying to install new firmware and keep getting " can't detect apm version. Please check your cabling". it was working fine until I added the compass, also my xbees aren't working anymore either? I have since removed the compass and it still will not install new firmware. It will connect to mission planner and functions properly but I just can't upload new firmware?
Any help is greatly appreciated
Cheers
Lee. 

Views: 1180

Reply to This

Replies to This Discussion

Have you tried connecting via Arduino serial monitor? If you can connect via Arduino, you know your board is ok. I have this issue sometimes too and it's intermittent and works differently on different computers :( I attribute it to the fact that I am running APM Planner in virtualization via VMWare Fusion...sorry I can't be more  help.

Yeah I've tried serial monitor, nothing there either

2.0.54 is out. hoping it will fix our problems..

Ive tried uploading sketches through arduino 0023 IDE and It won't do anything it just sits on uploading to io board and then after 5 minutes or so I get a message in the black box under the sketch saying timeout avrdude stk500  
I also have another arduino mega, not apm though, and the code uploads to mission planner no problem.
Could my board be broken ? Do I need to replace it?

Are you loading it directly to the APM like this?

 

I guess it doesn't matter how you load it if you've tried another board. If you're within the 30days of purchase, I'd send it back. Get an RMA from the store :/

What's an rma?

just a return authorization so that they can go over your board and issue a return/exchange if necessary.

this is whats happening. the board works fine but i just cant upload new firmware

http://www.youtube.com/watch?v=apDndpkgUDA

http://www.youtube.com/watch?v=7H1UECal8BY

Thanks for you hint, but Now it says: 'Upload succeeded, but verify failed: exp 75 got 70 at 2' - what can be reason for that?

A quick question, is this a 3.3v FTDI cable or 5v FTDI cable? 

I am experiencing the same problem with my APM2.0, it works fine but I am stuck with 2.9 firmware, I get the same msg

" can't detect apm version. Please check your cabling" did you find out what was wrong with it?, please help...

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service