I really wasn't sure which section to post this in, so if this is the wrong section I'll apologize now and please point me in the right direction.

I've been reading through the every section of every website I can locate trying to find any help to attach and control a Walkera G-2D Brushless Gimbal to the Pixhawk controller.

I can't seem find anything about it. Let me first say that I am new to this so my experience is minimal. This is my first custom drone project.

I am in the process of building a new rig with a Tarot 680 Pro, DJI E600 motor system and the Pixhawk controller. I have a Walkera G-2D Gimbal that I would like to use.

Has anyone already attached this Gimbal to a Pixhawk?
Any wiring diagrams I can use?

The G-2D controller has a power input and three controller pins for Pit / Roll / AUX, but there is no Ground connector on the control pins.

Heres a link to the limited manual showing the wiring and connectors. (http://img.banggood.com/images/upload/2 ... Manual.pdf)

The diagram in the Wiki (http://copter.ardupilot.com/wiki/common-tarot-gimbal/) shows using the AUX 1 port S and GND pins. Im assuming the S pin connects to the pitch pin on the Walkera G-2D controller, but where would I connect the GND pin?

Any help appreciated.

SOLUTION CAN BE FOUND HERE:

http://charlottefpv.com/2015/03/how-to-connect-and-configure-the-walkera-g-2d-gimbal-on-the-3dr-pixhawk/

Views: 4976

Reply to This

Replies to This Discussion

So I finally got it working. I now have my Walkera G-2D Gimbal connected to my 3DR Pixhawk. I have full manual control over the Gimbal pitch and the Pixhawk should take control when i use mission planner with ROI and Follow Me modes (Still untested).

I've created a write up of what I did here:

http://charlottefpv.com/2015/03/how-to-connect-and-configure-the-wa...

Great write up Simon.

I have the same setup as you.  Taranis Plus, Pixhawk and G-2d gimbal.

I followed the instructions you have on the web page but was not able to get any manual control of the gimbal with the wires plugged into the AUX terminal.  After plugging it into the TILT terminal I have between 5 and 10 degrees of tilt.

I tried adjusting the min and max on APM to -90 and 90 but the output is the same.  I even recalibrated my Taranis through the menu on the the Taranis and then in APM but no difference.  I also tried the switch on the side of the gimbal in both position 1 and 0 to no avail.

Any ideas on which setting I might need to tweak to get more tilt range.  I'm using the RS slider on the Taranis.

Cheers

Aussie in AZ

Hmmm. Not sure.

Have you altered the Servo Limits?

I have mine set to:

  Min: 1200

  Max: 1780

My controller cable to attached to Channel 9 and the input from the receiver is Channel 8

After this, It seemed to work.

I did manually set the Gimbal angle using the POT on the Gimbal controller with all Signal wires disconnected first so If my controls failed it would still be at a good angle to continue videoing.

Good look.. Brit in NC :)  (Brother in Perth)

Cheers mate.  

I set the servo limits to what you have and messed with the V1 and V2 knobs on the gimbal.

All is good now.  From straight ahead I have about 75 degrees of movement up and about the same down down using the RS knob on the Taranis.

I'm a happy man!!

Thanks for your help

Aussie

Glad it helped :)

Hi Simon, 

I've made exactly what you said in your very good wiki but by tilt is not working, I could see a little tilt movement if i put connector in PIT gimbal input and I change the range of servo pwm output on mission planner.

Do you have you any suggestion for me?

Thank you very much

Niccolò

Niccolo,

I had the same problem you are describing.  

Make sure the cable is plugged into the PIT on the Walkera gimbal.

Make sure the settings are the same as what Simon has on his tutorial (except maybe the TX channel, mine was different)

After you plug it in and calibrate your TX in Mission PLanner, get a tiny flat blade screw driver and while the gimbal it powered up, adjust the PIT value (I can't remember if it was V1 or V2)

After you adjust it, the camera should be pointing down from where it was when you first powered up.

You will have to play a little as I did to get the most travel out of the gimbal.  I only got about 75 degrees (not the full 90) from the horizontal position.

After you make a tweak on one of the V screws, adjust the POT on your TX to see what it's doing.  Make more or less adjustment as necessary.

It took me a while of messing around but finally got the desired adjustment  

Please note that if you fit the gimbal back onto your Walkera aircraft, you will need to adjust the V screws again to suit as the settings will be all messed up.  I put it down to the different way the Walkera flight controller operates the gimbal compared to the Pixhawk.

Good luck mate

Aussie

Aussie described it perfectly.

Another thing that caused me problems was that I had the Gimbal powered from its own power source and then only a single signal wire from the PixHawk to the Gimbal controller.  This caused issues and once I also had a GRN wire and SIGNAL wire from the PixHawk to the Gimbal Controller Input, everything worked.

Keep trying... Its worth it :)

Thank you to everything for the answers! I've spent lot of hours trying to let the gimball work but I've lost my time, it's like the radio signal not arrive to the gimball, the gimball is correctly linked to the pixhawk because if i change the pwm value interval in mission planner the gimball will move but if I turn the potentiometer on my radio the gimball doesn't move!! I'm so tired I think that if anyone of you has an other idea i must buy another gimbal!!! LOL

I had a play with mine this morning to see if I could figure out what is going on.  I think I might have an answer for you. Here is how you set up the Walkera Gimbal.

Follow Simon's settings screen shot in Mission Planner for gimbal control.

Here is the part I might not have mentioned in my last post.  

Make sure your Taranis is switched OFF.

Fit your GoPro to the gimbal and power up your aircraft/gimbal and wait for it to initialise.

With the aircraft on a flat surface, adjust the V2 screw so that the gimbal is horizontal. You will not be able to control this axis with this setup.

Adjust the V1 screw slowly until the gimbal is pointing almost straight down.  Once the gimbal stop moving as you adjust the V1 screw there is no point adjusting it any more.  See pic 1927.

I chose the RS (right slider) on my Taranis Plus to control the tilt.  Make sure it is centered and fire up you Taranis.

After you power it up the gimbal should automatically tilt upward to about the straight ahead position.  See pic 1928

You should now be able to control the tilt from the RS knob.

The point is, the gimbal needs to be at it's lowest tilt so that when you fire up the Taranis, it will centre to the straight ahead position.

Let me know how you go

Cheers

Aussie

Attachments:

I can't adjust the V1 screw if my pixhawk is power on and the pit cable is connected! If I disconnect the pit cable the V1 screw work.

Is it the same for you?

Thank you

Niccolò

Try everything Aussie said, but it also sounds like your channel is not bound properly.

Are you 100% sure you have your channel coming through the radio?

When you go into calibrate your radio in mission planner are you correctly seeing the channel move on the screen?

Make sure you have the correct channel assigned in the Gimbal screen in Mission Planner.

Check your on the latest firmware version.

I know these are just basic things, but if your not seeing any movement whatsoever, then it seems like maybe the signal is not being passed through.

Good look.

Simon

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service