Cannot load firmware in pixhawk

Hello everyone!

I've been having problems in loading firmware to pixhawk. I've used apm planner 2.0 as instructed. Pixhawk is connected to the computer via usb connector with peripherals connected to pixhawk which includes GPS with magnetometer, switch, buzzer and telemetry.Everytime I start loading firmware, it instructs me to unplug the pixhawk and plug it again afterwards. Status message will then be "downloading" then, "attempting to find com port" and stops. I checked again the pixhawk port in  the device manager and still it is present.

Can somebody tell me what to do please? or is the lacking of peripherals affect it as well? I hope somebody could help and could give a comment. Your comments will be very much appreciated and is a great help for me for sure. 

Thanks in advance,

Cherry

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Hi Cherry,

    How's your Pixhawk so far?

    • Hello Jay,

      For now,  I'm still having problems in terms of arming. The peripherals connected were GPS, compass, buzzer, and the safety switch. I still can't do the Radio Calibration since I have problems on the connectors/wires. Have you tried arming it without calibrating? I can't, I just want to ask if you've tried it successfully or not, because apm can do arming without Radio Calibration.

      Thanks,

      Cherry

      • I think you need to press the safety switch first before arming. have you do this procedure?

  • Hello Everyone!


    Sorry for the late notice. I've already loaded firmware to the pixhawk successfully! Thank you so much for your comments. :) 

    I've unplugged the peripherals connected except for the safety switch and the buzzer, as what ItCanOnlyBeJared adviced. I've used apm planner 2.0 at first, but still nothing good happened. I've also tried using QGroundControl 2.0.1 beta version for Windows, that is for upgrading the firmware and it works. It stops until 90% yet the status says upgrading was completed. And so, I've opened again apm planner 2.0 and connect pixhawk on it. Luckily it connects but only at once. Connecting it for the second time, third, and so on doesn't work anymore. So, I again tried loading the firmware by using apm planner 2.0, and fortunately it was successful! :D

    After a very long wait hooohh! We just really have to be patient. :D I hope this could help. Problem solved! Another problems are on the queue. Let's just enjoy exploring pixhawk and see you guys on the next discussions!

    Kind Regards,

    Cherry

  • You should be able to flash your firmware properly with everything unplugged with the exception of the switch in some situations. Leave the buzzer plugged in too. That shouldn't interfere with anything at all.

    On my PX4, I tend to unplug everything since I hate the wires flailing everywhere. So I just leave in the buzzer and the safety switch.

    I tell you though.... These things are a pain in the arse.

    • Thank you so much. Your advice really helps! :)

  • T3
    I had issue loading firmware from my Mac running VM Fusion, so I switch to a real PC and it worked. I can access logs and parameter from the Mac, just not load firmware.
    • I have successfully loaded the firmware and I'm using WIndows 7. Thanks for the comment. :)

  • Hi I have the same issue I recently purchased a PX4 but have been unable to upload its firm ware. I have searched the forums and spent hours trying to get it to connect. I am now using APM2 after MP did not seem to work. The drivers (they say they are working properly), changed the SDHC used the battery to power up. I have the musical tones but it wont connect after I unplug and plug in same thing "attempting to find com port"

    I am about to try with out the GPS as this may be draining the USB port too much, other posts seem to have fixed this with the use of a powered USB port.

    Any advice here too will be appreciated.

    Thanks Gaz


    • Try unplugging the peripherals except for the buzzer and the safety switch. Loading the firmware on pixhawk is really one of the crucial steps but I know you'll get there! :) God bless you!

      Thanks for your comment,

      Cherry

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @Jetsonhacks: And I helped with the course! JetBot, JetBot, happy little JetBot! JetBot ... GO! Meet the Jetson Specialists Inspiring a…
11 hours ago
DIY Robocars via Twitter
RT @a1k0n: Designed RPi + camera mounts + new bumper for the new car. Fits great on the car first try, except my longest camera cable doesn…
11 hours ago
gotham liked gotham's profile
yesterday
DIY Robocars via Twitter
RT @RoboticMasters: Monaco GP Circuit in the Donkey Sim (coming soon). Including buildings, tunnel and all! https://github.com/robotics-masters/sim-donkeycar-f1/tree/f1-tracks @diyr…
Wednesday
DIY Robocars via Twitter
RT @breadcentric: Here are the details of #AWSDeepRacer finals: https://blog.deepracing.io/2020/12/01/aws-deepracer-league-finals-2020-round-1-schedule/ #awsreinvent2020 #AWSreInvent https://t.co/ovqsjp8V…
Wednesday
DIY Robocars via Twitter
RT @breadcentric: #AWSDeepRacer League #awsreinvent2020 Open race is on Dec 1st - Dec 31st in three categories, 15 DeepRacer Evo (with LIDA…
Wednesday
DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars It's just something that's easy to track with chroma keying. I ended up using different colors on th…
Monday
DIY Robocars via Twitter
Monday
DIY Robocars via Twitter
RT @TinkerGen_: "The Tinkergen MARK ($199) is my new favorite starter robocar. It’s got everything — computer vision, deep learning, sensor…
Nov 23
DIY Robocars via Twitter
Nov 23
DIY Robocars via Twitter
RT @roboton_io: Join our FREE Sumo Competition 🤖🏆 👉 https://roboton.io/ranking/vsc2020 #sumo #robot #edtech #competition #games4ed https://t.co/WOx…
Nov 16
DIY Drones via Twitter
First impressions of Tinkergen MARK robocar https://ift.tt/36IeZHc
Nov 16
DIY Robocars via Twitter
Our review of the @TinkerGen_ MARK robocar, which is the best on the market right now https://diyrobocars.com/2020/11/15/first-impressions-of-tinkergen-mark-robocar/ https://t.co/ENIlU5SfZ2
Nov 15
DIY Robocars via Twitter
RT @Ingmar_Stapel: I have now explained the OpenBot project in great detail on my blog with 12 articles step by step. I hope you enjoy read…
Nov 15
DIY Robocars via Twitter
RT @DAVGtech: This is a must attend. Click the link, follow link to read the story, sign up. #chaos2020 #digitalconnection #digitalworld ht…
Nov 15
DIY Robocars via Twitter
RT @a1k0n: Got a new chassis for outdoor races (hobbyking Quantum Vandal) but I totally didn't expect that it might cause problems for my g…
Nov 11
More…