Hi all


As of today I am unable to upload firmware to my APM.  Any help would be appreciated, here's the data I've got.


I have two APM units, one for my quad and one for a fixed-wing I am building.  As of a couple of days ago the quad unit worked fine, the last change I made was soldering in voltage monitoring leads and resistors.  After that it could still connect.  Today when I went to try .44 I chose the right port and speed and selected "upload firmware."  The mission planner hangs for ~20 seconds at "detecting APM version" and then errors out with the message "Can't detect your APM version, please check your cabling."  


I cannot get into the CLI at all, it hangs on "Opened COM port" with the switch in SETUP mode.  With the switch in FLIGHT mode it spits out a ton of garbage, as I recall is normal.


If I switch the shield from SETUP to FLIGHT mode and connect via MAVLink, it appears to work fine, the flight data screen shows sensor input.


My other APM unit works fine.  I tried swapping shields and the other shield on the quad's arduino gives the same error, while the quad's shield on the other arduino works fine.


Interestingly I can connect through MAVLink via my telemetry as well.


Any ideas?  It sure seems like the quad's arduino somehow got messed up, but I've no idea how to confirm that beyond what I've already done, nor have I any idea what could have caused it.

Views: 336

Reply to This

Replies to This Discussion

Check to see if the USB connector solder joint has been cracked or is loose. If you're not careful removing the USB cable you can damage the connector.

Doesn't look like it.  Also, if that were the case, changing to the other shield (with its own USB) would probably have fixed it, no?

Yes, you're right--that would have fixed it. Sounds like something got fried on that APM board. If you've got an AVR programmer you can try reloading the bootloader.

The PPM blue light should cycle about 1/2 second when a RC controller is sending to it.

The yellow light should stay on constant after startup on your APM board.

If the yellow light blinks after battery connection startup then there is a problem.


Is there any info anywhere on how to do that?  I do have one of these from a previous project:




Would that work, or do I need a special arduino version?

Instructions are here

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service