I had initially raised this question in Arducopter 2.x group yesterday but since no one replied and I really need help, I am posting this question in the Arducopter User Group.

Here is the situation:

I am doing a project to augment Search and Rescue operations as we know it with Semi-Autonomous UAVs. About a month ago we tried to join modules together but we hit a major problem with making the Arducopter fly in AUTO mode. We need to get the Quadcopter following the waypoints before Friday, the project presentation date. 

Below is a screenshot of a log we downloaded yesterday. I have also attached the log to this post with our params file. The waypoint file for this flight only contained two waypoints and an RTL mode. Before this flight we tested Loiter mode and it worked well. In this flight however, we had multiple fly-aways with the Auto mode. 

We believe that our project has potential. We have presented at the NCUR conference last week and won an award yesterday for our project, but for this project to come together we need a video of the waypoint navigation working with system by Friday. 

EDIT 1:

Thank you Tsoi and Boland. 

Yesterday (4/21) I did three things before flying:

1. Downgraded the FW to 3.1.5

2. Twisted the GPS wires for them to stay together and used a toroid.

3. Waited until I had connection to more than 10 sats before flying auto. 

I ran two auto modes both worked well (the second ended abruptly at the second waypoint but that might be related to the problem I am about to explain).

The main issue that I am having now is the same the one discussed in the discussion forum called "AC 3.2.1 APM 2.5 Throttle pulsates in Loiter". As you can see from the image below and the log (named: 2015-04-21 20-18-29.log) attached, although the APM knows that the altitude is increasing and the error between desired alt and barAlt is increasing, it doesn't compensate.

red (barAlt) green (Desired Alt)

EDIT 2:

I flew again today (4/22) first with an Alt Hold P gain of 1 and then I increased it to 3 and tried it again. 

Stabilization when Alt Hold P gain = 1:

Stabilization when Alt Hold P gain = 3:

Both flight logs are attached in the response I left today at the bottom. 

Alt hold controller seems like it is broken. Not following the desired value at all. 

What now? Tomorrow is my last day to test and fly...

Details

Frame: DJI F450 kit with motors and escs (original)

Autopilot: APM 2.5+

GPS & Compass: ublox RCtimer version (Ublox LEA_6H-0-002  (19) it also says v1.2) I also have a 3DR MTK v2.0 that I can use

I have done autotune to tune the craft. 

Thanks!

Views: 1451

Attachments:

Replies to This Discussion

Go to your local Guitar Center and buy some copper tape.  Put copper tape on the top board under the GPS to shield the RF EMI from below possibly generated by the R Pi.  Also, keep in mind the data received from the GPS unit are coming down to the APM via those wires you have hanging down the side and they can also collect EMI.  You may need to get some ferrite rings and wrap the section of wires (both the magnetometer and GPS) closer to the APM in ferrite rings to filter out the noise.

I just downgraded to AR2.47 AP3.1.1 AC 3.1.5. will go out and try it in about an hour. I also rolled the gps cable around a toroid. 

I wonder why I was seeing EKF failsafe errors in logs if APM isn't trying to use them. Maybe it was just the 3.2.1 FW.

Thanks for the help

Given you are seeing GPS drop out even when the Pi is turned off, it's highly likely you have a problem with the GPS, it could just be the cables/plugs causing a poor connection or the GPS itself may be faulty. Adding a ground plane can only help, but it may not resolve the problem if the GPS is totally dropping out.

I came across this comparison of with/without a EMI shield on that GPS unit... looks convincing. https://youtu.be/Jn5KC61AvlA

Thank you Tsoi and Boland. 

Yesterday I did three things before flying:

1. Downgraded the FW to 3.1.5

2. Twisted the GPS wires for them to stay together and used a toroid.

3. Waited until I had connection to more than 10 sats before flying auto. 

I ran two auto modes both worked well (the second ended abruptly at the second waypoint but that might be related to the problem I am about to explain)

The main issue that I am having now is the same the one discussed in the discussion forum called "AC 3.2.1 APM 2.5 Throttle pulsates in Loiter". As you can see from the image below and the logs attached, although the APM knows that the altitude is increasing and the error between desired alt and barAlt is increasing, it doesn't compensate.

 Red (Bar Alt) Green (Desired Alt)

Any suggestions as to how I can fix this?

Thanks.

Attachments:

Please see edit.

Please see edit.

Have you tried tuning the altitude hold parameter? http://copter.ardupilot.com/wiki/altholdmode/#tuning

The pulsate problem was with version 3.2.1 firmware.  Since you had reverted back to 3.1.5, you should not have the same issue.  When changing firmware, you must go through the entire calibration process as if you are doing an initial install.  Did you recalibrate your ESC, Accelerometer, compass and radio?  If not do it first and try again.  Then you may need to do the tuning as Felix had suggested.

My Alt hold P gain was set to 1.5 so I decreased it to 1 (which I assume is the default value). I will give it a spin today and see the results. 

Wouldn't more P gain give me a faster controller.

I think the only thing that I had not calibrated yesterday after downgrading was the accelerometer. 

I will do it now and give it a spin this afternoon. 

Have you checked your vibration levels?

Errant vertical behaviour was what I encountered way back when they changed algorithms.

Do a flight and log your IMU data.

There is a good Wiki on vibration management.

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service