I had initially raised this question in Arducopter 2.x group yesterday but since no one replied and I really need help, I am posting this question in the Arducopter User Group.

Here is the situation:

I am doing a project to augment Search and Rescue operations as we know it with Semi-Autonomous UAVs. About a month ago we tried to join modules together but we hit a major problem with making the Arducopter fly in AUTO mode. We need to get the Quadcopter following the waypoints before Friday, the project presentation date. 

Below is a screenshot of a log we downloaded yesterday. I have also attached the log to this post with our params file. The waypoint file for this flight only contained two waypoints and an RTL mode. Before this flight we tested Loiter mode and it worked well. In this flight however, we had multiple fly-aways with the Auto mode. 

We believe that our project has potential. We have presented at the NCUR conference last week and won an award yesterday for our project, but for this project to come together we need a video of the waypoint navigation working with system by Friday. 

EDIT 1:

Thank you Tsoi and Boland. 

Yesterday (4/21) I did three things before flying:

1. Downgraded the FW to 3.1.5

2. Twisted the GPS wires for them to stay together and used a toroid.

3. Waited until I had connection to more than 10 sats before flying auto. 

I ran two auto modes both worked well (the second ended abruptly at the second waypoint but that might be related to the problem I am about to explain).

The main issue that I am having now is the same the one discussed in the discussion forum called "AC 3.2.1 APM 2.5 Throttle pulsates in Loiter". As you can see from the image below and the log (named: 2015-04-21 20-18-29.log) attached, although the APM knows that the altitude is increasing and the error between desired alt and barAlt is increasing, it doesn't compensate.

red (barAlt) green (Desired Alt)

EDIT 2:

I flew again today (4/22) first with an Alt Hold P gain of 1 and then I increased it to 3 and tried it again. 

Stabilization when Alt Hold P gain = 1:

Stabilization when Alt Hold P gain = 3:

Both flight logs are attached in the response I left today at the bottom. 

Alt hold controller seems like it is broken. Not following the desired value at all. 

What now? Tomorrow is my last day to test and fly...

Details

Frame: DJI F450 kit with motors and escs (original)

Autopilot: APM 2.5+

GPS & Compass: ublox RCtimer version (Ublox LEA_6H-0-002  (19) it also says v1.2) I also have a 3DR MTK v2.0 that I can use

I have done autotune to tune the craft. 

Thanks!

Views: 1452

Attachments:

Replies to This Discussion

The Log for the graphs above is attached here

Attachments:

Thank you for the response Randy. I have attached IMU log here for reference. 

I believe I have the Kyosho zeal vibration absorption Gels which should be good enough but according to log (attached), my Z axis accel readings have a high (0 - 20) vibration range. Maybe its because of the amount of cables attached to the autopilot.  

I will try to balance props and give it a spin tomorrow early in the morning. 

Thanks again. 

Attachments:
Any luck?
I have a very similar setup, not far from you.

Today I balanced my Props and flew with INS_MPU filter at 20. I still get pulses while on Alt_hold but the APM seems to compensate it while on Auto mode within +/- 2 meters. I got some data for my presentation which is tomorrow. I will also try flying tomorrow early in the morning :)

Could you share a video of your quad in flight?

If you can solve vibs probably you solve pulsate, try to balance your motors too, try with 3M foam that Randy recommend, if you can't find quikly, try with doble sided 3m tape only, a quick compromise solution, not definitive, try to fix 50 grs weight on your APM with doble sided tape (be carefull if you have internal compass, use something that not interfere). Good Luck.

Here is the video!

z axis vibration.

This my preferred mounting method to stop that, especially on noisy frames

Carbon plate/Sorbathane/Lead sheet/Gyro tape/APM

Thanks to everyone who helped me with this project. The video below shows our Quad following waypoints (of a lawnmower pattern). I will consider the advice on z axis vibration. 

Thanks again!

Thanks for the suggestion! 

The project supplies all are Geroge Mason University's property. I will probably buy a Pixhawk for future projects. 

It looks quite complicated. I gotta complete my own capstone project in a year but right now I'm looking for ways to make it easier. Guys, I found this resource https://edusson.com where you can order a capstone project writing service. Has anyone used such services? Are they worth it? Testimonials are good but it's better to know from this community.

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service