Hi folks,

I'm trying to download the logs from the flash on the APM 2 (v2.73) using the CLI tool in Terminal...it doesn't seem to be possible.

I've tried the sequences below, but they all seem to be inhibited by the incredibly long connection process the Mission Planner undergoes, which is probably 30-45 seconds.


  1. MP open, at the terminal tab.
  2. Connect APM via USB
  3. Click connect on MP
  4. Spam <enter>
  5. Nothing happens on screen.


  1. MP open, at the Flight Data tab.
  2. Plug in APM to USB.
  3. Connect to my com port from this screen, wait 40 seconds for the MP to respond, then connected.
  4. Switch to Terminal tab.
  5. Nothing rolling by on the screen.
  6. Hit the Terminal tab button again
  7. Screen clears, then a chunk of the ArdupilotMega 2.73] prompt appears but does not respond to button pushes.

I can still use the MP conventionally without issue--for tuning and config and such.  Also works with the 3DR radio just fine.

This MP failed to upload APM firmware, too.  I had to use the APM patch of Arduino to get the writes to verify--MP failed every time.

As for alternative CLI access, I can get to APM's CLI with no issues via SecureCRT and PuTTY.  To avoid losing my logs from this morning's maiden flights, I'm just running dump out of putty and saving the mess into a .log file... I'm not sure what I'll need to do to graph and analyze this later, but at least I'll have the data.

So, I suppose I have to challenges to unravel:

  1. How do I get MP CLI to function reliably?  Whatever I'm doing wrong is rendering it useless.
  2. How do I trim and save these log files so the APM native applications (like MP) can read and understand them?  The interpretation tools are great!

Any help you folks can offer is much appreciated!


Views: 1145

Reply to This

Replies to This Discussion

New MP feature.  After terminal mode you have to reboot.  Click the button at the top left of the terminal screen

I'm hunting for which button you're referring to--here's a screenshot of the top left of the terminal screen.  Which button do you mean?

Wops,  I assumed you had version 1.2.58. That is where the reboot button was introduced - right above the Show Settings button.   

Wow another update!  I'll get that down and try this all over again.

I have the new version and still this is a complete failure for me... how would you feel about listing an explicit step by step process of how you make this work?  I can't seem to find a complete, solid process that works!

I tried uploading 2.74b tonight and encountered this error--perhaps it's related?


You are using ArduPlane and APM 2.0  so perhaps better to also post this in Arduplane topics.  Also, did you get the latest version of Mission Planner  1.2.61  here http://ardupilot.com/downloads/?did=74  

There have been lots of updates to MP due to the new Arducopter so perhaps some issue not yet found or resolved in the Arduplane compatibility.

I am using MP 1.2.61 Arudcopter 2.9.1b and APM 2.5 and this works for CLI and log downloads

(the buttons will not exist if you do not have MP 1.2.61)

Open MP

Plug in usb   The Apm should boot    Do not try to connect yet... just

Click on [terminal]    This brings up a new screen with Connect APM button at top left

Click on [Connect APM]   This reboots the APM and does the equivalent of Enter three times - thus CLI

  You should get the CLI screen and the prompt.

Type help at the prompt to see if working  -  or click on the button for log download

If that does not work, check the baud rate and other connection parameters for the usb.

Reply to Discussion


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service