Hi all,
Wondering if anyone has advice. I stripped down my Arducopter before Christmas to make some changes. I added an APM 2560, optical flow sensor, navigation lights based on the 123 Blink post and a minim osd. I didn't have a chance to finish it off and left it sitting partially rebuilt until today. I have just finished the rebuild, downloaded the latest mission planner and uploaded the latest code. When I go into the cli I find that some information is legible and some is garbled. The cli then starts jumping around telling me stabilise mode is active, x mode is active, radio has been reset etc. It's doing this by itself at quite a pace and acting as if It's getting some sort of rogue signals telling it to go to particular menus and set them etc. The garbled info is the same as if I was at the wrong baud rate, but then at times it becomes perfectly legible. After erasing the EPROM, resetting etc I checked the motors, sometimes they work, sometimes not. I'm at a bit of a loss. Anyone seen this before ? I have so many wires coming off of the IMU now between the optical flow sensor, sonar, xbee, osd and nav lights I don't know what could be causing it. I have checked each solder and they all seem fine but . . . ?
Amy help is appreciated !
Thanks,
Eoin

Views: 296

Reply to This

Replies to This Discussion

All normal... read this: http://diydrones.com/forum/topics/gibberish-in-cli

basically it's the new way to avoid using the switch to select FLY/CLI mode.  

just press enter 3 times (and make sure your baud rate is set to 115K 

Edit: maybe you also have some issues with your cables... (sorry did not fully read all your post!) 

in flight mode (not cli) it should not jump around... 

Try rebooting your computer as well... I've seen strange behavior in MP sometimes due to my laptop needing a clean boot. 

Dany

Thanks Dany !

That explains the garbling (is that a word :)

In regard to the jumping around it all seems fine now. Copter is behaving as expected. I double checked all the cables and everything seems fine but I can't discount a possible short circut somewhere yesterday.

Thanks again

Eoin

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service