I am using AC 3.2.` on pixhawk and it works good.

When I uploaded AC 3.3 I got compass issues, I was getting errors compass variance

Also when I tried to fly , I almost crashed it, my tarot got very unstable and banked to left and right

any thoughts about it?



Views: 2105

Reply to This

Replies to This Discussion

you need to post a log file for anyone to really be able to help

I understand, however, it has nothing to do with my drone, the issue is with the firmware, after uploading 3.2.1, it works.   so for some reason 3.3 is causing issues.

Thank you

The logs will help us diagnose the issue 3.3 is having with *your* hardware. Needless to say many thousands of other people are using it without issue, so we need logs to see what's going on with your particular board. 

3.3 has worked flawlessly for alot of us.. what have YOU done to try and resolve this issue ? Did you take ANY steps at all ? Help yourself a little for others to help alot.  

Yes, I did the whole calibration few times, I tired to fly the quad, I disconnected the external compass and the GPS, and I noticed that the issue was with internal compass, that made me to think that the pixhaw was bad, but then I installed different firmware, and it worked out, I had no issiues.

so thx fro comments, I fixed the issue,  I just wanted to know if anybody else noticed any compass issues with the new firmware.


It is probably not the firmware issue, it happens when install new version, the settings you used before are different and need to re-tune all.

When changing, even slightly the position of the controller and other parts, sometimes the internal compass calibration offsets exceed the range (-400 400). If I have -500 (sometimes on Z axis) i manually put -400 and the internal compass working well.

Anyway, using the external compass is better, good one gives max -100 +100 Z offset.

Hi, despite the BAD AHRS errors I get even when the copter is standing still, I also now have problems with the compass...

I am running Copter 3.3.2 on my Hexa.

I just did 2 compass calibrations.

First one with auto dec, second one with declination set to my town.

Why are the compass 2 (internal compass?) offsets so incredibly high?

The wiki says that the sum of all absolute values shouldn't exceed 600... Well, I have nearly 2000!

Hi, I have 3 pixhawks and the internals on all of them have near those offsets. Not only that but if the calibration program is run successively, significantly different values are obtained. I also notice on dataflash logs the two mags when graphed diverge and converge. LSM303D strikes again (though it'd probably be fine if it were made external).

Try disabling the internal and using only the external.

The values depends of the metal around the controller and the Pixhawk hardware itself.

I have several Pixhawk, and each is different. Best MAG data (offsets are about 10) gives a clone Pixhawk, unfortunately the baro diverge a lot....

The original 3DR gives more offset (105 61 43), but the baro is very consistent.

Always measure the controller outside the frame, on a wooden table (no metal around). Then compare with the frame offsets.

A get BAD AHRS usually when the baro values floats. Normally, in quiet closed environment, the baro (ALT) should not float much (+- 20 cm)  The same clone mentioned above, floats about 5 meters after 8 minutes power on!

3DR controller I measured floats no more 20-30 cm in 1 hour.


thanks for your answers.

I changed the mounting from a 3D printed case to a selfmade mount that uses 4 screws through the holes in my AUAV-X2 board.

It just came to my mind that those screws are causing the trouble with the compass.. will try to find M2 nylon screws..

Now I just have to find out, what's causing the Bad AHRS error all the time..

will check baro, but the board is really high quality, so it shouldn't be the cause..

Dave, let us know if it solves your issue.
I have an auav-x2, and have never gotten its internal compass to work properly.   It's not very close to any metal (it is a small frame, so there's a steel frame screw maybe a couple cm away).
But, even sitting on my workbench, I can't get it calibrated.  The offsets are very high, and north doesn't point north.  Pixhawk sitting on the same bench is fine. 

I have disabled the internal compass on my auav-x2 copter, and it works great w/ the external one.

will try, but I am almost sure that the screws are the problem.

before the mounting change, the offsets were around 50 - 100.

I think that the steel screw could be your problem.

At my frame, the next screw is around 5-10cm away.

Maybe you can change the according screws to stainless steel v4a, brass, or aluminium ones.

I have ordered the nylon screws and also v4a ones and will report back when I get them.

I also use an external compass however, but I wanted to use the internal one for letting the EKF check plausibility.

Did you check the AUAV at the bench?

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service