Hi,

I don’t know if anybody can help me or at least explain this. I had problems with the loiter (the typical toilet-bowling) so I took a look at the compass offset values. They were -175 -158 -13, out of the recommended range (-150 150), so I decided to rearrange the hardware of my quad as some of you recommended. To have a reference of how much I can improve these values, yesterday I did the live compass calibration with the APM alone, without the frame, batteries, ESC, etc. Only the APM board (and a USB cable), away from any EMI source and metals, and surprisingly the values were -184, -155, -23. I repeated the live compass calibration several times but the values didn’t change so much :(

so… What can I do??

 

If this helps, I have checked old logs and I had had similar values of the compass offsets always! But the loiter was fine, not amazing, but fine.

I’m currently using APM 2.5 with firm 3.1-rc5 (the one with auto-tune).

Thanks!

Views: 9832

Reply to This

Replies to This Discussion

Did u find solution?
I have the same issue:
Test: Compass = FAIL - Large compass off params (X:-158.94, Y:115.60, Z:8.33)
No MAG data, unable to test mag_field interference

My system: APM 2.6, external compass LEA-6H GPS
Mission planner settings: External compass ROLL 180

Latest firmware.

Compass & mag are connected high in a middle

Any idea?
Thanks

I didn’t find a solution. I bought an external compass and now is working perfectly.

I don’t understand quite well you problem, you don’t have magnetic field data but you have offsets… weird.

I had a similar error (no MAG data) when I didn’t connect the external magnetometer correctly. Check the connections, I don’t know what else to say

I have this:

http://www.ebay.com/itm/281270810706?ssPageName=STRK:MEWNX:IT&_...

This is how my quad fly:

http://youtu.be/cVLoq02xjhk

http://youtu.be/YAD8_aaNBSc

My onboard module dont have compass so thats why I need GPS & compass external.

As you can see from video it's mounted far/high away from any electric device.

When I try to calibrate indoor with powered only apm & compass i still getting the same results. My X offset is too far away from normal -157. And LOG Diagnoss shows Compass check FAIL because of that Offset - and thats why it will not log mag data.

Compass still looks like its working, but i dont know how good is it working.

As video see loiter and seems working.

So if anybody has an idea - please.

Is it maybe hardware issue or something esle?

I'll also attache my logs.

And by the way my YAW looks also weird - when i try to use YAW copter looks like fall one side and the try to turn and the first move, than turn fine. Any idea?

Maybe somebody can take a look my logs to make sure everything works fine.

Thanks,

Norm

Attachments:

I'm pretty sure it is a hardware problem cos the same happened to me. My loiter had problems some times and few times even the stabilized was not working well (it wasn't a big problem, it wasn't horizontal and I had to stabilized by myself). But if in your case is working, I would do nothing.

Hi, is this problem solved? I am having a very similar issue with my APM. When I calibrate the internal compass everything is OK, but when I disable it and try to calibrate the external one the z axis is too high (can't bring it lower than 450).

My GPS is the NEO-M8N, I've tried calibrating it many times indoor and outdoor but none of that works.

Does anyone knows how to solve this?

Thanks!

I think the best is to desactivated all inboard compass and check extern compass and check use external for primary.

I try neo 8m and a Neo M8n and same results so I really think it's inboard problem.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service