Connection Error in APM Mission Planner with wireless telem

Earlier today I had the Mission Planner communicating perfectly with the APM (1.4). But now when ever I try to connect the usual window comes up and says "Getting Params.. (sysid 1 compid 1)". Then that stays for roughly 30seconds then I get "Connect Failed"

What is really interesting is that when I use HK GCS it connects no problem. 

I do have the baud at 57k and I have run the X-CTU on both XBees and everything seemed good there. What else should I try?

Views: 10180

Reply to This

Replies to This Discussion

Hi

I had the same problem. I just had to turn off the uart flow control and then everything was fine.

Can you solved the problem? how? I've the same problem, but I've XBEE PRO 868.
Any suggestion?
Thank's for all.

We have noticed this too on the arduplane software, the arducopter is fine. Definitely not a hardware issue, something to do with the APM planner changes or something updated with the latest APM releases that have been made recently.

No T0nimas we haven't been able to solve it.

Ok.

Thanks to answer so fast!

I dont have this hardware. so unless someone know why its failing, i cant do anything. And like quentin said, if it only happens with AP and not AC i dont see how it can be the planner causing it.

please try this.

1 connect via usb.

2 edit param SR0_PARAM to say 20

3 edit param SR3_PARAM to say 20

make sure you write them.

 

then try connecting as usual

Djalma, your issue apears to be cabeling. as the mp sends packet to the apm, but isnt receiving them.

It's hard to shed light on this issue, but it is really annoying!

The arduplane suffers badly when trying to connect. We have used xbees on 2.4GHz and XRF's or 868Mhz, both suffer the connection issue. When we then swap out the APM programming and load arducopter, they all connect without incident.

We have tried three apm 2's and 4 xbee pairs and 4 xrf pairs, all give the same results. This started about 6 to 8 weeks ago just after an APM planner update. All was well before that.

When arduplane is trying to connect at 57.6k it gets most of the parameters and then seems to stumble after or around the gimbal parameters. It then keeps repeating got parameter etc and then times out. Sometimes it does connect and then works, but the link is poor quality.

We then try the arducopter and it works without issue and doesn't stumble saying it has got parameter etc.

Sorry we can't be anymore helpful here, but I doubt it is the APM planner unless it behaves differently for arduplane and arducopter? Just odd that it all started after an APM planner update.

there are a fredw things to try.

changing the SR?_PARAMS like above.

also try changing the stream rates down, in the mission planner config. try say 1hz for all of them, and work your way back up. to clear the stream rates edit all SR?_????? to 0, the mission planner will reset these on the next connect. make sure you change the mission planner config for these first though.

Tried that and no difference.

We set all the telemetry rates to 1 in the end and it would connect 1 out of ten times.

It goes through the got param etc and then hiccups at the mnt parameter and then starts saying already got param etc. It then goes through a list of parameters it has already got and then fails.

Definitely not the equipment  as we said, if we then load on the arducopter software it connects without a hiccup. Put the arduplane back on and it fails again. Not sure where to look now!

CTRL-T.

What do you mean by CTRL-T? where is it used and what for?

Tommy where exactly do you turn off the uart control?

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service