Connection Error in APM Mission Planner with wireless telem

Earlier today I had the Mission Planner communicating perfectly with the APM (1.4). But now when ever I try to connect the usual window comes up and says "Getting Params.. (sysid 1 compid 1)". Then that stays for roughly 30seconds then I get "Connect Failed"

What is really interesting is that when I use HK GCS it connects no problem. 

I do have the baud at 57k and I have run the X-CTU on both XBees and everything seemed good there. What else should I try?

Views: 10185

Reply to This

Replies to This Discussion

It is used in Mission Planner for connecting to a UAV without having to read all parameters first :)

Thanks we will give it a go and see what happens.

Ok that connects instantly which is great and just what we wanted! Thanks Søren :)

So what has changed to cause clicking on the connect button to fail, yet Control T works a treat. Is it something to do with the way the APM planner handles the data stream or something to do with the arduplane apm software?

Hi,

Yes CTRL-T is one giant leap for mankind :)

With a standard Connect, Mission Planner insists on reading and understanding each and every parameter on board before even letting you see where your UAV is..  in a critical situation, with a flaky link, you can abandon all hope.

After the loss of a drone on that account, I hacked into the MP source trying to find a solution and discovered there was that one already.

The APM software will send enough data for you to have a reasonable overview, even if it never received a byte of data from the ground station end. MAVLink is stateless; is has no notion of being connected or not.

QGroundStation supports simply listening to an interface.

Regards

Soren

Fascinating Søren, it certainly works with other systems, but fails almost every time with the APM planner.

Michael, if you are still watching this thread, any idea's? Is the way the telemetry connects in the APM planner exactly the same for arduplane and arducopter?

Hi,

The way they connect is the same. There might not be the same amount of parameters to load, but otherwise there is no difference.

Of course, when you do CTRL-T you will want to verify that the uplink (ground to air link) works before taking off! With a plane for example by changing between Manual and Stabilized mode a few times from the Mission Planner and check that there is a response.

Regards

Soren

please try chaging param sr0_params to say 5

and sr3_params to 5.

 

this will slow down the connect but should not flood the link

Thanks Guys, we will take a look again at the parameter suggestions.

Why has this occurred? It used to work really well up until a few months ago and now nothing but trouble, obviously it is not just us suffering this problem from the comments.

Tried that, it just slowed down the link but we still get subsequent connection timeouts, when we disconnect and then reconnect.

We loaded a previous version of the APM arduplane software to see if it was anything to do with that, but the same happened. We are now suspecting it must be something to do with the APM planner link, especially as Control T connects instantly!

Ok, it gets worse!

I have created a video showing what happens with arduplane and then arducopter. This is one of three APM 2's that we have and it does it on all of them. Really frustrating, but the video clearly shows an issue with arduplane losing packets and when the arducopter firmware is loaded with the exact same hardware no packet loss and it connects almost instantly.

I hope the video will help Michael as we don't know if it is the APM planner or the arduplane firmware causing this.

It also highlights a screen issue with the paramaters list.

http://youtu.be/k3KF0If49p0

IM having a similar problem, but mine will not connect over usb i believe i damaged the firmware because i reloaded mp and a different computer and still ge the error "com port does not exist". i do have all the drivers loaded and can see it via both in mission planner as on com 3 on the drop down and as well as hardware in windows any ideas? I've reloaded mp several times on both pc's and the driver,and tried different baud rates as well ? is there a way to check the board outside of mp ?

have you cahnge the settings ive talked about.

via usb.

change sr3_params to 10

change sr0_params to 10.

 

change all the sr0_* and sr3_* to 0, these will be reset on the next connect.

 

and in the planner config screen change the telemertry rates lower.

to say 5 1 1 1

 

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service