I tried to load the new code through Mission Planner, it got half way through and lost the connection for some reason, now I cannot connect at all. I can connect through the terminal. I can connect through Arduino but when I upload the code I get an error (see attached jpg)

I have checked the CLI switch and baud rate and that RTS is set.

I have no idea what to do next, any help greatly appreciated.

Views: 222

Attachments:

Reply to This

Replies to This Discussion

Hello Ken,

 

Which APM board are you using?

 

Have you re-set the APM to factory spec using the CLI, then tried using the latest mission planner to load the code into the APM?

 

Regards

 

Martin

 

www.buildyourowndrone.co.uk

Hi Martin,
I am using the 1280 board.
Yes I have reset to factory spec using CLI, but cannot get Mission Planner to connect.

Regards
Ken

Hello ken, That reset normally cures 9 out of 10 issues, appears we might be on number 10 :(
Can you show a screen shot of where the planner is getting stuck?
Can you try this code with the IDE and see what happens:

http://code.google.com/p/ardupilot-mega/downloads/detail?name=ArduP...


Please disconnect all motors / lipo before uploading this code, this is not a copter code, I just want to see if the 1280 board is accepting a code known to work on it!
Regards

Martin

Hi Martin

The screen shot is attached to the first post.

Does the code you asked me to load need configuring first? If I try to compile it I get errors.

Regards
Ken

Hi Ken,

 

The screen shot was from IDE not mission planner I saw?

 

There are a few items which need to be set....

 

Might be easier to help you if you get team viewer, I can take a look at your screen with you. I use it to support my customers with Tech advice all the time, it's great and did I say free :) 

 

Email me at martin@buildyourowndrone.co.uk if you want to go down that road, I can book a slot with you :)

 

Regards

 

Martin

Hi Martin

See attached screen grab of mission planner.
Attachments:
Hello Ken,

Thanks for the screen shot and your emails, that is a message I've not seen before in mission planner! However I'm sure you and I will get to the bottom of this!

Look forward to talking with you later.

Regards

Martin

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service