Warning #1: an issue has been found with Tower's Pause button which can cause the vehicle to fly to an old position if the vehicle has not sent a position update to Tower in some time.

Warning #2: Copter-3.3.2 fixes a bug found in Copter-3.3.1's desired climb rate initialisation which could lead to a sudden momentary drop when switching from Stabilize or Acro to AltHold, Loiter or PosHold.

Warning #3: Copter-3.3.2 fixes an issue found in Copter-3.3.1 which could lead to hard landings in RTL or AUTO if the WPNAV_SPEED_DN was set too high (i.e. >400 or 4m/s) and/or the WPNAV_ACCEL_Z was set too low (i.e. <100 or 1m/s/s).

Warning #4: a bug was found in Copter-3.3 which could cause a sudden crash if you abort a Take-off initiated from a ground station.  Video description is here.  The bug is fixed in Copter-3.3.1 so we recommend upgrading.

Note #1: AC3.3-rc8 corrected a long standing bug in the HDOP reporting.  HDOP values will appear about 40% lower than previously but this does not actually mean the GPS position is better than before.
Note #2: if upgrading from AC3.2.1 the vehicle's accelerometer calibration needs to be done again.
Note #3: set SERIAL2_PROTOCOL to "3" and reboot the board to enable FrSky telemetry like in previous versions.
Note #4: the wiki will be updated over the next few weeks to explain how to use the new features

Copter-3.3.1 is available through the mission planner.  The full list of changes vs AC3.2.1 can be see in the ReleaseNotes and below are the most recent changes since AC3.3.

Sadly this version (and all future versions) will not run on the APM2.x boards due to CPU speed, flash and RAM restrictions.

Changes from 3.3:

1) Bug fix to prevent potential crash if Follow-Me is used after an aborted takeoff

2) compiler upgraded to 4.9.3 (runs slightly faster than 4.7.2 which was used previously)

Changes from 3.3-rc11:

1) EKF recovers from pre-arm "Compass variance" failure if compasses are consistent

Changes from 3.3-rc10:

1) PreArm "Need 3D Fix" message replaced with detailed reason from EKF

Changes from 3.3-rc9
1) EKF improvements:
    a) simpler optical flow takeoff check
2) Bug Fixes/Minor enhancements:
    a) fix INS3_USE parameter eeprom location
    b) fix SToRM32 serial protocol driver to work with recent versions
    c) increase motor pwm->thrust conversion (aka MOT_THST_EXPO) to 0.65 (was 0.50)
    d) Firmware version sent to GCS in AUTOPILOT_VERSION message
3) Safety:
    a) pre-arm check of compass variance if arming in Loiter, PosHold, Guided
    b) always check GPS before arming in Loiter (previously could be disabled if ARMING_CHECK=0)
    c) sanity check locations received from GCS for follow-me, do-set-home, do-set-ROI
    d) fix optical flow failsafe (was not always triggering LAND when optical flow failed)
    e) failsafe RTL vs LAND decision based on hardcoded 5m from home check (previously used WPNAV_RADIUS parameter)

Thanks for your testing!

Views: 374809

Reply to This

Replies to This Discussion

Whould it be possible to add a small delay, when Pixhawk is expecting new firmware, before it proceed to wake-up?

The problem I have is a competition between the laptop recognizing the USB and Pixhawk booting up. Sometimes it requires many attempts to flash new firmware with Mission Planner.
The stationary, also running Windows 7 Pro 64-bit, recognizes USB quicker and usually manages to flash.

I guess I'm not the only one having this kind of problem.

Thanks

Anders

Hi,


Indeed it was fixed at commit: Copter: deploy gear during mission RTL descent

Why do we still see version 3.4 "APMVERSION: APM:Copter V3.4-dev" as 3.3-rc5 was announced Copter 3.3-rc5 since 23-May-2015 ?


link of commit rc5: Copter 3.3-rc5 23-May-2015

It's a bit confusing for me.

No, your not alone on that. Sometimes I've used the reset button on the Pixhawk to get around this instead of yanking the USB cable out and back in (IIRC) ...

Please keep in mind this discussion is for copter testing.
Are you using Mission Planner in A virtual machine?

i'm facing a strange behaviour and i'm hoping somebody can help me out.

i have always an error message on the flight screen saying something like "GPS variance". Normally the error can be surpressed by disabling check_ekf_tresh. But obvious this is not the solution. This behaviour can lead to unwanted yaw rotations during take off -> pixhawk tries to correct the deviation which in reality is not.  


what i noticed today is that the yaw heading is turning slowly counter clock with the copter sitting on the ground and not moving just sitting there. The deviation is growing more and more after a couple of minutes i have an deviation in yaw greater  than 180 degrees.

Then i disabled compassmot just to see if this makes a difference and this solved the problem. i just set "COMPASS_MOTCT" to 0.

this startet with fw 3.3


Can somebody explain this ?

No! This happens every time I try to upload new firmware to my copter, or any other Pixhawk.

Not sure if there was an intended change in arming check but it appears that the safety switch check not always performed.

RC5: in loiter GPS lock but compass issue (indoor testing), I can arm before enabling with the safety switch (ground station indication "armed") and due to EKF variance  it immediately switches to LAND mode. So actually the FC interprets the status  as ARMED too. Motors are not spinning - so the switch still does its job.

Do you have compassmot enabled ? if yes try to disable and restart this could solve the ekf variance error.

Actually I don't have any problem with it (only temp due to indoor conditions) but I do not think that Pixhawk should arm without the safety switch enabled.

I did a few more tests with rc5 and the RCMAP changes. RCMAP works great as reported elsewhere. Couple of things I noticed:

1. I cannot arm in Auto. GCS says "Press safety switch" but the switch is already pressed!

2. If I arm in another mode, switch to Auto and then try and run a mission starting from the ground, when I raise the throttle the copter immediately heads towards the first waypoint from the ground, rather than climbing to a safe distance and then heading towards the waypoint. I was in long grass and cut a swathe through it before it got to a safe height!

I've not tried either of these before so not sure if they are new to 3.3, but both seem like bugs.

Great clip Marco !
Is your PixHawk enclosed ?, as you don't seem to have any dropping in altitude due to the high speed you are moving over the grass...,

I guess you are forward flying with camera looking backward, or is the front of the PixHawk pointing in the same direction as your camera ?

Erik
hi got no problem with 3.3rc5.on auto. i normally put takeoff on the first line and set the altitude and loiter time. succeeding lines are waypoints. last line is rtl

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service