Warning #1: an issue has been found with Tower's Pause button which can cause the vehicle to fly to an old position if the vehicle has not sent a position update to Tower in some time.

Warning #2: Copter-3.3.2 fixes a bug found in Copter-3.3.1's desired climb rate initialisation which could lead to a sudden momentary drop when switching from Stabilize or Acro to AltHold, Loiter or PosHold.

Warning #3: Copter-3.3.2 fixes an issue found in Copter-3.3.1 which could lead to hard landings in RTL or AUTO if the WPNAV_SPEED_DN was set too high (i.e. >400 or 4m/s) and/or the WPNAV_ACCEL_Z was set too low (i.e. <100 or 1m/s/s).

Warning #4: a bug was found in Copter-3.3 which could cause a sudden crash if you abort a Take-off initiated from a ground station.  Video description is here.  The bug is fixed in Copter-3.3.1 so we recommend upgrading.

Note #1: AC3.3-rc8 corrected a long standing bug in the HDOP reporting.  HDOP values will appear about 40% lower than previously but this does not actually mean the GPS position is better than before.
Note #2: if upgrading from AC3.2.1 the vehicle's accelerometer calibration needs to be done again.
Note #3: set SERIAL2_PROTOCOL to "3" and reboot the board to enable FrSky telemetry like in previous versions.
Note #4: the wiki will be updated over the next few weeks to explain how to use the new features

Copter-3.3.1 is available through the mission planner.  The full list of changes vs AC3.2.1 can be see in the ReleaseNotes and below are the most recent changes since AC3.3.

Sadly this version (and all future versions) will not run on the APM2.x boards due to CPU speed, flash and RAM restrictions.

Changes from 3.3:

1) Bug fix to prevent potential crash if Follow-Me is used after an aborted takeoff

2) compiler upgraded to 4.9.3 (runs slightly faster than 4.7.2 which was used previously)

Changes from 3.3-rc11:

1) EKF recovers from pre-arm "Compass variance" failure if compasses are consistent

Changes from 3.3-rc10:

1) PreArm "Need 3D Fix" message replaced with detailed reason from EKF

Changes from 3.3-rc9
1) EKF improvements:
    a) simpler optical flow takeoff check
2) Bug Fixes/Minor enhancements:
    a) fix INS3_USE parameter eeprom location
    b) fix SToRM32 serial protocol driver to work with recent versions
    c) increase motor pwm->thrust conversion (aka MOT_THST_EXPO) to 0.65 (was 0.50)
    d) Firmware version sent to GCS in AUTOPILOT_VERSION message
3) Safety:
    a) pre-arm check of compass variance if arming in Loiter, PosHold, Guided
    b) always check GPS before arming in Loiter (previously could be disabled if ARMING_CHECK=0)
    c) sanity check locations received from GCS for follow-me, do-set-home, do-set-ROI
    d) fix optical flow failsafe (was not always triggering LAND when optical flow failed)
    e) failsafe RTL vs LAND decision based on hardcoded 5m from home check (previously used WPNAV_RADIUS parameter)

Thanks for your testing!

Views: 374809

Reply to This

Replies to This Discussion

I'm a latecomer to beta testing v3.3.

I've had many successful flights with v3.2 but with v3.3rc5 I often cannot get it to arm. APM Planner says it needs a "3D Fix", yet I have 8 or more satellites and hdop of 1.6 - 1.9. I've even cranked up the HDOP threshold to 400 (i.e., 4.00)

First thing this morning I did get it to arm (after quite some time) so I successfully did the autotune process. After landing I changed the battery and tried to do another flight but couldn't get it to arm. I've had "prearm chk mask" = 1 (everything) so I tried to exclude only the GPS check but APM Planner doesn't seem to let me upload a number greater than "127" (and unsigned char??).

Could the "Need 3D Fix" message be generated by the failure of something else beside the GPS? I'm using a HKPilot32 (Pixhawk clone) with Ublox M8N gps on a F450 frame. 

Can anyone shed some light on this?

Hi,

I by no means intend to respond instead of develpers who know best but I had same situation going on with telemetry screen showing 10-12 stas and low hdop but drone would not arm saying same 'need 3d fix'.

this problem combined with very slow progress rate from 5-6 sats to 10 sats was all related to a high level of  EMI interference from the boscam transmitter 20cm away and FC BECs modules - so it took to put a solid copper plate under GPS unit for isolation and I look to do proper shielding now for GPS unit.

After this shielding it locks into 12-14 sats in less than a minute - M8N unit - and never plays this #D lock error message again if it shows me proper HDOP in the telemetry.

Craig thanks for your reply.
I've already tried another 3DR gps +compass (a Ublox 7n) and redo calibration but I get exactly the same results. I also ran compassmot and got just 10% of interference.
what else can be the problem? The loiter pid's? (But they were working fine...they are the default values for the 3DR X4 quad)

in my system after initial autotune this parameter was set to 15000, after new autotune with lighter battery it got to 17000.

what is the logic behind it and what is the safe vaue range to set it to?

atc_accel_p_max is 91837, atc_accel_r_max is 132275 - so this 17352 value indeed seems a bit out of place.

or is it?

One thing I'd like to understand is why Mission Planner reports PDOP as HDOP. Why not just call it what it is?

@Paul: Thanks for your response.

I don't power my fpv transmitter until I'm ready to go (otherwise it seems to get too hot) but one antenna from my FrSky D8R-XP is within about 10cm from the gps. I wonder if it's the telemetry transmitter that could be causing the problem?

Strange thing is that this problem only started when I went to v3.3. Perhaps this version is checking for gps velocity problems that get reported as lacking a 3D fix? Anyway, I'll try to eliminate sources of interference to see if that will help.

A while back a chap on RCG whom I will not name claimed that the X8R broadcasts out of band [they all do a little] and it was causing major issues with his GPS modules, his lapdog also claimed the same thing where as I tried and tried to reproduce the issue with 4 different RX's [2 X8R and 2 X4R-SB] and 6 different GPS units and I could not reproduce the issue. But it seems that some RX's do produce more noise than others and these new m8n's are uber sensitive to noise. I've not had any noise issues with any of them I have or have had but I DO see a lot of data drops with some of the cheaper ones, well actually ALL of them really if they are set to anything higher than a 2hz refresh. Doesn't seem to matte what baud as I have tested them from 9600 to 115200 and as soon as I go above 2Hz then they get a little spooky. I have one that goes so far as having mission planner report NO GPS then 3D lock then NO GPS over and over :(

Not saying it should affect the 6 or 7 series engines though. I'm just wondering if the devs changed something that gets uploaded to the GPS on boot.

Depending on your fpv transmitter frequency, 2.4 being the worst, it can generate a lot of noise and make aquiring sats difficult.

I like 2.4 for video and ended up using channel 2505, trying different antennas and maximizing separation until the GPS stopped complaining.

According to the logs you have bad vibrations on the Y axis, this only really shows up in IMU2 which is puzzling, but nevertheless you need to try and fix the vibrations if you can. The drift could easily be caused by this, if you do auto analysis in MP you also get a 0.8 discrepancy between the IMUs which can be an indication of vibrations. It could also be an indication of HW failure, but that's not obvious to me from the log other than the fact that the IMUs disagree. Both logs show bad vibrations.

this site keep dropping all input you type into it... it is annoying, after you typed a page or so of text.

in my case EMI noise was the reason of both compass and GPS errors. I think a lot of GPS units are extremely sensitive, also, BECs may have switched working mode if you dropped from 5.3V down to 3.3V and they may produce more noise now.

I had compared both logs, and since both of them show those little vibrations on Y axis I discarded that, because in the first log it really performed well... and you can see Vel tracking DesVel very nice.

About the hardware failure that's what I thought at the beginning and changed the pixhawk to another spare I had here... same configuration and it does exactly the same behaviour.

Since althold is working more or less fine (at least it doesnt try to run away lol ) could I try an autotune or this problem is NOT directly related to PID's ?

My fpv is on 5.8 but I've eliminated that so far. However my RC is on 2.4 so that could be an issue. I've violated one of the rules of troubleshooting by changing two things at once (moving FrSky antenna and unplugging the 915Mhz telemetry radio) but I've been able to arm now. It remains to be seen how repeatable that will be.

In any event you guys led me in the gps interference direction and that might well be the problem. If this is repeatable then I'll re-connect the 915 telemetry & see what happens. Would be nice to know if v3.3 does more checking of gps position information quality than v3.2 was doing which would explain why this is just happening now.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service