Warning #1: an issue has been found with Tower's Pause button which can cause the vehicle to fly to an old position if the vehicle has not sent a position update to Tower in some time.

Warning #2: Copter-3.3.2 fixes a bug found in Copter-3.3.1's desired climb rate initialisation which could lead to a sudden momentary drop when switching from Stabilize or Acro to AltHold, Loiter or PosHold.

Warning #3: Copter-3.3.2 fixes an issue found in Copter-3.3.1 which could lead to hard landings in RTL or AUTO if the WPNAV_SPEED_DN was set too high (i.e. >400 or 4m/s) and/or the WPNAV_ACCEL_Z was set too low (i.e. <100 or 1m/s/s).

Warning #4: a bug was found in Copter-3.3 which could cause a sudden crash if you abort a Take-off initiated from a ground station.  Video description is here.  The bug is fixed in Copter-3.3.1 so we recommend upgrading.

Note #1: AC3.3-rc8 corrected a long standing bug in the HDOP reporting.  HDOP values will appear about 40% lower than previously but this does not actually mean the GPS position is better than before.
Note #2: if upgrading from AC3.2.1 the vehicle's accelerometer calibration needs to be done again.
Note #3: set SERIAL2_PROTOCOL to "3" and reboot the board to enable FrSky telemetry like in previous versions.
Note #4: the wiki will be updated over the next few weeks to explain how to use the new features

Copter-3.3.1 is available through the mission planner.  The full list of changes vs AC3.2.1 can be see in the ReleaseNotes and below are the most recent changes since AC3.3.

Sadly this version (and all future versions) will not run on the APM2.x boards due to CPU speed, flash and RAM restrictions.

Changes from 3.3:

1) Bug fix to prevent potential crash if Follow-Me is used after an aborted takeoff

2) compiler upgraded to 4.9.3 (runs slightly faster than 4.7.2 which was used previously)

Changes from 3.3-rc11:

1) EKF recovers from pre-arm "Compass variance" failure if compasses are consistent

Changes from 3.3-rc10:

1) PreArm "Need 3D Fix" message replaced with detailed reason from EKF

Changes from 3.3-rc9
1) EKF improvements:
    a) simpler optical flow takeoff check
2) Bug Fixes/Minor enhancements:
    a) fix INS3_USE parameter eeprom location
    b) fix SToRM32 serial protocol driver to work with recent versions
    c) increase motor pwm->thrust conversion (aka MOT_THST_EXPO) to 0.65 (was 0.50)
    d) Firmware version sent to GCS in AUTOPILOT_VERSION message
3) Safety:
    a) pre-arm check of compass variance if arming in Loiter, PosHold, Guided
    b) always check GPS before arming in Loiter (previously could be disabled if ARMING_CHECK=0)
    c) sanity check locations received from GCS for follow-me, do-set-home, do-set-ROI
    d) fix optical flow failsafe (was not always triggering LAND when optical flow failed)
    e) failsafe RTL vs LAND decision based on hardcoded 5m from home check (previously used WPNAV_RADIUS parameter)

Thanks for your testing!

Views: 374926

Reply to This

Replies to This Discussion

Hello Leonardt,
The behavior is really strange! I try to explain it again:-)

I flew with my small G250 Copter very well, AC3.3-rc7, autotuned and with a Futaba 9z/jeti System.
Then I tried my new Taranis with a d4r2 Rx and the trouble starts.

I can fly the copter normal and smooth, but with hart inputs either from the Tx or the FCU the Copter starts wobbling as you can see in the video above.

I tried everything, repositioning of the Rx, a new x8r Rx, AC3.2.1, starting from the scratch, recalibrating and different PIDs (as you menthiont Leonardt, by in creasing the Rate_P by 0.1 the copter I was not able to steer) but nothing changed the behavior. In any case when I change to my old Futaba/Jeti system, then there is no wobbling.

The wobbling also happens when I switch from PosHold to RTL. Or when I start the Autotune, the Kopter nearly fall out of the Sky but become stable after some wobbles:-)

How can the copter/FCU change the behavior just by changing the Tx/Rx system??

In my dropbox is a Log where you can see the behavior!
I realy have no clue, what it can be!?!

Any Idea what It can be?
Thanks for help

I also would appreciate a working SToRM32 controller with pixhawk via serial! 

normally i set battery low to 13.5V to gain enough Flight time.

Is it important or shall i leave MOT_THST_BAT_MIN = 14 ?

OK, guys, best my novice investigation skills can tell, something has changed recently for tricopters. I'm fairly certain I flew 3.3RC5, but I know I have flown 3.3RC3 or RC4, because I have used the new autotune mode, one axis at a time, and things worked alright, if that gives you some historical reference.

ANYWAY, in AC3.3RC7, the firmware doesn't seem to take RC7_REV into account, meaning that the tricopter goes into a death spiral as soon as it leaves the ground. I've tried it with RC7_REV = 1 (Normal) and RC7_REV = -1 (Reversed) and there was no change in behavior. It even spins the same direction (to the right, or clockwise when viewed from above). Confirmed that this does NOT happen with AC3.2.1, but not sure when it showed up in AC3.3 (like I said, I have flown versions of AC3.3 without issue, I believe that this is new with 3.3RC7, but maybe I missed RC5, not sure). Log attached below, if that's helpful. They are labeled as they were set, one with Normal servo direction on RC7_REV, and one with Reversed servo direction. Shared via DropBox due to size limitations. Let me know if this is the wrong format or doesn't work.

Tricopter is currently unflyable. Help me Obi-Wan, you're my only hope.



Maybe something broke here?


This is the only mayor rework that happened with the tricopter code since April and has to do with the servo.

Yeah, try setting YAW_SV_REV to 1. Now there is also YAW_SV_MIN, YAW_SV_TRIM, and YAW_SV_MAX for min, center and max PWM output to the servo as well.

Hi Randy,

0.70 is a big step behind 0.80 or 0.82e (pan/yaw axis problems).

I will check if 0.70 is running for me (maybe a configuration issue from my side).

Hopefully there is a chance to get the 0.80 and above running with AC 3.3

What GCS are you using? Have you tried a different one? I would think more copter would be having problems with such a basic setting. Maybe it is the GCS that isn't properly doing what you expect. I noticed in a quick Google search that something similar had been a problem before.  Just a thought...

You need to set YAW_SV_REV to -1 sorry.

I'm primarily using APM Planner 2 for the Mac. I was having connection issues on my laptop, which has been pretty regular and I'm not the only one who has had issues on the Mac version of APM Planner 2 for some time now over several versions (sometimes it doesn't want to connect via telemetry, sometimes USB is having a bad weiner day, and between both of my computers sometimes it works sometimes it doesn't), so I went to my desktop. I also tried APM Planner 2 for PC (same computer, different partition), as well as APM Planner 1.whatever the latest version is for PC. I don't have an Android tablet, so I can't try changing the settings that way, but I don't think the Android GCSs give you that level of control, anyway. I don't mess around with QGroundControl or any of the other GCSs, either.

Anyway, yes, I have tried different computers and version to confirm that the setting was in fact changing (and even reflashed the board several times). The log files I posted were a clean reset to defaults reflash (after flashing Rover to make sure it REALLY nuked all the settings), then I set the yaw servo to reversed (as it should be) to get the first log, THEN I went back and set it to Normal (as it comes from a clean reflash). So I know the settings are in fact changing.

Aha! I figured it was something like that. I will go plug the tricopter in and see what that does. Thanks!

Strange, I didn't even have the tricopter yet in April, and I flashed the latest version sometime in early June and that was the version that worked.

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service