Warning #1: an issue has been found with Tower's Pause button which can cause the vehicle to fly to an old position if the vehicle has not sent a position update to Tower in some time.

Warning #2: Copter-3.3.2 fixes a bug found in Copter-3.3.1's desired climb rate initialisation which could lead to a sudden momentary drop when switching from Stabilize or Acro to AltHold, Loiter or PosHold.

Warning #3: Copter-3.3.2 fixes an issue found in Copter-3.3.1 which could lead to hard landings in RTL or AUTO if the WPNAV_SPEED_DN was set too high (i.e. >400 or 4m/s) and/or the WPNAV_ACCEL_Z was set too low (i.e. <100 or 1m/s/s).

Warning #4: a bug was found in Copter-3.3 which could cause a sudden crash if you abort a Take-off initiated from a ground station.  Video description is here.  The bug is fixed in Copter-3.3.1 so we recommend upgrading.

Note #1: AC3.3-rc8 corrected a long standing bug in the HDOP reporting.  HDOP values will appear about 40% lower than previously but this does not actually mean the GPS position is better than before.
Note #2: if upgrading from AC3.2.1 the vehicle's accelerometer calibration needs to be done again.
Note #3: set SERIAL2_PROTOCOL to "3" and reboot the board to enable FrSky telemetry like in previous versions.
Note #4: the wiki will be updated over the next few weeks to explain how to use the new features

Copter-3.3.1 is available through the mission planner.  The full list of changes vs AC3.2.1 can be see in the ReleaseNotes and below are the most recent changes since AC3.3.

Sadly this version (and all future versions) will not run on the APM2.x boards due to CPU speed, flash and RAM restrictions.

Changes from 3.3:

1) Bug fix to prevent potential crash if Follow-Me is used after an aborted takeoff

2) compiler upgraded to 4.9.3 (runs slightly faster than 4.7.2 which was used previously)

Changes from 3.3-rc11:

1) EKF recovers from pre-arm "Compass variance" failure if compasses are consistent

Changes from 3.3-rc10:

1) PreArm "Need 3D Fix" message replaced with detailed reason from EKF

Changes from 3.3-rc9
1) EKF improvements:
    a) simpler optical flow takeoff check
2) Bug Fixes/Minor enhancements:
    a) fix INS3_USE parameter eeprom location
    b) fix SToRM32 serial protocol driver to work with recent versions
    c) increase motor pwm->thrust conversion (aka MOT_THST_EXPO) to 0.65 (was 0.50)
    d) Firmware version sent to GCS in AUTOPILOT_VERSION message
3) Safety:
    a) pre-arm check of compass variance if arming in Loiter, PosHold, Guided
    b) always check GPS before arming in Loiter (previously could be disabled if ARMING_CHECK=0)
    c) sanity check locations received from GCS for follow-me, do-set-home, do-set-ROI
    d) fix optical flow failsafe (was not always triggering LAND when optical flow failed)
    e) failsafe RTL vs LAND decision based on hardcoded 5m from home check (previously used WPNAV_RADIUS parameter)

Thanks for your testing!

Views: 374519

Reply to This

Replies to This Discussion

Richard,

Thanks for giving it a try.  I think you have a very powerful copter (with a 6S battery?) because it hovers at about 36% throttle.  I see the THR_MID is set to 460 so that could be lowered a bit (maybe down to 400) to give you more control at the low end.

I suspect you can also lower the THR_MIN value to free up more control at the bottom end.  The default is 130 (which is what your vehicle is using) but that's quite conservative.  I suspect you could lower it to 90 but that's a guess.   It depends upon the deadzone of the particular ESC being used.  If you lower this value you might also want to set MOT_SPIN_ARMED to a lower but non-zero value.  So maybe MOT_SPIN_ARMED to 70, THR_MIN to 90.

I'm sure you know, setting MOT_SPIN_ARMED to zero means the props don't spin until you raise the throttle - this is fine, some people prefer this but using MOT_SPIN_ARMED is useful for finding out how big the ESC's deadzone is at the bottom.  So you can set MOT_SPIN_ARMED to just enough to get the motors spinning, then set THR_MIN 20 or 30 pwm higher to add more insurance that they'll keep spinning in the air.

Randy,

thanks for clarification!

Well, it is not stated directly but at 26.13 Compass is attached via an external cable (COMPASS_EXTERNAL) the following entries are about Compass2. 

Cheers,

Thorsten

Hi Adolfo,

maybe Fast and Raw are not working in parallel. If Raw is enabled Acc1 and Acc2 are logged not IMU1 and IMU2.

Regarding the "grass" vibrations seem to be no problem on your setup. However, I would appreciate if you could give RAW (only) another try. Just a short non-aggressive flight :-)

Thanks!

Thorsten

Jason,

I think it's a mechanical failure of some type affecting the front-right motor.  It's likely this motor because the vehicle flips right and forward and that motor's output (#1) goes to max while it's opposite (motor #2 on back left) goes to it's minimum.

There's also a moment just before the flip where (perhaps due to the yaw demand) that motor goes low.  The #1 motor going low should not be a problem but it could be if that ESC isn't calibrated correctly or the THR_MIN is too low.  I see the THR_MIN has already been increased from the default of 130 to 160 so it's a bit odd - my guess is that all the ESCs should be calibrated again.

Tell me exactly what you want me to do during flight.

Another 2 min of loiter in the same spot and some cruising around again in loiter ??

Hi Paul,

Yes, I haven't included it in -rc8 but I will still prepare a patch on -rc8 in the next couple of days so you can give it a try and provide some feedback.  Based on that we can see if it's good enough or whether we need to go back and look for a different solution.

I'm getting this as well... 

Error preparing inserttable: insert or replace into 'GRAW' (idx,"TimeMS","WkMS","Week","numSV","sv","cpMes","prMes","doMes","mesQI","cno","lli") values (?,?,?,?,?,?,?,?,?,?,?,?); Error is: table GRAW has no column named cpMes Unable to execute statement

Randy,

i made a short test with my AUAV-X2 and -rc8:

LogWhenDisarmed = ENABLED

When powered over USB the log gives a 5 on Powr/Flags.
When powered with battery the log gives a 7 on Powr/Flags.

That means, the Bit for USB_CONNECTED is always 1.

It seems, the problem is NOT solved...

Randy, do you know, is it normal?

Hello all,

I'm hoping someone can offer some input. Ive been flying 3.2.1 since its release and I saw that 3.3 was released, so wanted to give it a try. (3.3rc7) 1300 sized quad running 6S, T-motor 4014-11 330Kv with and all up flight weight of 6200g. I tried Stab, Alt Hold, and Pos Hold. The quad seemed much more responsive and generally smoother flying even with the default PIDs.

I was flying in Pos Hold and all was well until about minute 9 where the quad started to uncontrollably descend and yaw counter clockwise. I tried to feed it counter yaw and boosted the throttle to attempt to keep some altitude. Nothing worked and it crashed, fairly gently however. No real damage just a significant twist to the gimbal as the gear was still descending and didn't make it. I've looked at the logs and Yaw seems to be leading DesYaw but not drastically. The clockwise motors were hot to the touch as would be expected from chasing the yaw for 9 minutes.

I'm not experienced with logs and was hoping for some input.

I can't attach the log as its too large so heres a link:

https://drive.google.com/file/d/0B1CbIAUo7keqblZuRXdPS0NJc0U/view?u...

Thanks!

Tried out 3.3r8 today on a 680 quad, 6s 380kv 15in props.

Re did the Acc and compass calibration.

After installing 3.3r8 my voltage and current sensor stopped working, after about the third time plugging and unplugging the battery voltage started showing again.

The GPS is now struggling to get lock and took a rediculusly long time to lock and kept loosing lock for the first 10mins or so. Struggling to get 8 Sats where as I previously got 15 quickly indoors.

Loiter and Althold drop altitude pretty badly when ever any speed is built up, more so than 3.2 did.

Loiter is very loose sliding for a long time before holding position.



Resistance to uncontrolled climb out when going fast is better than before, the sound of my copter would suddenly change and a harmonic could be heard then the quad would climb to 150ft before settling down again.

Now when the harmonic is heard and uncontrolled climb out starts I can lower the throttle and recover in less than 50 ft.

Randy, so i've done some deeper testing today.

I couldn't get apm anymore to run into EKF error. (Red/Yellow flashing led)
Probably the problem was solved by re-run compassmot in a reasonable manner. This is not so simple as the motors are spinning up to 20000 rpm  and consume 160 Amps. But i think this time i've done it right. I will record it next time as the sound of motors is really impressive,
What i noticed instead is that the throttle mid value is causing the problem. Seems that values below 300 are accepted and saved but not taking any effect. The Throttle in and Throttle out values remaining same no matter if throttle mid is set to 200 or 300. No difference. Perhaps you could look into ?

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service