Warning #1: an issue has been found with Tower's Pause button which can cause the vehicle to fly to an old position if the vehicle has not sent a position update to Tower in some time.

Warning #2: Copter-3.3.2 fixes a bug found in Copter-3.3.1's desired climb rate initialisation which could lead to a sudden momentary drop when switching from Stabilize or Acro to AltHold, Loiter or PosHold.

Warning #3: Copter-3.3.2 fixes an issue found in Copter-3.3.1 which could lead to hard landings in RTL or AUTO if the WPNAV_SPEED_DN was set too high (i.e. >400 or 4m/s) and/or the WPNAV_ACCEL_Z was set too low (i.e. <100 or 1m/s/s).

Warning #4: a bug was found in Copter-3.3 which could cause a sudden crash if you abort a Take-off initiated from a ground station.  Video description is here.  The bug is fixed in Copter-3.3.1 so we recommend upgrading.

Note #1: AC3.3-rc8 corrected a long standing bug in the HDOP reporting.  HDOP values will appear about 40% lower than previously but this does not actually mean the GPS position is better than before.
Note #2: if upgrading from AC3.2.1 the vehicle's accelerometer calibration needs to be done again.
Note #3: set SERIAL2_PROTOCOL to "3" and reboot the board to enable FrSky telemetry like in previous versions.
Note #4: the wiki will be updated over the next few weeks to explain how to use the new features

Copter-3.3.1 is available through the mission planner.  The full list of changes vs AC3.2.1 can be see in the ReleaseNotes and below are the most recent changes since AC3.3.

Sadly this version (and all future versions) will not run on the APM2.x boards due to CPU speed, flash and RAM restrictions.

Changes from 3.3:

1) Bug fix to prevent potential crash if Follow-Me is used after an aborted takeoff

2) compiler upgraded to 4.9.3 (runs slightly faster than 4.7.2 which was used previously)

Changes from 3.3-rc11:

1) EKF recovers from pre-arm "Compass variance" failure if compasses are consistent

Changes from 3.3-rc10:

1) PreArm "Need 3D Fix" message replaced with detailed reason from EKF

Changes from 3.3-rc9
1) EKF improvements:
    a) simpler optical flow takeoff check
2) Bug Fixes/Minor enhancements:
    a) fix INS3_USE parameter eeprom location
    b) fix SToRM32 serial protocol driver to work with recent versions
    c) increase motor pwm->thrust conversion (aka MOT_THST_EXPO) to 0.65 (was 0.50)
    d) Firmware version sent to GCS in AUTOPILOT_VERSION message
3) Safety:
    a) pre-arm check of compass variance if arming in Loiter, PosHold, Guided
    b) always check GPS before arming in Loiter (previously could be disabled if ARMING_CHECK=0)
    c) sanity check locations received from GCS for follow-me, do-set-home, do-set-ROI
    d) fix optical flow failsafe (was not always triggering LAND when optical flow failed)
    e) failsafe RTL vs LAND decision based on hardcoded 5m from home check (previously used WPNAV_RADIUS parameter)

Thanks for your testing!

Views: 374766

Reply to This

Replies to This Discussion

Paul,

Ok, thanks for that report.  I think what must be happening is the GPS must be restarting and the standard config for the compass is not to send the new hdop message.  One way to fix it would be to connect to the GPS using u-center and default that message to on.  A better solution would be for us to add support in the driver to set this message on if we find it's not appearing.

A few things I forgot to mention.

  • I wonder why that GPS is restarting.  Maybe it's a power problem.
  • we will fix the issue so that an hdop of "0" is equivalent to a very high hdop.

I'm wondering if the zero hdop happens after the GPS has been running for a while and producing good hdop values or was it always zero from startup?

Pritam,

If you have a look from when the AutoTune was performed Leonard can probably take a look.

3CityDrones,

The problem is probably caused by very high vibrations.  Below is the output of the VIBE message which shows the vibrations are up above 50m/s/s and clipping of the accelerometers is also happening.  So not sure what vibration isolation system you're using but I'd recommend the 3M foam.  Feel free to post a picture of how your flight controller is mounted.

Robert,

No much has changed in PosHold vs AC3.2.1 but it's certainly possible that it's been broken somehow.  Have you tested AC3.2.1's PosHold with the same parameters to see that it performs better?  I'd just like to confirm that this is an AC3.3 issue instead of a general PosHold performance issue.

Odd issue with RC8 and telemetry radio.

I'm having an odd issue with RC8. I got my replacement hawk [it is a Hawk Lite] today and it comes with an oddball 3.3-dev firmware on it for quad. So I flashed it with 3.3-rc8 for hex and I lose the ability to use my Telemetry radios. It's a 4 wire air unit and when I flash back to 3.2.1 it works fine. Flash it back to 3.3-rc8 and it no longer connects. When watching the air unit on 3.2.1 you can see the data light blink as it should suggesting it is passing MavLink data fine, but on 3.3-rc8 there is no blinking at all suggesting it is not passing the mavlink data at all.

I faintly remember seeing others with this issue in this HUGE thread but I can't find it using the search so I don't know what I need to do to enable it to work in rc8.

I can't fly to test the new board until I am able to use the radios because I refuse to fly without them. 

Can anyone point me in the right direction on this issue? I seem to remember it being something about CTS/RTS but the only air unit I have that supports that is on my X8 and I have 4 other air units but they are all 4 wire.

Thanks.

This is weird. Seems that flashing it back to 3.2.1 and then connecting then flashing it back to 3.3-rc8 has fixed the issue for me as now it connects fine. Not sure how or why it fixed it but it seems to have and that means now I get to calibrate and test! Joy.

Craig,

There may be an issue with the auto detect of the flow control pins.  Setting BRD_SER1_RTSCTS or BRD_SER2_RTSCTS to zero will likely sort it out.  There is also a PR to fix the underlying issue but I'll need to test it first.  Maybe we need to put that into -rc9.

Thanks Randy for your prompt answer! I have copied this info and will post it on the RGC group for the Lite board just in case anyone else has this issue.

I find it strange that flashing it back to 3.2.1 then back to 3.3-rc8 also fixed it as well though.

And yes I would think that putting the fix into rc9 will go a long way in avioding having to answer this issue over and over as I am pretty sure I am not the only one running 4 wire radios :)

Thanks again for the work around though!

Motors and props are perfectly balanced. FC is mounted by using thick 3m foam, exactly.
When FC replaced by naze32 , copter is flying briliant. Are you sure it's vibrations?
Please look at the magnetometer data... MagX for example. For me it could be caused by electromagnetic interferences - as problem is happening mainly in one place...
With rc7 copter is wobbling-in comparing to rc5. No autotune has been done since rc5.

Randy - you might be right, I did not use/test position hold intensively before 3.3 so I am not sure. Due to the nature of problems (copter movements) I assumed it is EKF related but it is assumption only.

3citydrones,

The VIBE message is pretty definitive about the amount of vibration.  I'm not necessarily saying it's the only cause of the EKF-Check errors but the vibrations are very serious it would be best to resolve that issue first.  The levels are about 3x what my IRIS produces and in the same range as the Evgeny logs in which the vehicle lost attitude control.

We are working on improved vibration resistance for -rc9 but in any case, these vibes are pretty serious and should be taken care of.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service