Warning #1: an issue has been found with Tower's Pause button which can cause the vehicle to fly to an old position if the vehicle has not sent a position update to Tower in some time.

Warning #2: Copter-3.3.2 fixes a bug found in Copter-3.3.1's desired climb rate initialisation which could lead to a sudden momentary drop when switching from Stabilize or Acro to AltHold, Loiter or PosHold.

Warning #3: Copter-3.3.2 fixes an issue found in Copter-3.3.1 which could lead to hard landings in RTL or AUTO if the WPNAV_SPEED_DN was set too high (i.e. >400 or 4m/s) and/or the WPNAV_ACCEL_Z was set too low (i.e. <100 or 1m/s/s).

Warning #4: a bug was found in Copter-3.3 which could cause a sudden crash if you abort a Take-off initiated from a ground station.  Video description is here.  The bug is fixed in Copter-3.3.1 so we recommend upgrading.

Note #1: AC3.3-rc8 corrected a long standing bug in the HDOP reporting.  HDOP values will appear about 40% lower than previously but this does not actually mean the GPS position is better than before.
Note #2: if upgrading from AC3.2.1 the vehicle's accelerometer calibration needs to be done again.
Note #3: set SERIAL2_PROTOCOL to "3" and reboot the board to enable FrSky telemetry like in previous versions.
Note #4: the wiki will be updated over the next few weeks to explain how to use the new features

Copter-3.3.1 is available through the mission planner.  The full list of changes vs AC3.2.1 can be see in the ReleaseNotes and below are the most recent changes since AC3.3.

Sadly this version (and all future versions) will not run on the APM2.x boards due to CPU speed, flash and RAM restrictions.

Changes from 3.3:

1) Bug fix to prevent potential crash if Follow-Me is used after an aborted takeoff

2) compiler upgraded to 4.9.3 (runs slightly faster than 4.7.2 which was used previously)

Changes from 3.3-rc11:

1) EKF recovers from pre-arm "Compass variance" failure if compasses are consistent

Changes from 3.3-rc10:

1) PreArm "Need 3D Fix" message replaced with detailed reason from EKF

Changes from 3.3-rc9
1) EKF improvements:
    a) simpler optical flow takeoff check
2) Bug Fixes/Minor enhancements:
    a) fix INS3_USE parameter eeprom location
    b) fix SToRM32 serial protocol driver to work with recent versions
    c) increase motor pwm->thrust conversion (aka MOT_THST_EXPO) to 0.65 (was 0.50)
    d) Firmware version sent to GCS in AUTOPILOT_VERSION message
3) Safety:
    a) pre-arm check of compass variance if arming in Loiter, PosHold, Guided
    b) always check GPS before arming in Loiter (previously could be disabled if ARMING_CHECK=0)
    c) sanity check locations received from GCS for follow-me, do-set-home, do-set-ROI
    d) fix optical flow failsafe (was not always triggering LAND when optical flow failed)
    e) failsafe RTL vs LAND decision based on hardcoded 5m from home check (previously used WPNAV_RADIUS parameter)

Thanks for your testing!

Views: 374811

Reply to This

Replies to This Discussion

Upgrading AC from 3.2.1 to 3.3 caused PIDs confusion.

I've never changed PID values for my PixHawk based quadcopter before. I always used the default values, and it flew perfectly. But one day after upgrading the firmware to AC3.3 (I did all necessary sensors re-calibration) my quad started flying very wobbly. It was harshly oscillating in any flight mode, especially when I let it just hover and do not touch a controller. It was twitching instead of being calm. I've never faced anything like that before... Sample video: https://youtu.be/FBSDrych4wo


I realised that it's a PID related issue and I decided to run AutoTune - I thought it's the easiest way to sort it out. After facing a crash during the AutoTune session (gps stick + arm were broken) I understood that it won't be so easy. Video: https://youtu.be/NfqnJZm1NsQ

I've gone through the Arducopter wiki and some other tutorials on Youtube, and tried to tune PIDs manually.
At first it was rather successful - I decreased Rate P value a bit (from 0.150 to 0.126) and those crazy oscillations went away.

Then I've faced the same issue that I had during AutoTune session:
1. I move roll/pitch stick in one direction
2. The quad gets some horizontal speed
3. Then I harshly move the stick in opposite direction (for emergency breaking or to instantly change the flight direction to the opposite one)
4. The quad tilts in that direction and starts resisting the speed and attitude (what is absolutely expected)
5. Then it suddenly kind of flies off the handle... and does a half-flip/flip of death with rotation around the vertical axis
Please see the video, which demonstrates several flips like that: https://youtu.be/jq_N8E_c4M4 (could provide log files if needed)

I tried to increase Rate I value (from 0.100 to 0.150) to solve the issue. At first it seemed to help. I got rid of the flips at a low speed, but when the quad speeded up significantly it appeared again.

Unfortunately, I didn't manage to play with Rate D, because of the broken GPS mast.

Gents, what parameter tuning could help me with the issue described above (flips)? Didn't try Rate D and Stabilize P yet.

Thank you in advance!

---

My quad details
Frame: custom 350mm V type (not Vtail)
Weight: around 1kg
Motors: SunnySky 2208 1100KV
ESC: Afro Opto 20a
Props: 8045 plastic
Battery: 4S 3300mah
FC: Pixhawk installed on a dampered plate

Hi John,

sorry to see your crash!!

Can you please provide a log of the flip and a couple of photos of your copter.

This is how you need to tune your copter.

Reduce Rate P, I, and D by 25% at a time, from defaults, until your copter is stable.

Increase Rate D until you start to see oscillations.

Reduce Rate D until you don't see oscillations

Increase Rate P until you see oscillations

Decrease Rate P until you see oscillations

Set Rate I equal to P

Check to make sure your copter is stable when quickly rolled and pitched to 45 degrees and the stick is let go. Don't hold the stick to build up speed, this test should be done as quickly as possible.

If the copter passes this test perform Autotune on each axis.

I have done about a dozen flights now with V3.3 on my littlest Pix, a 320_mm hexacopter.  I had a few issues with the Autotune and PIDs on upgrade, but this thread has helped me sort those out.  Thanks boyz.  I have been pretty satisfied with V3.3

But, today I have landing gear and a bent arm to repair. On my last flight, it inexplicably dropped from the sky.  I have tried to decipher the cause from my logs, but I don't have the experience to determine the issue. It felt like a voltage drop, but the battery had over 11_V remaining and the cells are within .1_V of each other.

Can anybody suggest the culprit? . . . 

Attachments:
Hi I have a quad done auto tune flies great with 3.3.1
When in drift mode it can reach 50mph but is OK up to 30/35 mph but above that it starts to dive loosing height tried changing max angle for all flight modes to 30' but still losses hight above 35mph
could this be software or does any one think frame/mechanic have reached its limit on forward speed and power to keep nose up enough to maintain hight
It's not a barometer problem as I cover whole pixhawk in cling film to keep out wind altering pressure on barometer
Stuart

you should NEVER cover the holes on the baro. Use dense foam not cling wrap.

Hi yes there is dense foam over the barometer in the pixhawk case
Stuart

Logs: http://1drv.ms/1MPxlJ5

First file - P value tuning. Second one - more about I value tuning.

Photo: http://1drv.ms/1PuM8I2

The only difference is that GPS is put on stick now (the same location, but on stick).

What Craig is getting at is that you said you cover the whole pixhawk in cling film, which is essentially the same as covering the holes on the barometer rendering it useless.

Oh sorry no I only covered with cling film over the top to stop wind blowing in directly it was no where near air tight or all around
I still got height reading on mission planer
Cheers stuart

sorry missread where you said you covered the entire hawk in cling wrap and not just the baro :( 

Hi stubugs,

Can you provide a log please.

Will do but hopefully tomoz as is 11.10at night here lol so if it's not raining I'll try tomorrow cheers stuart

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service