Warning #1: an issue has been found with Tower's Pause button which can cause the vehicle to fly to an old position if the vehicle has not sent a position update to Tower in some time.

Warning #2: Copter-3.3.2 fixes a bug found in Copter-3.3.1's desired climb rate initialisation which could lead to a sudden momentary drop when switching from Stabilize or Acro to AltHold, Loiter or PosHold.

Warning #3: Copter-3.3.2 fixes an issue found in Copter-3.3.1 which could lead to hard landings in RTL or AUTO if the WPNAV_SPEED_DN was set too high (i.e. >400 or 4m/s) and/or the WPNAV_ACCEL_Z was set too low (i.e. <100 or 1m/s/s).

Warning #4: a bug was found in Copter-3.3 which could cause a sudden crash if you abort a Take-off initiated from a ground station.  Video description is here.  The bug is fixed in Copter-3.3.1 so we recommend upgrading.

Note #1: AC3.3-rc8 corrected a long standing bug in the HDOP reporting.  HDOP values will appear about 40% lower than previously but this does not actually mean the GPS position is better than before.
Note #2: if upgrading from AC3.2.1 the vehicle's accelerometer calibration needs to be done again.
Note #3: set SERIAL2_PROTOCOL to "3" and reboot the board to enable FrSky telemetry like in previous versions.
Note #4: the wiki will be updated over the next few weeks to explain how to use the new features

Copter-3.3.1 is available through the mission planner.  The full list of changes vs AC3.2.1 can be see in the ReleaseNotes and below are the most recent changes since AC3.3.

Sadly this version (and all future versions) will not run on the APM2.x boards due to CPU speed, flash and RAM restrictions.

Changes from 3.3:

1) Bug fix to prevent potential crash if Follow-Me is used after an aborted takeoff

2) compiler upgraded to 4.9.3 (runs slightly faster than 4.7.2 which was used previously)

Changes from 3.3-rc11:

1) EKF recovers from pre-arm "Compass variance" failure if compasses are consistent

Changes from 3.3-rc10:

1) PreArm "Need 3D Fix" message replaced with detailed reason from EKF

Changes from 3.3-rc9
1) EKF improvements:
    a) simpler optical flow takeoff check
2) Bug Fixes/Minor enhancements:
    a) fix INS3_USE parameter eeprom location
    b) fix SToRM32 serial protocol driver to work with recent versions
    c) increase motor pwm->thrust conversion (aka MOT_THST_EXPO) to 0.65 (was 0.50)
    d) Firmware version sent to GCS in AUTOPILOT_VERSION message
3) Safety:
    a) pre-arm check of compass variance if arming in Loiter, PosHold, Guided
    b) always check GPS before arming in Loiter (previously could be disabled if ARMING_CHECK=0)
    c) sanity check locations received from GCS for follow-me, do-set-home, do-set-ROI
    d) fix optical flow failsafe (was not always triggering LAND when optical flow failed)
    e) failsafe RTL vs LAND decision based on hardcoded 5m from home check (previously used WPNAV_RADIUS parameter)

Thanks for your testing!

Views: 374141

Reply to This

Replies to This Discussion

Thank's Stephan

Hi, I get the bad accel health quite a bit in the colder weather. I've read Dmitry's thread and I'm not sure its the same problem as the sensors discharge issue. I see good data from the imu2 accelerometers when indoors, then I take it out where its cold and within 5 minutes imu2 goes bad. Then I can bring it indoors again and it'll start working. I've disabled the prearm checks for INS (then tried disabling all of them), and also have ins_use2=0. If I can manage to arm, it flies fine. But getting past that hurdle is sometimes difficult. I've found a workaround, to power up inside where its warmer then take the MR outside and arm/fly before the lsm303d goes bad (but sometimes this is difficult as the GPS needs a minute or two to lock in). Is there any way to disable the bad accel health warnings and ignore the lsm303d completely besides downgrading to AC3.2.1?

Hi Thorsten, I have not had an opportunity yet to see if the class 10 card I fitted has fixed the issue.. I will find out though one way or the other ..I am not sure I like the "None Small Medium and Detailed" logging options, I prefer to select specific items to log .. 

Hi Randy ...just to say thanks for your reply .. I have fitted a faster card i will see how that goes .. .. I have a concern with compass bar going into the red when the copter turns in Auto mode .. I have tried this with just a bare spare pixhawk board plugged into the PC, I get a similar result when move by hand .. otherwise the copter seems to be behaving it self now .. the green bars hardly move on the EKF monitor ..just compass getting up but only some times ..I have the internal compass disabled .. your thoughts ?

Hello,

i have a small tri running 3.3.2.on a pixfalcon. Flying in stabilize or pos hold there is always a small drift in yaw. Even when i keep the stick centered, it slowly turns.

Looking at the logs i found that the DesYaw also drifts and the tri follows quite well. Where does this drift in DesYaw come from?

Attachments:

Can someone help w/ pixracer APM support?  This isn't exactly 3.3 related, but seems like the best place to post.  (And sorry for double posting, I already mentioned this in the pixracer blog, but don't think I can attach logs there)

So, my pixracer seems to function properly w/ PX4.  I haven't flown much, but it sets up/calibrates ok. 

APM doesn't work.  I think I am narrowing down some of the issues to the USB connection (I have used different cables/ports, etc)
I plug the board in to my computer.  Program it w/ Qgc using APM alpha.  It programs fine.  I calibrate.  It goes through the steps, but doesn't save.  I look at the parameter list, and the offsets are there.  But, it keeps telling me I need to calibrate the compass. 
I disconnected the USB, and calibrated it over the telemetry modem, and the settings saved! 
But then, I get "bad gyro health" and "accelerometer unhealthy" (or something similar) 9 out of 10 power cycles. 
And finally, sometimes all the compass and accel calibrations are lost.  What's strange to me is my RC config and tuning remains, but the compass and accel settings are all back to 0's in the config.  I think this (cleared settings) only happens when plugged in to USB.  And it seems to be when I unplug from USB, it reboots the board, and the next time I plug it in those settings are gone.  And again, I have tried different cables and ports, and even 2 different computers.

Logs attached.  First one is when I enabled logging and was getting the gyro health error.  The second one is after unplugging the board, rebooting, and my compass settings were gone. 

Attachments:

I just ordered one myself I hope I don't go through the same issues.

So are you saying it seems to work okay with the PX4 firmware but not the APM firmware? Hopefully it's something that just needs tweaked in the settings. Please post back here or over at http://diydrones.com/profiles/blog/show?id=705844%3ABlogPost%3A2170...  if / when you figure it out. I would suggest emailing them directly over there at sales@auav.co  Hope it gets sorted out I was going to be running 3.4 dev myself. Have you tried 3.2 or 3.3? Do you have a gps with external mag? Perhaps disable the internal and see if that does the trick?? 

I have been in contact with Nikolay at AUAV. The APM stack does not communicate with the pixracer at this time. He assured me that the developers are working on it and should have a fix in the next couple of weeks. With multiple voices it might raise awareness.

Cheers,
Randy

Wow... that's not just a minor glitch. Thanks for the info. 

Well, I am using, or rather 'testing' the alpha version of 3.4 and having these issues. 
So, I'm still not sure if you are saying 3.3 should not be working, because you are correct.. It is not supported yet. 
Or, are you saying the developers know that even 3.4 alpha is not working? 
The people involved w/ AUAV have been saying on another forum, that APM 3.4 alpha should be working..   It's fine if it isn't, and I understand development means it could work one day and not the next..   I'd just like to know.

And Richard, px4 loads and calibrates w/out any problems, but I had issues w/ it too.. That may be simply my inexperience w/ px4.  I can't arm and take off in any mode other than manual, which is a problem if I want to be in acro and immediately take off and race in acro or something.  And, I have had issues disarming in modes other than manual.  Just sitting on my workbench, I can be in alt_hold (or altctl is what they call it) and put my throttle stick bottom left and it disarms.  But, out in the field it doesn't always.  Other quirks like that... 

This is much smaller than a standard pixahawk.. I bought one of these to try waiting for it to arrive. http://www.banggood.com/PX4-Pixhawk-Lite-V2_4_6-32Bits-Open-Source-...

The Pixhawk Lite is a great little board as long as you can live without a buzzer [which has caused a ton of people to semi brick them during a firmware flash by not waiting long enough for the upgrade to complete before hitting the ok button] But the Lite is a full Pixhawk whereas the new PixRacer is a stripped down PX4 so the PX4 stack works well on it but the APM stack hasn't had the needed [for lack of a better terminology] drivers written for APM yet. I've been following the development of the Racer for a while now on the PX4users group and it looks interesting but worth waiting a while for until they get all the kinks worked out.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service