Warning #1: an issue has been found with Tower's Pause button which can cause the vehicle to fly to an old position if the vehicle has not sent a position update to Tower in some time.

Warning #2: Copter-3.3.2 fixes a bug found in Copter-3.3.1's desired climb rate initialisation which could lead to a sudden momentary drop when switching from Stabilize or Acro to AltHold, Loiter or PosHold.

Warning #3: Copter-3.3.2 fixes an issue found in Copter-3.3.1 which could lead to hard landings in RTL or AUTO if the WPNAV_SPEED_DN was set too high (i.e. >400 or 4m/s) and/or the WPNAV_ACCEL_Z was set too low (i.e. <100 or 1m/s/s).

Warning #4: a bug was found in Copter-3.3 which could cause a sudden crash if you abort a Take-off initiated from a ground station.  Video description is here.  The bug is fixed in Copter-3.3.1 so we recommend upgrading.

Note #1: AC3.3-rc8 corrected a long standing bug in the HDOP reporting.  HDOP values will appear about 40% lower than previously but this does not actually mean the GPS position is better than before.
Note #2: if upgrading from AC3.2.1 the vehicle's accelerometer calibration needs to be done again.
Note #3: set SERIAL2_PROTOCOL to "3" and reboot the board to enable FrSky telemetry like in previous versions.
Note #4: the wiki will be updated over the next few weeks to explain how to use the new features

Copter-3.3.1 is available through the mission planner.  The full list of changes vs AC3.2.1 can be see in the ReleaseNotes and below are the most recent changes since AC3.3.

Sadly this version (and all future versions) will not run on the APM2.x boards due to CPU speed, flash and RAM restrictions.

Changes from 3.3:

1) Bug fix to prevent potential crash if Follow-Me is used after an aborted takeoff

2) compiler upgraded to 4.9.3 (runs slightly faster than 4.7.2 which was used previously)

Changes from 3.3-rc11:

1) EKF recovers from pre-arm "Compass variance" failure if compasses are consistent

Changes from 3.3-rc10:

1) PreArm "Need 3D Fix" message replaced with detailed reason from EKF

Changes from 3.3-rc9
1) EKF improvements:
    a) simpler optical flow takeoff check
2) Bug Fixes/Minor enhancements:
    a) fix INS3_USE parameter eeprom location
    b) fix SToRM32 serial protocol driver to work with recent versions
    c) increase motor pwm->thrust conversion (aka MOT_THST_EXPO) to 0.65 (was 0.50)
    d) Firmware version sent to GCS in AUTOPILOT_VERSION message
3) Safety:
    a) pre-arm check of compass variance if arming in Loiter, PosHold, Guided
    b) always check GPS before arming in Loiter (previously could be disabled if ARMING_CHECK=0)
    c) sanity check locations received from GCS for follow-me, do-set-home, do-set-ROI
    d) fix optical flow failsafe (was not always triggering LAND when optical flow failed)
    e) failsafe RTL vs LAND decision based on hardcoded 5m from home check (previously used WPNAV_RADIUS parameter)

Thanks for your testing!

Views: 374809

Reply to This

Replies to This Discussion

I have a couple of issues which I can't figure out.

1. At the field the last couple of times I have not been able to get a 3D GPS fix at all. HDOP stays at 99. Now I'm in my office and I'm getting a 3D fix inside easily, which seems crazy. The only differences are I just upgraded to 3.3.3 from 3.3.2rc, it's warmer in my office than outside (by about 20o) and I am on USB power rather than battery. can't really see how any of these would translate into GPS no workee. Any ideas? It's not a connection issue in case anyone wants to suggest that :)

2. I have calibrated the accelerometers multiple times but I end up with a corner drooping in flight and the copter drifting a lot in AltHold. Could this be temp related? How flat does the mounting of the FC have to be relative to the frame? I would have thought that the calibration and leveling would take care of any discrepencies, but does it?

AUAV-X2 if it matters.

Andy, I see similar things, were it boots up fine, but will not lock GPS until I unplug it and start over. Then it works fine. Have you tried that? As for the leveling, that is done when you arm it. Whatever angle it is when you arm is what it considers level. Calibration, it seems is affected by the temp. I was having problems with accel and magnetometer cals and it was suggested that I cal in the cold. That seems to help, though it isn't as cold out now. Hope that helps.

I tried many reboots and change of batteries - same result. It definitely coincided with my upgrade to 3.3.2rc, but now is gone again. I guess I'll have more concrete proof if its now fine at the field.
I'd be surprised if level was set at arming - that can't be level at all!


The limits are enforced by the mission planner but only on the extended tuning screen.  If you adjust them using the full parameter list (or full parameter tree) screen then it's possible to set them to whatever you like.

If it's a heading hold problem then adjusting the yaw parameters is more likely to help.  So for example, on the Extended Tuning screen (of mission planner), the Stabilize Yaw, and Rate Yaw parameters.

The compass's effect on the heading is quite slow, it's really most the Z-axis gyro that controls the heading so it makes sense that re-calibrating the compass didn't help much.

Hi Randy

I had a crash today.After the first flight (about 17min) I decided  to had another flight. The copter was in hover and just increased the throtle (In pos.hold mode about 3-4 meters from ground) with out any other input  the copter leaned right and it fell to the ground like a rock.


pixhwak with copter v.3.3.3



Any advice setting up the Z1 Tiny 2 in APM Mission Planner?  What gimbal type do you select?  (I assumed servo since that's the type of input that the tiny 2 would accept from a normal receiver).  For whatever reason when I try to connect the input pins for the Z1 Tiny 2 to my Autopilot (driven by ppm from receiver) it just buzzes and doesn't care about what inputs I'm giving from my radio.  If plug it in directly to the receiver it behaves like it should (slews to where I have my radio set to).  

Thanks in advance,


of course level is not set on arming....

Randy,when can we expect 3.4 in mission planer....is this thread dead or what(no post for 7 days),do i need to follow whats new somewhere else?

just had a look here: https://github.com/diydrones/ardupilot/milestones 

The AC 3.4.0 milestone is only 27% complete. I guess now that a lot of developers have had their support withdrawn by 3DR the dev speed might be slowed down a lot. I'm not sure really what's going on. In the end it is an open source project and therefore has no real 'deadlines' to meet.

It is a shame, though. I was eagerly awaiting the EKF2 and boat take off. I tried flying master under controlled conditions and it worked great. But I'm too scared to fly master in the wide open.

I've been flying 3.4 since Dec without issue. Although if anythings been done since Dec I guess the experience could be different. 

I'm not getting any Bata versions showing up on the MP after clicking "Beta firmwares" .

Reply to Discussion


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service