I've been flying with my large quad for almost a year, and I've never had an issue with the motors, until a couple of days ago. The quad was flying in auto mode in an area where I have already tried a few times, and it was behaving correctly. Then, when it was going back home, it reached one of the last waypoints and I saw the copter loosing power and then suddenly crashing.

I suspect the issue was that one ESC was not giving enough power to the motor, as seen in this part of the log. I can see that M3 tries to go high and saturates at its highest point, while M4 goes down to compensate and also saturates at its lowest point. Is my reasoning correct?

Just for reference, I use U7 280KV Motors and 40A ESCs. I would appreciate if you could analyze the flight log since I can't find any other cause for the sudden crash.

Here is the log.


Views: 196

Reply to This

Replies to This Discussion

I would really appreciate some opinion on what happened based on the flight log posted, since I think it would be useful to have a fresh pair of eyes looking into this issue.

Thanks a lot again.

yes, something, likely an ESC , worked "randomly"  , seems like more and less, not hetting full throttle demand, just making it hard to control:

Reply to Discussion


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service